Not sure you are still working on in. Just in case I post my complete test config. I noted several differences to the config above.
It took me quite a while until everything was working as expected. But I was not familiar with MT, at all. So there might be lots of room for improvement. Just let me know.
My main goal was to use the switch chip of the CRS125 for some VLANS and connect every VLAN to a specific WLAN from the wAP ac via CAPsMAN.
I think it would not make much sense to use the CRS without the switching chip. If everything has to go through the CPU its getting very slow. CPU is weak and Bandwith to the CPU is 1 Gbit/s. (learned here:
https://www.youtube.com/watch?v=LoZzt04Ixw0 )
My findings:
- use only one master port on the CRS! But you do NOT need to add all 24 ports!
- Using a switched trunk port for the wAP might work with manual config. I saw no way to get it done with CAPsMAN.
- I had to put the masterport in a bridge to allow IP traffic to/from VLANs (seems that makes the connection to the CPU)
The test config itself:
- 'admin' specifies the network with the right to do everything
- 'multimedia' is for guests, IosT, video server... its not allowed in 'admin'
- 'admin_service_access' might we ignored. I build it because playing around with the VLAN config threw me out one time too often (serial cable arrived today....)
- no further sec measurements taken until yet.
- using CAPsMAN provisioning would be the next logical step.
Would be great to hear some advice how to further improve the setup. Preferably you have a working config. That's because I read a lot of posts/tutorials/wikis and none had a working CRS/switching/VLAN/CAPsMAN/wAP combi.
# feb/22/2017 23:17:28 by RouterOS 6.39rc35
# config with adapted IPs/MACs/PWs
#
/interface bridge
add name=bridge-admin
add name=bridge-multimedia
/interface ethernet
set [ find default-name=ether1 ] name=e1-sw1master-admin
set [ find default-name=ether2 ] master-port=e1-sw1master-admin name=\
e2-sw1-multimedia
set [ find default-name=ether3 ] master-port=e1-sw1master-admin name=\
e3-sw1-admin
set [ find default-name=ether4 ] master-port=e1-sw1master-admin name=\
e4-sw1-multimedia
set [ find default-name=ether5 ] master-port=e1-sw1master-admin name=\
e5-sw1-trunk
set [ find default-name=ether6 ] master-port=e1-sw1master-admin name=\
e6-sw1-multimedia
set [ find default-name=ether7 ] master-port=e1-sw1master-admin name=\
e7-sw1-trunk
set [ find default-name=ether8 ] master-port=e1-sw1master-admin name=\
e8-sw1-multimedia
set [ find default-name=ether9 ] name=e9-wlan
set [ find default-name=ether10 ] name=e10-wlan
set [ find default-name=ether11 ] name=e11-wlan
set [ find default-name=ether12 ] name=e12-wlan
set [ find default-name=ether13 ] name=e13
set [ find default-name=ether14 ] name=e14
set [ find default-name=ether15 ] name=e15_admin_service_access
set [ find default-name=ether16 ] name=e16
set [ find default-name=ether17 ] name=e17
set [ find default-name=ether18 ] name=e18_internet
set [ find default-name=ether19 ] name=e19
set [ find default-name=ether20 ] name=e20
set [ find default-name=ether21 ] name=e21
set [ find default-name=ether22 ] name=e22
set [ find default-name=ether23 ] name=e23
set [ find default-name=ether24 ] name=e24
/interface vlan
add interface=e1-sw1master-admin name=vlan10-admin vlan-id=10
add interface=e1-sw1master-admin name=vlan20-multimedia vlan-id=20
/caps-man configuration
add channel.band=2ghz-b/g/n channel.extension-channel=Ce channel.frequency=\
2417 channel.width=20 country=germany datapath.arp=enabled \
datapath.bridge=bridge-admin datapath.client-to-client-forwarding=no \
datapath.local-forwarding=no mode=ap multicast-helper=default name=\
cfg_admin security.authentication-types=wpa2-psk security.encryption=\
aes-ccm security.group-encryption=aes-ccm security.passphrase=yourpass1 \
ssid=xt32
add country=germany datapath.bridge=bridge-multimedia \
datapath.local-forwarding=no mode=ap multicast-helper=full name=\
cfg_multimedia security.authentication-types=wpa2-psk \
security.encryption=aes-ccm security.group-encryption=aes-ccm \
security.passphrase=yourpass2 ssid=xt32guest
add channel.band=5ghz-a/n/ac channel.width=20 country=germany datapath.arp=\
enabled datapath.bridge=bridge-admin \
datapath.client-to-client-forwarding=no datapath.local-forwarding=no \
mode=ap multicast-helper=default name=cfg_admin_5GHz \
security.authentication-types=wpa2-psk security.encryption=aes-ccm \
security.group-encryption=aes-ccm security.passphrase=yourpass1 ssid=xt32
/caps-man interface
add configuration=cfg_admin disabled=no l2mtu=1600 mac-address=\
6C:3B:6B:7E:C5:43 master-interface=none name=cap1-2GH radio-mac=\
6C:3B:6B:7E:C5:43
add configuration=cfg_multimedia configuration.mode=ap disabled=no l2mtu=1600 \
mac-address=6E:3B:6B:7E:C5:43 master-interface=cap1-2GH name=\
cap1-2GH-guest radio-mac=00:00:00:00:00:00
add configuration=cfg_admin_5GHz disabled=no l2mtu=1600 mac-address=\
6C:3B:6B:7E:C5:42 master-interface=none name=cap1-5GH radio-mac=\
6C:3B:6B:7E:C5:42
add configuration=cfg_admin disabled=no l2mtu=1600 mac-address=\
6C:3B:6B:87:8E:36 master-interface=none name=cap2--2GH radio-mac=\
6C:3B:6B:87:8E:36
add configuration=cfg_multimedia disabled=no l2mtu=1600 mac-address=\
6E:3B:6B:87:8E:36 master-interface=cap2--2GH name=cap2-2GH-guest \
radio-mac=00:00:00:00:00:00
add configuration=cfg_admin_5GHz disabled=no l2mtu=1600 mac-address=\
6C:3B:6B:87:8E:35 master-interface=none name=cap2-5GH radio-mac=\
6C:3B:6B:87:8E:35
add configuration=cfg_admin disabled=no l2mtu=1600 mac-address=\
6C:3B:6B:7E:C5:07 master-interface=none name=cap3-2GH radio-mac=\
6C:3B:6B:7E:C5:07
add configuration=cfg_multimedia disabled=no l2mtu=1600 mac-address=\
6E:3B:6B:7E:C5:07 master-interface=cap3-2GH name=cap3-2GH-guest \
radio-mac=00:00:00:00:00:00
add configuration=cfg_admin_5GHz disabled=no l2mtu=1600 mac-address=\
6C:3B:6B:7E:C5:06 master-interface=none name=cap3-5GH radio-mac=\
6C:3B:6B:7E:C5:06
/ip pool
add name=admin ranges=172.16.10.20-172.16.10.200
add name=multimedia ranges=172.16.20.20-172.16.20.200
add name=dhcp_pool7 ranges=169.254.110.10-169.254.110.200
/ip dhcp-server
add address-pool=multimedia disabled=no interface=bridge-multimedia name=\
dhcp-multimedia
add address-pool=dhcp_pool7 disabled=no interface=e15_admin_service_access \
name=dhcp_admin_service
add address-pool=admin disabled=no interface=bridge-admin name=dhcp-admin
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes
/caps-man manager interface
add disabled=no
/interface bridge port
add bridge=bridge-multimedia interface=vlan20-multimedia
add bridge=bridge-admin interface=vlan10-admin
/interface ethernet switch egress-vlan-tag
add tagged-ports=e5-sw1-trunk,e7-sw1-trunk,switch1-cpu vlan-id=10
add tagged-ports=e5-sw1-trunk,e7-sw1-trunk,switch1-cpu vlan-id=20
/interface ethernet switch egress-vlan-translation
add customer-vid=10 customer-vlan-format=untagged-or-tagged new-customer-vid=\
0 ports=e1-sw1master-admin,e3-sw1-admin service-vlan-format=\
untagged-or-tagged
add customer-vid=20 customer-vlan-format=untagged-or-tagged new-customer-vid=\
0 ports=\
e2-sw1-multimedia,e4-sw1-multimedia,e6-sw1-multimedia,e8-sw1-multimedia \
service-vlan-format=untagged-or-tagged
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=e1-sw1master-admin,e3-sw1-admin
add customer-vid=0 new-customer-vid=20 ports=\
e2-sw1-multimedia,e4-sw1-multimedia,e6-sw1-multimedia,e8-sw1-multimedia
/interface ethernet switch vlan
add comment="multimedia VLAN" ports="e2-sw1-multimedia,e4-sw1-multimedia,e5-sw\
1-trunk,e6-sw1-multimedia,e7-sw1-trunk,e8-sw1-multimedia,switch1-cpu" \
vlan-id=20
add comment="admin VLAN" ports=\
e1-sw1master-admin,e3-sw1-admin,e5-sw1-trunk,e7-sw1-trunk,switch1-cpu \
vlan-id=10
/ip address
add address=192.168.2.12/24 interface=e18_internet network=192.168.2.0
add address=172.16.10.1/24 interface=bridge-admin network=172.16.10.0
add address=172.16.20.1/24 interface=bridge-multimedia network=172.16.20.0
add address=169.254.110.1/16 interface=e15_admin_service_access network=\
169.254.0.0
/ip dhcp-server network
add address=169.254.0.0/16 gateway=169.254.110.1
add address=172.16.10.0/24 dns-server=172.16.10.1 gateway=172.16.10.1
add address=172.16.20.0/24 dns-server=172.16.20.1 gateway=172.16.20.1
/ip dns
set allow-remote-requests=yes servers=\
85.214.20.141,213.73.91.35,8.8.8.8,8.8.4.4
/ip firewall filter
add action=accept chain=input connection-state=established,related
add action=accept chain=input in-interface=bridge-admin
add action=accept chain=input in-interface=bridge-vlan
add action=accept chain=input dst-address=!172.16.10.0/24 in-interface=\
bridge-multimedia
add action=accept chain=input in-interface=e15_admin_service_access
add action=log chain=input log=yes log-prefix=rejected->
add action=reject chain=input reject-with=icmp-admin-prohibited
add action=accept chain=forward connection-state=established,related
add action=accept chain=forward in-interface=bridge-admin
add action=accept chain=forward in-interface=bridge-vlan
add action=accept chain=forward in-interface=bridge-multimedia protocol=icmp
add action=accept chain=forward in-interface=bridge-multimedia out-interface=\
e18_internet protocol=tcp
add action=accept chain=forward in-interface=bridge-multimedia out-interface=\
e18_internet protocol=udp
add action=accept chain=forward connection-state="" in-interface=\
e15_admin_service_access
add action=log chain=forward log=yes log-prefix=rejected->
add action=reject chain=forward reject-with=icmp-admin-prohibited
/ip firewall nat
add action=masquerade chain=srcnat comment="internet access" out-interface=\
e18_internet src-address=172.16.10.0/24
add action=masquerade chain=srcnat comment="internet access" out-interface=\
e18_internet src-address=172.16.20.0/24
add action=masquerade chain=srcnat comment="Service NAT" out-interface=\
e18_internet src-address=169.254.0.0/16
/ip route
add distance=1 gateway=192.168.2.1
/system clock
set time-zone-name=Europe/Berlin
/system ntp client
set enabled=yes primary-ntp=192.53.103.108