Community discussions

MikroTik App
 
MRACHINI
just joined
Topic Author
Posts: 10
Joined: Fri Feb 26, 2016 12:53 am

Multi PPTP Over Multi PPPOE

Thu Apr 06, 2017 11:55 pm

Hey,

so I have multiple PPPOE interfaces, 4 to be exact, and I want to connect 4 different PPTP clients, to the same PPTP Server, and I want each PPTP client to connect over one of the PPPOE interfaces.

how can I do that?
Last edited by MRACHINI on Tue Apr 11, 2017 10:16 am, edited 1 time in total.
 
idlemind
Forum Guru
Forum Guru
Posts: 1146
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: Multi PPTP Over Multi PPPOE

Sun Apr 09, 2017 6:28 pm

I'd just add a /32 route for each IP used in "connect-to" portion of the PPTP client interface.

#1
/ip route add dst-address=1.1.1.1/32 gateway=IPofTheOtherSideofThePPoEYouWantTosUse
/interface pptp-client add connect-to=1.1.1.1
#2
/ip route add dst-address=2.2.2.2/32 gateway=IPofTheOtherSideofThePPoEYouWantTosUse
/interface pptp-client add connect-to=2.2.2.2
etc ...
 
MRACHINI
just joined
Topic Author
Posts: 10
Joined: Fri Feb 26, 2016 12:53 am

Re: Multi PPTP Over Multi PPPOE

Tue Apr 11, 2017 10:09 am

I'd just add a /32 route for each IP used in "connect-to" portion of the PPTP client interface.

#1
/ip route add dst-address=1.1.1.1/32 gateway=IPofTheOtherSideofThePPoEYouWantTosUse
/interface pptp-client add connect-to=1.1.1.1
#2
/ip route add dst-address=2.2.2.2/32 gateway=IPofTheOtherSideofThePPoEYouWantTosUse
/interface pptp-client add connect-to=2.2.2.2
etc ...
That would work fine if i had each PPTP client connect to PPTP servers with different IPs,
I updated the original post, I forgot to mention that i want to connect all pptp clients to the same PPTP server :(, but over different PPPOEs.

Who is online

Users browsing this forum: aljay13, dd2594mt, pmh, TOzzy and 48 guests