One of the links is very limited. I'd like to run PCQ to give equal use to all traffic over that link. I'm having a hard time getting PCQ to function as expected. I don't want to use an address-list (I want it to just balance all IPs connected), but I'm having a hard time getting any of these to work.
Is there a straight forward way to just PCQ a single port with a specific max-limit? [I cannot mark traffic coming in another port because traffic comes in and out of several ports and is then routed at this location.]
Here is my config using an address list... it is getting most of the upload traffic, but only 10% of the download traffic hits the queue:
Code: Select all
/ip firewall mangle
add action=mark-packet chain=postrouting comment=\
"PTP1 Download Marked by Address List" new-packet-mark=Mark_PTP1_down \
passthrough=yes src-address-list=PTP_1_Addresses
add action=mark-packet chain=prerouting comment=\
"PTP1 Upload Marked by Address List" new-packet-mark=Mark_PTP1_up \
passthrough=yes src-address-list=PTP_1_Addresses
/queue type
add kind=pcq name=PCQ_PTP1_download pcq-classifier=dst-address
add kind=pcq name=PCQ_PTP1_upload pcq-classifier=src-address
/queue tree
add max-limit=10500k name=PTP1_download packet-mark=Mark_PTP1_down \
parent=global queue=PCQ_PTP1_download
add max-limit=2500k name=PTP1_upload packet-mark=Mark_PTP1_up \
parent=global queue=PCQ_PTP1_upload