:global check [/interface wireless registration-table get 0 rx-rate ]
:log info [:pick $check 0 3 ]
/queue simple set 0 max-limit=([:pick $check 0 3 ]-0.XX)
First can I ask where did you get this info ?the key in AP (NV2) performance is always that
- the lowest signal client/data rate is in control of the total throughput.
so when a cpe maxes out on the connected datarate, it takes down the overall throughput of the AP
the way to avoid this is, is to hard set the queue on the client to lets say 80% of the possible wireless data rate and so protect the AP from dropping throughput.
what is the way to go here, write an script for cpe, or implement this in NV2 protocol on the station/cpe side.
I have to disagree with this statement how can this occur on a TDMA wireless protocol (NV2),the key in AP (NV2) performance is always that
- the lowest signal client/data rate is in control of the total throughput.
so when a cpe maxes out on the connected datarate, it takes down the overall throughput of the AP
First can we really compare Cisco Meraki to Mikrotik NV2!
/queue simple
add max-limit=10M/10M name=queue1 target=wlan1
{
:local RX [/interface wireless registration-table get 0 rx-rate ];
:local QS [:pick $RX 0 [:find $RX "M"]];
/queue simple set 0 max-limit=((($QS / 10)*8)."M")
}
@hengst I am sorry but cannot agree with your statement " - the lowest signal client/data rate is in control of the total throughput." is just not accurate, It maybe accurate for 802.11 but certainly not for NV2 TDMA because I have had faulty CPE's using a data rate of 1Mbps and only the customer with that very low data rate was complaining while none of the rest of other clients registered to that AP complained ?the key in AP (NV2) performance is always that
- the lowest signal client/data rate is in control of the total throughput.
so when a cpe maxes out on the connected datarate, it takes down the overall throughput of the AP
These might have suffered from other problems, i dont think you should compare them to this topic/issue .Please check ;
viewtopic.php?f=7&t=128415
viewtopic.php?f=7&t=126028
{
:local RX [/interface wireless registration-table get 0 rx-rate ];
:if ([:find $RX "."]>=1 ) do={:set $RX ( [:pick $RX 0 [:find $RX "."]]+1 )} else={:set $RX [:pick $RX 0 [:find $RX "M"]]};
/queue simple set 0 max-limit=((($RX * 8) / 10)."M");
}
:log warning ("queue set to " . ((($RX * 8) / 10)."M"));
{
:local CX [/interface wireless registration-table get 0 rx-ccq ];
/queue simple set 0 max-limit=((($CX * 5) / 10)."M");
}
/queue interface
set wlan1 queue=only-hardware-queue
i played with that a lot.nice lets try remove all queue and try set only hardware queueCode: Select all/queue interface set wlan1 queue=only-hardware-queue
let me know the results.
many thanks
It is encouraging to read you state this approach makes a big difference, howeverThnx ADahi , think you make magic happen here.
after some testing i found using ccq is a better approach
one can play with the factor "5" , ideal would be that its dynamic to the ccq.Code: Select all{ :local CX [/interface wireless registration-table get 0 rx-ccq ]; /queue simple set 0 max-limit=((($CX * 5) / 10)."M"); }
so if ccq is 20%, , the divide number would be 1 for example, and if ccq is 100% divide would be 9.
i see big improvements in test setup.
such a simple solution that makes big difference by preventing a client with low ccq degrading AP overall throughput.
now the script need to be fine tuned and run with scheduler or should it be looped script and only change queue if needed ?
also it needs to set up and down limits according to ccq up/down rates.
but it is big improvement for sure to AP throughput.
@Mikrotik programmers. is it not possible to integrate this approach in NV2 ?
Is it possible to post before and after results when using the script?i played with that a lot.nice lets try remove all queue and try set only hardware queueCode: Select all/queue interface set wlan1 queue=only-hardware-queue
let me know the results.
many thanks
when doing so its very hard to predict the behavior ,
bottom line is that the connection how is maxing out , is the bottleneck for all others.
when using the script as it is at this point makes it already prevent clients maxing out there connection for whatever reason.
It is encouraging to read you state this approach makes a big difference, however
(1) As ROS is mostly software based any extra function(s) which require constant CPU cycles which will result in a drop in performance with misleading results?
(2) NV2 only calculates CCQ when traffic is flowing, so will you have a cut off (CCQ less than 20% - do not run script!)
{
:local CX [/interface wireless registration-table get [/interface wireless registration-table find interface="wlan1"] rx-ccq ];
:log info [$CX];
/queue simple set 0 max-limit=((($CX * 8) / 13)."M");
}
@ADahi
sorry to hijack the topic thread but I am looking for a script to detect when 1Mbps data rates are being used by a CPE and print to a file?
FYI@ADahi
sorry to hijack the topic thread but I am looking for a script to detect when 1Mbps data rates are being used by a CPE and print to a file?
really, you are "Forum Guru", I should learn from you
are you serious?
FYI@ADahi
sorry to hijack the topic thread but I am looking for a script to detect when 1Mbps data rates are being used by a CPE and print to a file?
really, you are "Forum Guru", I should learn from you
are you serious?
“Forum Guru” is a user (not staff) who has been helpful to other users? I have tried to be helpful to other users and this forum,
You will discover there is “Guru’s” (helpful users) in different sections like - Wireless networking, Scripting, forwarding protocols, ...etc.
And you will usually get good practical advice from them in those sections,
For me my main area of interest and forum activity has been Wireless Networking as a WISP user, my business has had me jumping from one technical area to another but maybe my New Year Resolution should be learning scripting in depth?
Great - Rather than continue on this thread (once again sorry for hijacking) can you check my post viewtopic.php?f=7&t=126028 this details the issue?FYI@ADahi
sorry to hijack the topic thread but I am looking for a script to detect when 1Mbps data rates are being used by a CPE and print to a file?
really, you are "Forum Guru", I should learn from you
are you serious?
“Forum Guru” is a user (not staff) who has been helpful to other users? I have tried to be helpful to other users and this forum,
You will discover there is “Guru’s” (helpful users) in different sections like - Wireless networking, Scripting, forwarding protocols, ...etc.
And you will usually get good practical advice from them in those sections,
For me my main area of interest and forum activity has been Wireless Networking as a WISP user, my business has had me jumping from one technical area to another but maybe my New Year Resolution should be learning scripting in depth?
ok, how can I help
explain your plan
yes i played/ing a lot with those settings every day. fixed 80% would be my choice.did you use this before?
0 mac-address=00:00:00:00:00:00 interface=wlan1 signal-range=-60..120
authentication=yes forwarding=no ap-tx-limit=50000000 client-tx-limit=0
private-algo=none private-key="" private-pre-shared-key=""
management-protection-key="" vlan-mode=no-tag vlan-id=1
1 mac-address=00:00:00:00:00:00 interface=wlan1 signal-range=-75..-60
authentication=yes forwarding=no ap-tx-limit=10000000
client-tx-limit=10000000 private-algo=none private-key=""
private-pre-shared-key="" management-protection-key="" vlan-mode=no-tag
vlan-id=1
2 mac-address=00:00:00:00:00:00 interface=wlan1 signal-range=-85..-75
authentication=yes forwarding=no ap-tx-limit=1000000
client-tx-limit=1000000 private-algo=none private-key=""
private-pre-shared-key="" management-protection-key="" vlan-mode=no-tag
vlan-id=1