What's wrong with it? Have you even read o'reilly's book on securing cisco routers? So why should we care less for MikroTik routers???mt99, do you really expect that every owner of every MikroTik device would follow such a lengthy advise?
really, the only thing that can be done is using good default settings. then some people might improve or customize them,
and those that do not know or do not care are not left vulnerable.
yes it is, but the problem is not the people who are familiar with RouterOS or security.If you are familiar with mikrotik ros its a matter of 5-10 mins to secure your router with the above recomendations.
mt99, do you really expect that every owner of every MikroTik device would follow such a lengthy advise?
Code: Select all
# initial deployment script built off of RouterOS 6.41
#
# remove the hashtags below this line after you've set your values
# set your time zone below
# /system clock
# set time-zone-autodetect=no time-zone-name=Country/City
/ip firewall filter
# ensure this is at the top of the rule list
add action=accept chain=input comment="allow admin access to router from authorized clients" dst-port=22222,8888,8291 in-interface-list=!WAN protocol=tcp
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set api-ssl disabled=yes
set ssh port=22222
set www port=8888
# change the below to your admin network
# set winbox address=192.168.88.0/24
# set your preferred admin username below
# /user set 0 name=myuser
/ip cloud
set update-time=no
/ip neighbor discovery-settings
set discover-interface-list=!WAN
/ip ssh
set strong-crypto=yes
/tool bandwidth-server
set enabled=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
To my understanding, RouterOS x86 and CHR are definitely affected, but since you cannot run your own binaries there they cannot be exploited (unless there are other vulnerabilities that allow one to execute arbitrary code on a router). ARM devices may also be affected, but the same "exploitability" considerations apply.Is mikrotik affected by Spectre and meltdown bugs?
But... why?- don't use the default admin user
if you know the username, it is very easy to brute-force simple passwords. if you don't know the username, brute-force is basically out of the question.But... why?- don't use the default admin user
https://en.wikipedia.org/wiki/Security_ ... _obscurityif you know the username, it is very easy to brute-force simple passwords. if you don't know the username, brute-force is basically out of the question.
?use a strong password
It merely squares the search space.if you know the username, it is very easy to brute-force simple passwords. if you don't know the username, brute-force is basically out of the question.
[admin@mikrotik] > /user ssh-keys print
Flags: R - RSA, D - DSA
# USER BITS KEY-OWNER
0 R admin 2048 user@host
[admin@mikrotik] > /ip ssh set always-allow-password-login=no
I think the typical scenario is:You see there is already a default firewall, it got removed anyway.
Will be very nice if mikrotik add to the dst-address-type an other option like "local-network" which will refers to all locally connected networks, like the local parameter but instead of using only the local address use the netmask. This rule can be changed and only who is connected to the local networks connected to the router will have access .Code: Select all
/ip firewall filter
# ensure this is at the top of the rule list
add action=accept chain=input comment="allow admin access to router from authorized clients" dst-port=22222,8888,8291 in-interface-list=!WAN protocol=tcp
That is just a different approach to what is already there. The current firewall uses interface lists to group interfaces in categories like WAN and LAN, and filters according to that.Will be very nice if mikrotik add to the dst-address-type an other option like "local-network" which will refers to all locally connected networks, like the local parameter but instead of using only the local address use the netmask.
True, but that protection is absolutely zero. It only protects you against people sniffing the password, which is unlikely to beOne of the first steps I take when deploying Mikrotik kit, is generating a local certificate, signing it locally and enabling HTTPS with it, disabling HTTP. This gives the same level of protection that SSH affords.
HTTPS per default rather than HTTP would be on the same basis SSH is used rather than eg telnet.True, but that protection is absolutely zero. It only protects you against people sniffing the password, which is unlikely to beOne of the first steps I take when deploying Mikrotik kit, is generating a local certificate, signing it locally and enabling HTTPS with it, disabling HTTP. This gives the same level of protection that SSH affords.
the scenario of the attacks. The problem is keeping the default (empty) password or using an obvious password that can be
found by trying a small list of common passwords. The https is going to do absolutely nothing about that.
A better protection would be to use a certificate for SSH login instead of a password, but I don't think that is possible with
https right now.
Those won't buy a MT device in the first place...yes it is, but the problem is not the people who are familiar with RouterOS or security.If you are familiar with mikrotik ros its a matter of 5-10 mins to secure your router with the above recomendations.
the problem is the users who buy a device, plug it in, look on youtube for a movie made by another beginner on how to setup PPPoE, and stop doing anything once they can surf the web.
THAT is the category of users who now got hacked. it is useless to write about how to secure a router for those people, they won't read it and probably won't understand it.
to keep those people safe, the only thing that works is security by default and mandatory security, like unique default password or mandatory password change on first logon.
and keep always-allow-password-login set to no:
Password login is no longer possibly and brute force attack can never succeed.Code: Select all[admin@mikrotik] > /ip ssh set always-allow-password-login=no
That's true, but I did not state anything else. If you look at my post this should be clear. Please do not cite just half of important information.Regarding this, that is not actualy the case.and keep always-allow-password-login set to no:
Password login is no longer possibly and brute force attack can never succeed.Code: Select all[admin@mikrotik] > /ip ssh set always-allow-password-login=no
Even with this option set to no (which is by the way already set by default), the SSH password will always work, unless you put the SSH public key, only then it will not work.
Well, it allows password login even if an SSH key is uploaded. It's up to you whether or not that meets your security requirements.The only way to use SSH key and the password, is to set this option to yes.
Is it safe, to have SSH key and always-allow-password-login=yes?
add chain=input action=accept protocol=udp dst-port=546 src-address=fe80::/16 comment="accept DHCPv6-Client prefix delegation.
add chain=input action=accept protocol=udp dst-port=546 src-address=fe80::/10 comment="accept DHCPv6-Client prefix delegation.
So i need to set some random password for those ssh users that i want ONLY ssh key login so that won't get in other services (winbox,telnet,..) without password ?"to have SSH key and always-allow-password-login=yes?"
Well, it allows password login even if an SSH key is uploaded. It's up to you whether or not that meets your security requirements.
Hi,yes it is, but the problem is not the people who are familiar with RouterOS or security.If you are familiar with mikrotik ros its a matter of 5-10 mins to secure your router with the above recommendations.
the problem is the users who buy a device, plug it in, look on youtube for a movie made by another beginner on how to setup PPPoE, and stop doing anything once they can surf the web.
THAT is the category of users who now got hacked. it is useless to write about how to secure a router for those people, they won't read it and probably won't understand it.
to keep those people safe, the only thing that works is security by default and mandatory security, like unique default password or mandatory password change on first logon.
What I think is, automate what MikroTik has said for a million time: https://help.mikrotik.com/docs/display/ ... our+routerHi,yes it is, but the problem is not the people who are familiar with RouterOS or security.If you are familiar with mikrotik ros its a matter of 5-10 mins to secure your router with the above recommendations.
the problem is the users who buy a device, plug it in, look on youtube for a movie made by another beginner on how to setup PPPoE, and stop doing anything once they can surf the web.
THAT is the category of users who now got hacked. it is useless to write about how to secure a router for those people, they won't read it and probably won't understand it.
to keep those people safe, the only thing that works is security by default and mandatory security, like unique default password or mandatory password change on first logon.
maybe is better to disable default setting and to remove quick set. RouterOS and MikroTik HW should be configured by technical specialist and not by consumer people who does not understand security. This end user people want something that is "click" and "click" ..for this they could buy other products, but not MikroTik.
In current world more people then before know that security is important.
I personally hate that in MikroTik is quick set to set some default setting and is possible by clicking to set "something" that end user does not understand.
I always reset default configuration to have "no configuration" when I am preparing device for my customers.
When there will be no quick set and no default config - simply nothing - it will not do anything unless you know how to setup.
For this reason usually is good for that people who do not know how to setup to find somebody who could setup it.
I understand that MikroTik wants to sell to everybody, but do you really want to be some horrible technology like very cheap units from TP-link, Ubiquity or others ?
Better is to have some option that everybody who buy MikroTik device have to contact some specialist to set it for him - it will make business good for all of us who are technical specialists and know about it.
I thing there could be some list of specialist(not only certified) and customer could get some advantage with new purchased device which will motivate him or really press him to contact somebody.
There could be some form of discount on first setup from specialist or other promo - I thing it is good theme for MikroTik marketing department.
From my point of view I still see MikroTik devices as something more than cheap router from online shop and something that should be set by some technical specialist.
What do you think of this?
Remove the feature if you don't want it to be used.@DarkNate ... why you quote whole previous post just to add one line sentence? Why you do not "post reply"?
Please read this viewtopic.php?p=864613#p864613 and link in my signature.
Addition when locking:
Lock but able to reset (new), to those who not want to show/edit the config. Hardware theft/reuse is still available
Lock and no reset (current), only access/reuse when the correct timeframe is known.
Press what button?to enable such settings you need to briefly press the button
Well, the "protected routerboot" with these times is there exactly to prevent that. It is for routers that are not owned by you but are placed in a location where you have physical access.I concur with writers above.
once someone has physical access to a router, it should always be resetable ...
"the button". also known as the "reset button". some routers have 2 buttons, but all of them have at least 1 I think.Press what button?to enable such settings you need to briefly press the button