Place here the output of "/export hide-sensitive" from both routers, and replace public addresses, if any, with some x.x.x.x but in a way that the same address is replaced by same letters everywhere.
OK.
HQ Site with Public IP Static:
jan/06/1970 05:55:24 by RouterOS 6.23
# software id = YZED-T8KD
#
/interface bridge
add admin-mac=4C:5E:0C:6D:0D:43 auto-mac=no name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
ether4-slave-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
disabled=no distance=indoors frequency=auto l2mtu=1600 mode=ap-bridge \
wireless-protocol=802.11
/ip neighbor discovery
set ether1-gateway discover=no
/interface ethernet
set [ find default-name=ether5 ] master-port=ether2-master-local name=Ethernet5
/ip ipsec proposal
add auth-algorithms=md5 enc-algorithms=3des name=proposal1
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp_pool1 ranges=192.168.20.5-192.168.20.50
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether4-slave-local \
lease-time=3d name=dhcp1 relay=192.168.20.250
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=\
ether2-master-local network=192.168.88.0
add address=192.168.22.1/24 interface=ether4-slave-local network=192.168.22.0
add address=XXX.XX.XX.33/29 interface=ether1-gateway network=XXX.XX.XX.32
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no \
interface=ether1-gateway
/ip dhcp-server network
add address=192.168.20.0/24 dns-server=192.168.20.250 gateway=192.168.20.250 \
netmask=24
add address=192.168.88.0/24 comment="default configuration" dns-server=\
192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=XXX.XX.XX.33
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input dst-port=8291 protocol=tcp
add chain=input dst-port=500 protocol=udp
add chain=input dst-port=4500 protocol=udp
add chain=input protocol=ipsec-ah
add chain=input protocol=ipsec-esp
add action=drop chain=input protocol=tcp
/ip firewall nat
add chain=srcnat dst-address=192.168.10.0/24 src-address=192.168.22.0/24
add action=masquerade chain=srcnat comment="default configuration" disabled=yes \
out-interface=ether1-gateway
add action=masquerade chain=srcnat
/ip ipsec peer
add comment=myIPsec enc-algorithm=3des generate-policy=port-override \
hash-algorithm=md5 send-initial-contact=no
/ip ipsec policy
add comment=myIPsec dst-address=192.168.10.0/24 proposal=proposal1 \
sa-dst-address=0.0.0.0 sa-src-address=XXX.XX.XX.33 src-address=\
192.168.22.0/24 tunnel=yes
/ip route
add distance=1 gateway=XXX.XX.XX.33
/system leds
set 0 interface=wlan1
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=Ethernet5
add interface=wlan1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=Ethernet5
add interface=wlan1
add interface=bridge-local
Remote Site with Dynamic Public IP:
jan/29/2018 14:33:21 by RouterOS 6.25
# software id = 5DXW-DVVT
#
/interface bridge
add comment="Bridge porta eth4 e wlan1" name=bridge-e4-w1
/interface ethernet
set [ find default-name=ether2 ] comment="WAN1 - ADSL"
set [ find default-name=ether3 ] comment="WAN2 - Rilancio in fibra"
/ip neighbor discovery
set ether2 comment="WAN1 - ADSL"
set ether3 comment="WAN2 - Rilancio in fibra"
set bridge-e4-w1 comment="Bridge porta eth4 e wlan1"
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
management-protection=allowed mode=dynamic-keys name=profile1 \
supplicant-identity=""
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country=italy dfs-mode=\
no-radar-detect disabled=no l2mtu=2290 mode=ap-bridge security-profile=\
profile1 ssid=TCCS wireless-protocol=802.11
/ip ipsec proposal
add auth-algorithms=md5 enc-algorithms=3des name=proposal1
/ip pool
add name=dhcp_pool1 ranges=192.168.10.2-192.168.10.254
add name=dhcp_pool2 ranges=192.168.10.2-192.168.10.254
add name=dhcp_pool_LAN ranges=192.168.10.2-192.168.10.160
/ip dhcp-server
add address-pool=dhcp_pool_LAN disabled=no interface=bridge-e4-w1 lease-time=\
3d name=dhcp_LAN
/ip ipsec mode-config
add address-pool=dhcp_pool_LAN name=cfg1 split-include=192.168.10.0/24
/interface bridge port
add bridge=bridge-e4-w1 interface=ether4
add bridge=bridge-e4-w1 interface=wlan1
/ip address
add address=192.168.88.1/24 interface=ether5 network=192.168.88.0
add address=192.168.10.1/24 interface=bridge-e4-w1 network=192.168.10.0
add address=152.62.81.114/24 interface=ether3 network=152.62.81.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=ether2
/ip dhcp-server network
add address=192.168.10.0/24 dns-server=192.168.10.1 gateway=192.168.10.1
/ip dns
set allow-remote-requests=yes servers=152.62.81.99,8.8.8.8
/ip dns static
add address=152.62.81.251 name=nas-01
add address=152.62.81.253 name=exchange
/ip firewall address-list
add address=192.168.88.0/24 list=LAN
add address=192.168.10.0/24 list=LAN
/ip firewall filter
add chain=input dst-port=500 protocol=tcp
add chain=input protocol=ipsec-ah
add chain=input protocol=ipsec-esp
add chain=input dst-port=4500 protocol=udp
add chain=input src-address-list=LAN
add chain=input comment="Accept established connections" connection-state=\
established
add chain=input comment="Accept related connections" connection-state=related
add action=drop chain=input comment="Drop invalid connections" \
connection-state=invalid
add chain=input comment=UDP protocol=udp
add chain=input comment="Allow limited pings" limit=50/5s,2 protocol=icmp
add action=drop chain=input comment="Drop excess pings" protocol=icmp
add chain=input comment="SSH for secure shell" dst-port=22 protocol=tcp
add chain=input comment=winbox dst-port=8291 protocol=tcp
add chain=input comment="From Mikrotikls network" src-address=\
159.148.172.192/28
add chain=input comment="From our private LAN" src-address-list=LAN
add action=log chain=input comment="Log everything else" log-prefix=\
"DROP INPUT"
add action=drop chain=input comment="Drop everything else"
add chain=forward comment="Traffic from/to the LAN" connection-state=new \
in-interface=bridge-e4-w1
add chain=forward comment="Traffic from/to the LAN" connection-state=new \
in-interface=ether5
add chain=forward comment="Accept established connections from/to the LAN" \
connection-state=established
add chain=forward comment="Accept related connections from/to the LAN" \
connection-state=related
add action=drop chain=forward comment="Drop everything else from/to the LAN" \
disabled=yes
add action=log chain=forward disabled=yes log-prefix="DROP FORWARD"
add action=log chain=output disabled=yes log-prefix="DROP OUTPUT"
/ip firewall nat
add chain=srcnat comment="IPsec traffic NAT bypass" dst-address=\
192.168.22.0/24 src-address=192.168.10.0/24
add action=masquerade chain=srcnat out-interface=ether2
add action=masquerade chain=srcnat out-interface=ether3
/ip ipsec peer
add address=XXX.XX.XX.33/32 comment=myIPsec enc-algorithm=3des \
hash-algorithm=md5
/ip ipsec policy
add comment=myIPsec dst-address=192.168.22.0/24 proposal=proposal1 \
sa-dst-address=XXX.XX.XX.33 sa-src-address=0.0.0.0 src-address=\
192.168.10.0/24 tunnel=yes
/system clock
set time-zone-name=Europe/Rome
/system identity
set name=RB951G-TCCS
/system leds
set 0 interface=wlan1
/system logging
add topics=ipsec
/system ntp client
set enabled=yes primary-ntp=193.204114.232 secondary-ntp=193.204.114.233