I have some problems ran into with my routeros 6.41 in terms of vlans.
This is where I am asking for help and support. And please let me say sorry for my english, I am a non native speaker.
Situation:
I have the following network architecture in mind and things do not really work as intended.
Code: Select all
Firewall---->VOIP Gateway
---->WAN
---->Switch---->NAS(120)
---->Computer(120)
---->Mikrotik(2,140,145)---->Device1(140)
---->Device2(140)
---->Device3(140)
---->Access Point(2,140,145)
vlan140 is for some devices connected to the mikrotik via lan. the vlan is vlan for internal wifi devices (they are in the same vlan140 in order to make them able communicating with each other)(192.168.140.0/24)
vlan145 is guest wifi only.(192.168.145.0/24)
vlans should be separated.
The mikrotik has the Ip 192.168.15.3.
Problem:
If I connect devices to the Port (e.g. for Device2) I get a DHCP assigned. The IP is from the wrong range, I get 192.168.15.xx instead of 192.168.140.xx.
It seems that those untagged ports are assigned to the wrong vlan.
Second problem: I cannot Ping the mikrotik from 120 vlan. Firewall allows the route. If I disconnect the mikrotik physically, ping status changes. but ping never has success.
I can ping the access point from vlan 120. access point and mikrotik are in the same vlan and subnet.
What I have done so far:
Access point has 2 wifi ssids (one 145 and one 140). dhcp is coming from firewall through the vlan and this works.
access point itself is connected to management vlan2 with fitting ip and this also seems to work.
switch has vlans enabled and ports are perpared (access, trunked)
firewall has dhcp pools per each vlan.
Question:
What am I doing wrong? Did I adjust the vlans on mikrotik correctly? I find it pretty confusing. I do not want to use any routing functions, just use it as a switch to separate networks. routing is done on the firwall machine.
this is my current setup:
Code: Select all
# nov/30/2017 04:09:57 by RouterOS 6.41
# software id = P42F-71TR
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number =xx
/interface ethernet
set [ find default-name=ether1 ] name=e1uplink
set [ find default-name=ether2 ] name=e2lan-hue
set [ find default-name=ether3 ] name=e3lan-rece
set [ find default-name=ether4 ] name=e4lan-raum
set [ find default-name=ether5 ] name=e5lan-ap poe-out=off
set [ find default-name=sfp1 ] disabled=yes
/interface bridge
add fast-forward=no name=br-lan
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
set [ find default-name=wlan2 ] ssid=MikroTik
/interface ethernet switch port
set 1 vlan-header=always-strip
set 2 vlan-header=always-strip
set 3 vlan-header=always-strip
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=br-lan interface=e1uplink
add bridge=br-lan interface=e2lan-hue
add bridge=br-lan interface=e3lan-rec
add bridge=br-lan interface=e4lan-raum
add bridge=br-lan interface=e5lan-ap
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface ethernet switch vlan
add independent-learning=no ports=e1uplink,e5lan-ap switch=switch1 vlan-id=2
add independent-learning=no ports=\
e1uplink,e2lan-hue,e3lan-rec,e4lan-raum,e5lan-ap switch=switch1 \
vlan-id=140
add independent-learning=no ports=e1uplink,e5lan-ap switch=switch1 vlan-id=\
145
/ip address
add address=192.168.15.3/24 interface=br-lan network=192.168.15.0
/ip dns
set allow-remote-requests=yes servers=192.168.15.1
/ip route
add comment="standardgatew" distance=1 \
gateway=192.168.15.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Berlin
/system identity
set name=MikroTik_EG
/system logging
add topics=debug,wireless
/system ntp client
set enabled=yes primary-ntp=137.250.121.254 secondary-ntp=194.25.134.196
[empy@MikroTik_EG] >