my name is Adrian and I need your help.
I am configuring simple queue for limiting the bandwidth of windows update download.
I configured it in a few steps:
> created an address list of windows update servers
> created 3 mark connection and 3 mark packet mangle rules with destination address list set to those addresses in connection mark and applied the connection mark in packet mark rules
> rules are for new, established and related conenctions
> created simple queue type with limitation
> applied the simple queue
Problem is, mangle is showing the traffic when I download the windows update, but not simple queue. I am including configs.
Here is my address list for windows updates:
Code: Select all
Here is address list:
/ip firewall address-list
add address=13.107.4.50 list=windows_update
add address=54.208.189.112 list=windows_update
add address=157.56.77.153 list=windows_update
add address=65.55.50.157 list=windows_update
add address=65.55.50.158 list=windows_update
add address=147.229.255.81 list=windows_update
add address=207.46.22.245 list=windows_update
add address=2.0.0.0/8 list=windows_update
add address=70.0.0.1 list=windows_update
add address=60.0.0.1 list=windows_update
add address=94.0.0.1 list=windows_update
add address=111.0.0.1 list=windows_update
add address=132.0.0.1 list=windows_update
add address=157.0.0.1 list=windows_update
add address=207.0.0.1 list=windows_update
add address=213.0.0.1 list=windows_update
Here are mangle rules;
/ip firewall mangle
add action=mark-connection chain=prerouting comment=\
"limit windows update established" connection-state=related \
dst-address-list=windows_update new-connection-mark=Win_Update \
passthrough=yes
add action=mark-connection chain=prerouting comment=\
"limit windows update related" connection-state=established \
dst-address-list=windows_update new-connection-mark=Win_Update \
passthrough=yes
add action=mark-connection chain=prerouting comment=\
"limit windows update new" connection-state=new dst-address-list=\
windows_update new-connection-mark=Win_Update passthrough=yes
add action=mark-packet chain=prerouting comment="win update established" \
connection-mark=Win_Update connection-state=established new-packet-mark=\
win_update passthrough=no
add action=mark-packet chain=prerouting comment="win update related" \
connection-mark=Win_Update connection-state=new new-packet-mark=\
win_update passthrough=no
add action=mark-packet chain=prerouting comment="win update new" \
connection-mark=Win_Update connection-state=related new-packet-mark=\
win_update passthrough=no
Here is simple queue
/queue simple
add name=queue_download_MS_update packet-marks=win_update priority=4/4 queue=\
default-small/PCQ_downloadMSUpdate target="" total-queue=default
Here is queue type
/queue type
add kind=pcq name=PCQ_downloadMSUpdate pcq-classifier=dst-address pcq-rate=7M
Best regards,
Adrian Bardossy