I am trying to write a script, which could just copy a local directory "/flash/umfiles" to "/umfiles" by using fetch tool from localhost to localhost
Code: Select all
:local LOCALfolder "flash/umfiles"
:local FTPserverAddress "192.168.88.1";
:local FTPuser "admin";
:local FTPpass "eplmmlsw";
:local FTPfolder "umfiles";
:foreach FILE in=[/file where name="$LOCALfolder"] do={
/tool fetch address="$FTPserverAddress" src-path="($LOCALfolder . $name)" user="$FTPuser" mode=ftp password="$FTPpass" dst-path=($FTPfolder . "$name") upload=yes;
}