I have a Routerboard HAP-AC with a fairly vanilla configuration.
For Internet, I am using a PPPOE client attached to VLAN 35. I connect, my machines behind the unit have Internet access and everything seems fine. However, the speed is considerably less than what I get directly connected to the providers router.
Diagram:
ISP->Fiber->TPLINK MC220L->Ethernet (ether1)->VLAN35->PPPOE
The provider informed me that 1500 is the MTU. In order to get that, I set 1520 on the VLAN and 1520 on the Ether1. I have tried with/with out that setting, it makes minimal difference.
I have plugged the fiber using the MiniGBIC into the HAP, I get the same results. I'd prefer to use the TPLINK as I know its not the issue (when I plug the ethernet into the providers router, I get good speed).
DSL Reports speed tests
providers modem:
http://www.dslreports.com/speedtest/31354324
http://www.dslreports.com/speedtest/31352958
http://www.dslreports.com/speedtest/31353684
mikrotik:
http://www.dslreports.com/speedtest/31486608
http://www.dslreports.com/speedtest/31493471
http://www.dslreports.com/speedtest/31486936
Code: Select all
# mar/29/2018 09:14:48 by RouterOS 6.41.2
# model = RouterBOARD 962UiGS-5HacT2HnT
/interface bridge
add fast-forward=no name=bridgeLocal
/interface ethernet
set [ find default-name=ether1 ] mtu=1520
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-eC disabled=no frequency=auto mode=ap-bridge name=VA3IAN-11 ssid=VA3IAN-11 wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-eCee disabled=no frequency=auto mode=ap-bridge name=VA3IAN-5G ssid=VA3IAN-5G wps-mode=disabled
/interface vlan
add interface=ether1 mtu=1520 name=vlan35 vlan-id=35
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan35 name=pppoe-out1 password=xxxxxxxxx use-peer-dns=yes user=b1xxxxx
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=XXXXXXXXXXXXXX
/ip pool
add name=dhcp ranges=192.168.2.100-192.168.2.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridgeLocal name=dhcp1
/interface bridge port
add bridge=bridgeLocal interface=ether2
add bridge=bridgeLocal interface=ether3
add bridge=bridgeLocal interface=ether4
add bridge=bridgeLocal interface=ether5
add bridge=bridgeLocal interface=VA3IAN-11
add bridge=bridgeLocal interface=VA3IAN-5G
/interface list member
add interface=pppoe-out1 list=WAN
add interface=bridgeLocal list=LAN
/ip address
add address=192.168.2.1/24 interface=bridgeLocal network=192.168.2.0
/ip dhcp-server network
add address=192.168.2.0/24 dns-server=192.168.2.1 domain=iang.internal gateway=192.168.2.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.2.1 name=router
add address=192.168.2.10 name=nas
/ip firewall filter
add action=drop chain=input comment="Drop Invalid connections" connection-state=invalid
add action=accept chain=input comment="Allow Established connections" connection-state=established
add action=accept chain=input comment="Allow ICMP" protocol=icmp
add action=accept chain=input in-interface=!pppoe-out1 src-address=192.168.0.0/16
add action=drop chain=input comment="Drop everything else"
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
/system clock
set time-zone-name=America/Toronto
/system identity
set name=router
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set vlan35 disabled=yes display-time=5s
set pppoe-out1 disabled=yes display-time=5s
set bridgeLocal disabled=yes display-time=5s
set VA3IAN-11 disabled=yes display-time=5s
set VA3IAN-5G disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2 disabled=yes display-time=5s
set ether3 disabled=yes display-time=5s
set ether4 disabled=yes display-time=5s
set ether5 disabled=yes display-time=5s
set sfp1 disabled=yes display-time=5s