Hi, What I suggested(Using a MetaRouter) should work.
Take into account that a MetaRouter is just a virtual router inside the main router. To configure the meta-router you can connect an ethernet cable to the assigned interface, Winbox will detect two routers in the same interface.
I will include a figure and the configuration, but you could still need some additional configuration.
However, I will post a simple working example based on the following scenario.
#*************************
#Main Router COnfiguration
#*************************
#Add a bridge, loopback(To connect the MainRouter to the MetaRouter)
/interface bridge
add name=local
/ip address
#Assign an IP address to the bridge(name=local) interface
add address=192.168.0.1/24 interface=local network=192.168.0.0
#Link to ISP 1
add address=192.168.100.2/24 interface=ether1 network=192.168.100.0
/metarouter
add name=mr1
/metarouter interface
#Assign the Ether9 interface to be used by the MetaRouter(In the metarouter the name will be Ether1)
add static-interface=ether9 virtual-machine=mr1 vm-mac-address=\
02:04:01:94:70:0D
#Assign the bridge(local) to the meta router(To connect the MainRouter to the MetaRouter)
#In the MetaRouter the interface name will be Ether2.
add dynamic-bridge=local dynamic-mac-address=02:B1:79:AB:31:93 type=dynamic \
virtual-machine=mr1 vm-mac-address=02:67:24:1F:76:8A
#*************************
#MetaRouter COnfiguracion
#*************************
/ip address
#Link to Main Router(Bridge local on main router)
add address=192.168.0.2/24 interface=ether2 network=192.168.0.0
#Link to ISP 2
add address=192.168.100.2/24 interface=ether1 network=192.168.100.0
/ip route
add distance=1 dst-address=0.0.0.0/32 gateway=192.168.100.1
#Nat All the traffic
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
If you need more details, let me know.
PD: Although this approach could solve your problem (also shows the capabilities of MetaRouter), for this specific case I would suggest (as other users do) changing the IPS's IP(if possible).