Hi, I am unsure if what I am seeing is what should be occuring so I will post below the scenario in the hope that someone can comment.
Simple setup, a gateway, an AP and a CPE
Gateway
/interface vlan
add interface=ether3_Lan name=vlan10 vlan-id=10
/ip pool
add name=pool_vlan10 ranges=10.0.10.2-10.0.10.254
/ip dhcp-server
add address-pool=pool_vlan10 disabled=no interface=vlan10 lease-time=30s name=dhcp_vlan10
/ip address
add address=10.0.10.1/24 interface=vlan10 network=10.0.10.0
/ip dhcp-server network
add address=10.0.10.0/24 dns-server=10.0.10.1 gateway=10.0.10.1
AP
/interface bridge
add name=bridge-vlan10 pvid=10 vlan-filtering=yes
/interface wireless
disabled=no mode=ap-bridge ssid=vlan10 vlan-id=10 vlan-mode=use-tag
/interface vlan
add interface=ether1 name=vlan10 vlan-id=10
/interface bridge port
add bridge=bridge-vlan10 interface=wlan1
add bridge=bridge-vlan10 interface=ether1
/interface bridge vlan
add bridge=bridge-vlan10 tagged=ether1,wlan1 vlan-ids=10
Now... the DHCP server successfully assigns IP address to the AP (10.0.10.2) and to the CPEs (10.0.10.x), everything seems to work as expected.
Try to access the AP with Winbox, all is good.
Now try to access the AP with mac telnet, nope, no go, wont connect.
Are these characteristics correct for the above setup ?
Thanks