Rough example,
See manual for more details
http://www.mikrotik.com/testdocs/ros/2.9/ip/route.php
*** Replace x.x.x.x with your gateway to the ISP of your choice... ***
/ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=HTTPForward passthrough=yes comment="" disabled=yes
Then add a route for the new marked routing...
/ip route add gateway=x.x.x.x routing-mark=HTTPForward comment="HTTP Traffic" disabled=no
Then add a route rule for the new routing...
/ip route rule add src-address=0.0.0.0/0 table=HTTPForward action=lookup