In 6.38.7 (bugfix), it works fine as follows:
Code: Select all
[admin@pppoe-server] > /ip ro pr ter where static
0 ADS dst-address=3.3.3.3/32 gateway=2.2.2.2 gateway-status=2.2.2.2 reachable via <pppoe-test> distance=1 scope=30 target-scope=10
1 A S dst-address=7.7.7.7/32 gateway=3.3.3.3 gateway-status=3.3.3.3 recursive via 2.2.2.2 <pppoe-test> distance=1 scope=40 target-scope=30
After upgrading to 6.40.8 (bugfix), it has stopped working:
Code: Select all
[admin@pppoe-server] > /ip ro pr ter where static
0 ADS dst-address=3.3.3.3/32 gateway=<pppoe-test> gateway-status=<pppoe-test> reachable distance=1 scope=30 target-scope=10
1 S dst-address=7.7.7.7/32 gateway=3.3.3.3 gateway-status=3.3.3.3 unreachable distance=1 scope=40 target-scope=30
This issue also exists on the latest current release 6.42.1.
Has anyone else seen this?
A simple lab setup to show this is as follows (ether2 on both routers are connected):
pppoe-server:
Code: Select all
/interface pppoe-server server
add disabled=no interface=ether2
/ppp secret
add name=test password=test local-address=1.1.1.1 remote-address=2.2.2.2 routes=3.3.3.3/32
/ip route
add dst-address=7.7.7.7/32 gateway=3.3.3.3 scope=40 target-scope=30
Code: Select all
/interface bridge
add name=loopback protocol-mode=none
/ip address
add address=3.3.3.3/32 interface=loopback
add address=7.7.7.7/32 interface=loopback
/interface pppoe-client
add disabled=no interface=ether2 password=test user=test