You can download it from the archive:Hey there, many thanks for the latest release though it looks like I am getting a 404 not found for ARM (rb3011) through your download page. I might just be a very keen bean!
Thanks for that, successfully downloaded now!Donkeyrollerz - You tried to download version while it was still being released.
pe1chl - Version fixes all the problems mentioned in changelog. There are no hidden fixes.
Yes, it is impossible to live without itdo i need to upgrade the firmware every time when new version comes out?
The firmware has gotten in sync with RouterOS versions....even if nothing has changed in the firmware.
I hope one time it will be separated again and as extra information a second version number stating minimal RouterOS version.
So how is the indicated problem going to be fixed?Donkeyrollerz - You tried to download version while it was still being released.
pe1chl - Version fixes all the problems mentioned in changelog. There are no hidden fixes.
Can anybody make me a solution / script so after the ROS upgrade the unit either in the same reboot, or thereafter reboots again to update the fw version?The firmware has gotten in sync with RouterOS versions....even if nothing has changed in the firmware.
I hope one time it will be separated again and as extra information a second version number stating minimal RouterOS version.
OH! So I'll sit and wait again.... Getting a bit frustrated over arm devices and NV2.....*) wireless - improved Nv2 reliability on ARM devices;
I'm sorry to indicate that the nv2 protocol on arm devices continues to fail. It is unstable and has packet loss. Nstreme is still the best option
here you goCan anybody make me a solution / script so after the ROS upgrade the unit either in the same reboot, or thereafter reboots again to update the fw version?
Now each and every unit has to be rebooted twice. which is a pain if you have to do big amounts....
:log info "Checking firmware...";
/system routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
:log info "Updating firmware";
upgrade;
# Automatic restart
:delay 2s
/system reboot
} else={
:log info "No update."
}
Don't do that! It can result in a boot loop!here you goCan anybody make me a solution / script so after the ROS upgrade the unit either in the same reboot, or thereafter reboots again to update the fw version?
Now each and every unit has to be rebooted twice. which is a pain if you have to do big amounts....
create this script then make a schedule on startup for it.Code: Select all:log info "Checking firmware..."; /system routerboard :if ([get current-firmware] != [get upgrade-firmware]) do={ :log info "Updating firmware"; upgrade; # Automatic restart :delay 2s /system reboot } else={ :log info "No update." }
Well, I am not of yesterday. I have to try it first. I made some scripts myself in the past but just as script that I'd copy and paste in a terminal window when we upgrade units.Don't do that! It can result in a boot loop!
MikroTik put out a release about six months ago where the "new available firmware" field always showed up as blank. Boot loop.The only bootloop possible is one caused by the new bootloader not being properly written. Which didn't happen to me on 30-40 RC updates.
[admin@PRIMARY-ROUTER] /ip ipsec policy group> print
Flags: * - default
# NAME
0 group2
1 group1
2 default
However, after the upgrade I noticed that the two routers with DNS servers (one for internal, one for my guest network) were no longer resolving. This wasn't an issue before the upgrade. I did see them receiving UDP 53 packets. After checking IP > DNS to see if anything had obviously changed and toggling "allow remote requests" on and off with no help, I activated a backup partition with 6.41.4 on both devices and rebooted. DNS is working again. Has anyone else seen this problem?
You can try Netinstall. But first, run /export and save your config.How I do resolve problem with no free disc space to upgrade firmware?
I have HAP Lite with old FW, when I try to upload new pkg, - see error, "You have only 6.4mB of free space", Write error..
and new FW pkg is 7+ mBytes.. What i can delete for upgrade fitmware?
Total is 16 mbytes.. AutoUpgrade still not working - due this reason..
I have the same issue with CCR1036 and RB1100AHx2, it started after upgrading to 6.42.1 and I've checked with 6.42.2 and 6.42.3. The issue persists with some routers, I've upgraded 20, had problems with 6 of them and 2 of this 6 didn't work after downgrade them to a previous version.I upgraded an RB750GL, a 3011, a CRS226, and a RB951G-2HnD from 6.41.4 to 6.42.4 with no issues.
However, after the upgrade I noticed that the two routers with DNS servers (one for internal, one for my guest network) were no longer resolving. This wasn't an issue before the upgrade. I did see them receiving UDP 53 packets. After checking IP > DNS to see if anything had obviously changed and toggling "allow remote requests" on and off with no help, I activated a backup partition with 6.41.4 on both devices and rebooted. DNS is working again. Has anyone else seen this problem?
But it does not reboot to take the changes into account. After upgrade you see a comment in export:icsterm - Auto upgrade feature under RouterBOARD settings does the same thing automatically.
[admin@mikrotik] > /system routerboard print
;;; Firmware upgraded successfully, please reboot for changes to take effect!
routerboard: yes
...
:if ([/system routerboard get pending-upgrade ] = true) do={ /system reboot }
Scripts can read the log! See https://wiki.mikrotik.com/wiki/Manual:S ... _log_entryBut this is not available to scripts, no? Perhaps you should add a read-only property "pending-upgrade". A scheduled script could look like this:
Yes...Scripts can read the log! See https://wiki.mikrotik.com/wiki/Manual:S ... _log_entryBut this is not available to scripts, no? Perhaps you should add a read-only property "pending-upgrade". A scheduled script could look like this:
:if ([ :len [ /log find where topics=system,info,critical and message="Firmware upgraded successfully, please reboot for changes to take effect!" ] ] > 0) do={ /system reboot }
As I wrote before, the router should do this automatically just after the automatic upgrade, before it brings up all the interfaces.But this is not available to scripts, no? Perhaps you should add a read-only property "pending-upgrade". A scheduled script could look like this:
Code: Select all:if ([/system routerboard get pending-upgrade ] = true) do={ /system reboot }
That refers to the remote side ROS version.rb952ui-5ac2nD hap lite
What problems? I can't click your WinBox to see actual settings for some reason.After upgrade, still have problems with DHCP.
Regards.
What problems? I can't click your WinBox to see actual settings for some reason.After upgrade, still have problems with DHCP.
Regards.
Opened Ticket#2018062122002481 with supouts as requested, please take a look Strods.I upgraded an RB750GL, a 3011, a CRS226, and a RB951G-2HnD from 6.41.4 to 6.42.4 with no issues.
However, after the upgrade I noticed that the two routers with DNS servers (one for internal, one for my guest network) were no longer resolving. This wasn't an issue before the upgrade. I did see them receiving UDP 53 packets. After checking IP > DNS to see if anything had obviously changed and toggling "allow remote requests" on and off with no help, I activated a backup partition with 6.41.4 on both devices and rebooted. DNS is working again. Has anyone else seen this problem?
I had this happen on a RB800, drove me crazy till I downgraded to 6.41 then upgraded by loading files directly instead of auto-upgrade. Seems to work now.I also confirm that DNS stops after a few hours on some CCR1009's
Sent from my ONEPLUS A5010 using Tapatalk
I also confirm that DNS stops after a few hours on some CCR1009's
Sent from my ONEPLUS A5010 using Tapatalk
I don't think the Mikrotik guys understand Spanish nor will most of the forum members. I believe there is a Spanish forum somewhere too...buenas tardes este firmware lo instale en 3 equipos rb750gl pero los mismos dejaron de funcionar, se reinicia constantemnete y los leds encienden y apagan a cada momento no los puedo recuperar ni con netinstall, tienen alguna solucion para este problema me quedaron 3 equipos como pisapapeles.
The VLAN configuration is the same for all models. MikroTik completely changed (improved) the VLAN configuration in 6.41 for all devices. It is not MikroTik's fault if you have some routers running versions before 6.41 and some running later versions.Why it just started to suck... different configurations for different rb models in vlans,... are You kidding? cant't rewrite config in common syntax?
You must be kidding... CRS1xxx vs CRS328..The VLAN configuration is the same for all models. MikroTik completely changed (improved) the VLAN configuration in 6.41 for all devices. It is not MikroTik's fault if you have some routers running versions before 6.41 and some running later versions.Why it just started to suck... different configurations for different rb models in vlans,... are You kidding? cant't rewrite config in common syntax?
This is pertinent NOT true! arm models with 6.41 are not working properly with PPPoE. Everytime we take a new arm unit (SXT-sq, LHG, DISC) we can set it up with same config as we use for some 800 other routers but we have to upgrade to 6.42.x just to make internet traffic for the client happening!The VLAN configuration is the same for all models. MikroTik completely changed (improved) the VLAN configuration in 6.41 for all devices. It is not MikroTik's fault if you have some routers running versions before 6.41 and some running later versions.
I assumed he must not be talking about HW offload. He said "it just started to suck", meaning he was talking about a recent change. VLAN config has always been a PITA with hw-offload, and the 'switch' menu has always been different for different device models, so the fact that this was always awkward did not jibe with his statement that it "just started to suck", and by this line of reasoning he must not have been referring to the switch menu. Except for MikroTik switches where you don't necessarily need VLAN interfaces, you've always had to set up VLANs in two places instead of one if you need hw-offload and it was easy to get two packets received for every packet sent and other weirdness like that if you didn't know exactly what you were doing. If he is talking about new things, he must mean the VLAN config under "bridge". The VLAN config was always so much of a problem with hw-offload that we just did them in software (except for switches and other such cases where we badly needed hardware acceleration).Some you have to do in new bridge configuriration some left in Switch Chip. Others you can completly made in bridge menu and retain HWoffload.
So don't mislead people. Iviks has a valid point regarding VLAN config. It is not the same for all models if you want HW offload and I am certain this is what he means.
I wasn't saying anything about other issues with 6.41. My reply was only regarding the VLAN config in the bridge menu, which was changed in 6.41, and nowhere did I say that 6.41 was bug free in all regards. I have no doubt that there were bugs, and to be on the safe side, we have been remaining for several months at versions below 6.41 on production devices without careful testing to make sure everything worked. The new bridge is a big change, and big changes always have a high risk of new bugs...This is pertinent NOT true! arm models with 6.41 are not working properly with PPPoE.
Haven't seen this myself except in the case that you mention (MTU size differences) which is related to use of MAC winbox. Are you connecting to winbox with IP?I just encountered a problem with upgrading a RB850Gx2 to version 6.42.4. After the upgrade, Winbox will no longer complete connecting to the RB850Gx2. The main window opens, and a few subwindows start to populate, and then the Winbox connection hangs up, and eventually times out. The appearance is similar to what I’ve encountered in the past when there were MTU size differences that seem to cause Winbox to choke when handling large packets. However, in this case, there should not be any MTU size inconsistencies.
I appreciate your suggestions, however this particular router has all interfaces and bridges left at default MTU sizes (i.e., actual mtu = 1500). I just scanned all interface specifications on this RB850Gx2, and every Ethernet, VLAN, and bridge is set for an MTU of 1500 (for Layer 3 protocols). I’m familiar with the MTU problems affecting Winbox because I do have lots of MikroTik routers of various stripes configured to use non-standard MTU sizes. My impression is that Winbox has issues with packet fragmentation. However, this RB850Gx2 should have been easy, since all MTU settings were left at default.Haven't seen this myself except in the case that you mention (MTU size differences) which is related to use of MAC winbox. Are you connecting to winbox with IP?I just encountered a problem with upgrading a RB850Gx2 to version 6.42.4. After the upgrade, Winbox will no longer complete connecting to the RB850Gx2. The main window opens, and a few subwindows start to populate, and then the Winbox connection hangs up, and eventually times out. The appearance is similar to what I’ve encountered in the past when there were MTU size differences that seem to cause Winbox to choke when handling large packets. However, in this case, there should not be any MTU size inconsistencies.
Are you sure it isn't an MTU issue? I've seen issues before with bridge auto MTU not adjusting properly when adding a port, resulting in a bridge IP MTU that is higher than it should be. Disabling and re-enabling the bridge or rebooting the device triggers the bridge to recalculate the correct MTU to use based on the ports that are attached and then it works. I haven't been able to reproduce this issue consistently.
I can confirm that 6.42.4 on RB1100AHx2 (PPC) does not have this issue with Winbox disconnects.One possibility is that this is related to the PPC processor family.
I wasn't saying anything about other issues with 6.41. My reply was only regarding the VLAN config in the bridge menu, which was changed in 6.41, and nowhere did I say that 6.41 was bug free in all regards. I have no doubt that there were bugs, and to be on the safe side, we have been remaining for several months at versions below 6.41 on production devices without careful testing to make sure everything worked. The new bridge is a big change, and big changes always have a high risk of new bugs...This is pertinent NOT true! arm models with 6.41 are not working properly with PPPoE.
Hi.Does it fix the "lost space after upgrade" issue on CCR?
(when upgrading 6.42.1 to 6.42.3 on a CCR split into two 64MB partitions a lot of diskspace remains in-use after the upgrade and not enough space is left for another upgrade)
I am using VLAN config in our network and as a test I migrated my own home router from a config where the VLANs were done in switch config, with each VLAN connected to a separate bridge, to a new-style config with a single bridge with all the VLAN filtering and no VLAN config in the switch menu. No spanning tree or other advanced features.In the case of the WISP that I work for, the changes introduced in 6.41+ will not require that we make changes to the config, however, it is in our best interest to do so since it will remove three or four bridges from our config that we will no longer need due to these new features. For us, a simpler setup means fewer mistakes which means fewer customer issues, ultimately increasing customer satisfaction, even if it means we have to do a bit of extra work to get there.
I agree completely. It is highly problematic that with some models you cannot do bridge VLAN filtering at all without making hardware offload impossible. This should be more consistent between models, and I hope they are prioritizing that. Also, bridge options should ideally be clearly marked with whether an option is supported for hardware offload or not on a specific model, so that people will know what they have to do to get hardware offload without the guesswork (kind of like the way the hardware accelerated ipsec options are marked with the "(H)").IMHO it should be possible to have hardware accelerated VLAN bridging as the switch chips are clearly capable of doing it. This should have priority to implement, in fact it should have been included before the new bridge config went in to "current".
The problem is in 6.42.4 user needs also 'winbox' permission to login via API. Should be fixed in next version, now you can just add that permission.I cannot access to router via API(PHP) after updated.
Return back to BugFix only v.6.40.8 => Worked.
The switch menu should be there because they have not yet made all of the switch options work with hardware offload besides simple bridge ports (to replace the master/slave setting). On most models they have not yet made the bridge VLAN config work with hardware offload, so VLANs still need to be configured the old way if you need hardware offload. In our case (a WISP) we don't need hardware offload because we are not bridging more than 100Mbps so we configure everything using the new means even though it means hardware offload will be disabled.The switch menu shouldn't be there, should it? Thankfully at least it works now with the original switch VLAN config and the VLAN interfaces I added to the bridge.
EDIT: additionally, the sfp1 interface disappeared. We don't have a module in it, but it's nowhere to be found, not even in command line. It was there with the interfaces in 6.34.2.
I know with the RB3011 if spanning tree is enabled then hardware offload gets turned off, that might be the case for the 2011 as well but I'm not sure. Keep that in mind as you are experimenting with the config.@mducharme: in the meantime I've "found" the VLAN filtering option (I was in a kind of hurry to bring things back online), so I'll start testing it on the RB2011. I've modified my original post, removing the false info. So it might become possible to use the bridge config and ditch the old switch config even on this model. We'll see.
No, I rebooted to update the firmware, too, and the sfp1 interface didn't appear.
If you don't need HW acceleration then you don't need to configure the VLANs in the switch menu (so you don't need it in two places), you can remove that config (set the switch config back to factory default and ignore the VLAN tab) and use only bridge VLAN filtering. You might get the HW acceleration back automatically at a future date when they add HW offload support for bridge VLANs with that model.EDIT: I checked the "VLAN filtering" option. The router immediately created dynamic VLAN configuration on the bridge, based on the current switch config, and disabled HW accel on the ports. Oh well. I don't really need HW acceleration there, though, as it's a gateway, but I'm pretty much pissed that now I need to configure the same thing at 2 places... Now I left it as is, using switch config and HW accel.
Hi Chupaka, could you explain better how to give this permission?The problem is in 6.42.4 user needs also 'winbox' permission to login via API. Should be fixed in next version, now you can just add that permission.I cannot access to router via API(PHP) after updated.
Return back to BugFix only v.6.40.8 => Worked.
So no... So this might be a dangerous update for some people as it might use up more disc space and then they will not be able to update or downgrade and will be forced to Netinstall.Donkeyrollerz - You tried to download version while it was still being released.
pe1chl - Version fixes all the problems mentioned in changelog. There are no hidden fixes.
That is why my two CCRs are effectively locked at 6.42.1 until MikroTik sort this out... which every .x release I hope they have done, but until now hey seem to rate this seriousSo no... So this might be a dangerous update for some people as it might use up more disc space and then they will not be able to update or downgrade and will be forced to Netinstall.
I tested the upgrade on a CCr1036 where I have plenty of HD space so if something goes wrong I wont get shut out. Indeed this update consumed 14MB of additional space. Pre 6.42 updates did not consume much more space like that. So something still seems wrong to me.
I reported this a page before, funny that no one read the topic.The problem is in 6.42.4 user needs also 'winbox' permission to login via API. Should be fixed in next version, now you can just add that permission.I cannot access to router via API(PHP) after updated.
Return back to BugFix only v.6.40.8 => Worked.