I need some help with dual wan PCC configuration. I have two routers connected by one cable on ether2. The two routers have their independent respective internet connection. What I want to achieve is for both routers to share their internet traffic.
Router A have subnet 192.168.80.0/24 and Router B have subnet 192.168.88.0/24. Router A ether2 have address 192.168.123.1 and Router B ether2 have address 192.168.123.2.
I have added a static router to connect Router A and Router B via ether2.
The problem is no internet traffic is going through ether2. Maybe the issue is when a packet arrives from ether2, the router does not know how to router to ether1.
Router A
Code: Select all
[admin@MT-30] > export hide-sensitive
# jun/30/2018 18:48:19 by RouterOS 6.42.3
# software id = 6I1X-92CP
#
# model = 2011UAS-2HnD
# serial number = 402602239286
/caps-man channel
add band=2ghz-b/g/n control-channel-width=20mhz name=2G
add band=5ghz-a/n/ac control-channel-width=20mhz name=5G
/interface bridge
add fast-forward=no name=COOKST
add admin-mac=00:0C:42:F8:A5:78 auto-mac=no comment=defconf name=bridge-local
/interface wireless
# managed by CAPsMAN
# channel: 2452/20-Ce/gn(36dBm), SSID: COOKST, CAPsMAN forwarding
set [ find default-name=wlan1 ] name=wlan2 ssid=MT-30A
/interface ethernet
set [ find default-name=ether1 ] mac-address=00:0C:42:F8:A5:77
set [ find default-name=ether2 ] mac-address=00:0C:42:F8:A5:78
set [ find default-name=ether3 ] mac-address=00:0C:42:F8:A5:79
set [ find default-name=ether4 ] mac-address=00:0C:42:F8:A5:7A
set [ find default-name=ether5 ] mac-address=00:0C:42:F8:A5:7B
set [ find default-name=ether6 ] mac-address=00:0C:42:F8:A5:7C
set [ find default-name=ether7 ] mac-address=00:0C:42:F8:A5:7D
set [ find default-name=ether8 ] mac-address=00:0C:42:F8:A5:7E
set [ find default-name=ether9 ] mac-address=00:0C:42:F8:A5:7F
set [ find default-name=ether10 ] mac-address=00:0C:42:F8:A5:80
set [ find default-name=sfp1 ] disabled=yes mac-address=00:0C:42:F8:A5:76
/caps-man datapath
add bridge=COOKST name=COOKST
/caps-man security
add authentication-types=wpa-psk,wpa2-psk comment=jesusislord encryption=aes-ccm,tkip name=COOKST
/caps-man configuration
add channel=2G country=australia datapath=COOKST distance=indoors mode=ap name=COOKST-2G security=COOKST ssid=COOKST
add channel=5G country=australia datapath=COOKST distance=indoors mode=ap name=COOKST-5G security=COOKST ssid=COOKST
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=COOKST ranges=10.0.0.20-10.0.0.200
add name=dhcp_pool3 ranges=192.168.80.20-192.168.80.254
/ip dhcp-server
add address-pool=COOKST disabled=no interface=COOKST name=COOKST
add address-pool=dhcp_pool3 disabled=no interface=bridge-local name=dhcp1
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=COOKST-2G name-format=identity name-prefix=COOKST
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=COOKST-5G name-format=identity
/interface bridge port
add bridge=bridge-local comment=defconf interface=ether3
add bridge=bridge-local comment=defconf interface=ether4
add bridge=bridge-local comment=defconf interface=ether5
add bridge=bridge-local comment=defconf interface=ether6
add bridge=bridge-local comment=defconf interface=ether7
add bridge=bridge-local comment=defconf interface=ether8
add bridge=bridge-local comment=defconf interface=ether9
add bridge=bridge-local comment=defconf interface=*1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge-local list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=ether2 list=WAN
/interface wireless cap
#
set caps-man-addresses=127.0.0.1 enabled=yes interfaces=wlan2
/ip address
add address=192.168.80.1/24 comment=defconf interface=bridge-local network=192.168.80.0
add address=192.168.123.1/30 interface=ether2 network=192.168.123.0
add address=10.0.0.1/24 interface=COOKST network=10.0.0.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.0.0.0/24 gateway=10.0.0.1
add address=192.168.80.0/24 gateway=192.168.80.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input dst-address-type=local src-address-type=local
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=local_wan_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=local_wan_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=bridge-local new-connection-mark=local_wan_conn \
passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=bridge-local new-connection-mark=remote_wan_conn \
passthrough=yes per-connection-classifier=both-addresses-and-ports:1/0
add action=mark-routing chain=prerouting connection-mark=local_wan_conn in-interface=bridge-local new-routing-mark=to_local_wan passthrough=yes
add action=mark-routing chain=prerouting connection-mark=remote_wan_conn in-interface=bridge-local new-routing-mark=to_remote_wan passthrough=yes
add action=mark-routing chain=output connection-mark=local_wan_conn new-routing-mark=to_local_wan passthrough=yes
add action=mark-routing chain=output connection-mark=remote_wan_conn new-routing-mark=to_remote_wan passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=ether1
add action=masquerade chain=srcnat src-address=10.0.0.0/24
/ip route
add check-gateway=ping distance=1 gateway=192.168.123.2 routing-mark=to_remote_wan
add check-gateway=ping distance=1 dst-address=192.168.80.0/32 gateway=bridge-local
add check-gateway=ping distance=1 dst-address=192.168.88.0/24 gateway=192.168.123.2
/system clock
set time-zone-name=Australia/Sydney
/system identity
set name=MT-30
/system routerboard settings
set auto-upgrade=yes silent-boot=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Code: Select all
[admin@MT-30A] > export hide-sensitive
# jun/30/2018 18:49:17 by RouterOS 6.42.1
# software id = YSFQ-H9GG
#
# model = 2011UAS-2HnD
# serial number = 419E0125FDC1
/caps-man channel
add band=2ghz-b/g/n control-channel-width=20mhz name=2G
add band=5ghz-a/n/ac control-channel-width=20mhz name=5G
/interface bridge
add fast-forward=no name=COOKST
add admin-mac=00:0C:42:F8:A5:78 auto-mac=no comment=defconf name=bridge-local
/interface wireless
# managed by CAPsMAN
# channel: 2447/20-Ce/gn(36dBm), SSID: COOKST1, CAPsMAN forwarding
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-F8A581 \
wireless-protocol=802.11
/interface ethernet
set [ find default-name=sfp1 ] disabled=yes
/caps-man datapath
add bridge=COOKST name=COOKST
/caps-man security
add authentication-types=wpa-psk,wpa2-psk comment=jesusislord encryption=aes-ccm,tkip name=COOKST
/caps-man configuration
add channel=2G country=australia datapath=COOKST distance=indoors mode=ap name=COOKST-2G security=COOKST ssid=COOKST1
add channel=5G country=australia datapath=COOKST distance=indoors mode=ap name=COOKST-5G security=COOKST ssid=COOKST1
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=COOKST ranges=10.0.0.20-10.0.0.200
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge-local name=defconf
add address-pool=COOKST disabled=no interface=COOKST name=COOKST
/tool user-manager customer
set admin access=own-routers,own-users,own-profiles,own-limits,config-payment-gw
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=COOKST-2G name-format=identity name-prefix=COOKST
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=COOKST-5G name-format=identity
/interface bridge port
add bridge=bridge-local comment=defconf interface=ether3
add bridge=bridge-local comment=defconf interface=ether4
add bridge=bridge-local comment=defconf interface=ether5
add bridge=bridge-local comment=defconf interface=ether6
add bridge=bridge-local comment=defconf interface=ether7
add bridge=bridge-local comment=defconf interface=ether8
add bridge=bridge-local comment=defconf interface=ether9
add bridge=bridge-local comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge-local list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=ether2 list=WAN
/interface wireless cap
#
set caps-man-addresses=127.0.0.1 enabled=yes interfaces=wlan1
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge-local network=192.168.88.0
add address=192.168.123.2/30 interface=ether2 network=192.168.123.0
add address=10.0.0.1/24 interface=COOKST network=10.0.0.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.0.0.0/24 gateway=10.0.0.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input dst-address-type=local src-address-type=local
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=local_wan_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=local_wan_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=bridge-local new-connection-mark=local_wan_conn \
passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=bridge-local new-connection-mark=remote_wan_conn \
passthrough=yes per-connection-classifier=both-addresses-and-ports:1/0
add action=mark-routing chain=prerouting connection-mark=local_wan_conn in-interface=bridge-local new-routing-mark=to_local_wan passthrough=yes
add action=mark-routing chain=prerouting connection-mark=remote_wan_conn in-interface=bridge-local new-routing-mark=to_remote_wan passthrough=yes
add action=mark-routing chain=output connection-mark=local_wan_conn new-routing-mark=to_local_wan passthrough=yes
add action=mark-routing chain=output connection-mark=remote_wan_conn new-routing-mark=to_remote_wan passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=ether1
add action=masquerade chain=srcnat src-address=10.0.0.0/24
/ip route
add check-gateway=ping distance=1 gateway=192.168.123.1 routing-mark=to_remote_wan
add check-gateway=ping distance=1 dst-address=192.168.80.0/24 gateway=192.168.123.1
/system clock
set time-zone-name=Australia/Sydney
/system identity
set name=MT-30A
/system routerboard settings
set auto-upgrade=yes silent-boot=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool user-manager database
set db-path=user-manager