I just tested this very carefully and it seems to NOT work over 6.17.
Rudios, can you check this out and repeat your testing? It seems very clear to me that it's still broken.
Following is my very simple two router setup. Details are at the end.
Each router is connected via ether1 to my workbench LAN, as 192.168.1.133 and .134.
I'll call them 'left' and 'right'.
Both have a bride called bridge-tunnel, with no ports. Admin MAC set to 02:AA:AA:AA:AA:AA on the right and 02:BB:BB:BB:BB:BB on the left.
Both bridges are connected via BCP using PPTP.
Left bridge is statically assigned 192.168.40.5/24.
Right bridge is statically assigned 192.168.40.1/24
DHCP server is created on right bridge with pool 192.168.40.100-192.168.40.200.
DHCP client is created on left bridge.
Testing
------
1) Ping from left router to 192.168.40.1
2)Ping from right router to 192.168.40.5
3)Look for left bridge DHCP client to get IP address from right bridge DHCP server.
Results
====
ROS 6.17 Tests 1&2 passes, Test 3 failes
ROS 5.26 Tests 1,2 & 3 always passes.
The configuration was not changed in any way between ROS versions. I tested 6.17, downgraded to 5.24, tested, upgraded to 6.17 again and re-tested.
Here are the detailed configurations. It takes about 2 minutes to set this up.
Left router:
# jul/25/2014 15:32:08 by RouterOS 6.17
# software id = 4RFY-E9RX
#
/interface bridge
add admin-mac=02:BB:BB:BB:BB:BB auto-mac=no name=bridge-tunnel
/ppp profile
add bridge=bridge-tunnel name=profile-tunnel
/interface pptp-client
add add-default-route=no allow=pap,chap,mschap1,mschap2 connect-to=\
192.168.1.133 dial-on-demand=no disabled=no keepalive-timeout=60 max-mru=\
1450 max-mtu=1450 mrru=1600 name=pptp-tunnel password=tunneltest profile=\
profile-tunnel user=tt
/ip address
add address=192.168.40.5/24 interface=bridge-tunnel network=192.168.40.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=ether1
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=bridge-tunnel use-peer-dns=no use-peer-ntp=no
Right router:
# jan/02/1970 00:21:04 by RouterOS 6.17
# software id = 8J2K-5ZUR
#
/interface bridge
add admin-mac=02:AA:AA:AA:AA:AA auto-mac=no name=bridge-tunnel priority=0x4000
/ip pool
add name=pool1 ranges=192.168.40.100-192.168.40.200
/ip dhcp-server
add address-pool=pool1 authoritative=yes disabled=no interface=bridge-tunnel \
name=server1
/ppp profile
add bridge=bridge-tunnel name=profile-tunnel
/interface pptp-server server
set default-profile=profile-tunnel enabled=yes mrru=1600
/ip address
add address=192.168.40.1/24 interface=bridge-tunnel network=192.168.40.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.40.0/24 gateway=192.168.40.1
/ppp secret
add local-address=192.168.80.1 name=tt password=tunneltest profile=\
profile-tunnel remote-address=192.168.80.2