I have successfully configured routeros to allow VPN clients to connect via IKEv2, backed with radius, and authenticating using EAP-TLS (no passwords). The config is below.
What I discovered is that this configuration would only work if I took the private key and certificate of our radius server and installed that certificate on the routerboard (certificate=certificate-of-the-radius-server.pem).
Obviously this is not great - I would prefer the radius server to have the certificate, not have this duplicated on the routers, which aren't necessarily as physically secure as the radius box is. Can anyone confirm why this is the case? What are the requirements on the certificate on the routerboard, why is the certificate in radius not good enough?
Code: Select all
# feb/25/2018 13:00:00 by RouterOS 6.41.2
# software id = 95CM-PS1P
#
# model = 1100AHx2
# serial number = 5732041E2225
/ip ipsec mode-config
add address-pool=default-dhcp name=roadwarrior split-include=192.168.x.x/24
/ip ipsec policy group
add name=roadwarrior
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=blowfish pfs-group=modp4096
add auth-algorithms=sha256,sha1 enc-algorithms=aes-256-cbc lifetime=8h name=roadwarrior pfs-group=none
/ip ipsec peer
add address=0.0.0.0/0 auth-method=eap-radius certificate=certificate-of-the-radius-server.pem dh-group=ecp256,modp2048,modp1536,modp1024 enc-algorithm=aes-256 \
exchange-mode=ike2 generate-policy=port-strict hash-algorithm=sha256 mode-config=roadwarrior passive=yes policy-template-group=roadwarrior send-initial-contact=no
/ip ipsec policy
add dst-address=192.168.x.x/24 group=roadwarrior proposal=roadwarrior src-address=0.0.0.0/0 template=yes
add dst-address=192.168.y.y/24 group=roadwarrior proposal=roadwarrior src-address=0.0.0.0/0 template=yes
Graham
--