hello
when i use fasttrack
the pcc do not work
when i turn off the fasttrack
everything is ok
is this a bug ?
thank you very much
thank you very muchPCC requires mangle and connection tracking to work.
Fast track removes all connection tracking in an effort to process packets faster.
No bug. No magic.
because i saw somebody use it with pcc in the forumPCC requires mangle and connection tracking to work.
Fast track removes all connection tracking in an effort to process packets faster.
No bug. No magic.
thank you ,the issue confuses me so much timeNo, it is not a bug. It is actually mentioned somewhere in the wiki. Fasttrack bypasses some sections of the Firewall engine (part of which is mangle) and this makes it incompatible with some features that look inside packets, like pcc (which is based on source/destination addresses/ports).
when you add fasttrack rule,you can define the rule of yourself and separate the ip that you do not want to fasttrackLet's assume that there are a few subnets behind the router. Those subnets are separated on L2 (either physical ether ports or VLANs) and L3 (different network addresses). Which is proper / best way of excluding certain subnet from being fasttracked? For example because those subnets will be subject to PCC or simple queue or ...
.when you add fasttrack rule,you can define the rule of yourself and separate the ip that you do not want to fasttrack
or you can make filter rule before the fasttrack rule and choose no passthrough
/ip firewall filter
add action=fasttrack-connection chain=forward connection-state=established,related src-address=!192.168.41.0/24
add action=fasttrack-connection chain=forward comment="FastTrack: established & related" connection-bytes=8000-0 \
connection-mark=FT connection-state=established,related
add action=accept chain=est_rel comment="Accept: established & related" connection-state=established,related
add action=drop chain=est_rel comment="Drop: invalid" connection-state=invalid
That rule gets applied in both directions ... on the way back from internet to internal src-address exclude will not do the job...I've created rule such as this:Code: Select all/ip firewall filter add action=fasttrack-connection chain=forward connection-state=established,related src-address=!192.168.41.0/24
Do I understand correctly that if the connection is initiated from 192.168.41.0/24 (src address matches), it should not be fasttracked? And that's true for both directions?That rule gets applied in both directions ... on the way back from internet to internal src-address exclude will not do the job...
Fasttracking behaves like connection-marking, once set it's for both directions.
/ip firewall filter
add action=fasttrack-connection chain=forward connection-state=established,related src-address=!192.168.41.0/24
/ip firewall filter
add action=fasttrack-connection chain=forward connection-state=established,related src-address=!192.168.41.0/24 in-interface-list=LAN
# or similar
.The rulewill do followingCode: Select all/ip firewall filter add action=fasttrack-connection chain=forward connection-state=established,related src-address=!192.168.41.0/24
* LAN -> WAN
will not fasttrack if the src is .41. network.
* WAN -> LAN
will fasttrack ALL connections as none have src from .41. range
Result: all connections end up fasttracked
I tried to keep a queue functional by excluding [!] the IP's, similar to above ^, but it would not work. I had to put accept rules with that traffic before the fasttrack rule then the queue started working again --> viewtopic.php?f=2&t=139341#p702303The ruleCode: Select all/ip firewall filter add action=fasttrack-connection chain=forward connection-state=established,related src-address=!192.168.41.0/24
.I tried to keep a queue functional by excluding [!] the IP's, similar to above ^, but it would not work.
/ip firewall mangle
add action=mark-connection chain=forward comment="Guest VLAN" connection-state=new in-interface=vlan-41\
new-connection-mark=vlan41 passthrough=yes
/ip firewall filter
add action=fasttrack-connection chain=forward comment="fasttrack ... everything that is not marked (see mangle rules)"\
connection-mark=no-mark connection-state=established,related
# after that comes the normal accept established,related rule