For some reason when swapping the VRRP-ip from ccr-1 to ccr-2 all goes well, but .... back from ccr-2 to ccr-1 takes a long delay (several minutes) before the VRRP-ip can be pinged.
Topology:
CCR-1 --- CRS-1 -----ISP VLAN (vlan-gs-ser) ----- CRS-2 --- CCR-2
I read the forum but didnt came across the right solution. Anyone here having suggestions on where to debug? Complete configs below:
CCR-1:
Code: Select all
# jan/08/2019 21:59:15 by RouterOS 6.43.8
# software id = UD8E-94C7
#
# model = CCR1036-12G-4S
# serial number =
/interface bridge
add ingress-filtering=yes name=bridge pvid=10 vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] speed=100Mbps
set [ find default-name=ether2 ] speed=100Mbps
set [ find default-name=ether3 ] mac-address=4C:5E:0C:63:F7:DB speed=100Mbps
set [ find default-name=ether4 ] disabled=yes speed=100Mbps
set [ find default-name=ether5 ] disabled=yes speed=100Mbps
set [ find default-name=ether6 ] disabled=yes speed=100Mbps
set [ find default-name=ether7 ] disabled=yes speed=100Mbps
set [ find default-name=ether8 ] disabled=yes speed=100Mbps
set [ find default-name=ether9 ] disabled=yes speed=100Mbps
set [ find default-name=ether10 ] disabled=yes speed=100Mbps
set [ find default-name=ether11 ] speed=100Mbps
set [ find default-name=ether12 ] disabled=yes speed=100Mbps
set [ find default-name=sfp1 ] advertise=10M-full,100M-full,1000M-full
set [ find default-name=sfp2 ] advertise=10M-full,100M-full,1000M-full
set [ find default-name=sfp3 ] advertise=10M-full,100M-full,1000M-full \
disabled=yes
set [ find default-name=sfp4 ] advertise=10M-full,100M-full,1000M-full \
disabled=yes
/interface vlan
add interface=bridge name=vlan-mgmt vlan-id=20
add interface=bridge name=vlan-proxmox vlan-id=107
add interface=bridge name=vlan-vrrp vlan-id=111
/interface bonding
add mode=802.3ad name=trunk-ccr1-crs1 slaves=ether2,ether3
/interface vrrp
add interface=vlan-vrrp name=vrrp1
/routing bgp instance
set default as=***** router-id=******
add as=****** name=ibgp redistribute-connected=yes redistribute-other-bgp=yes
/interface bridge port
add bridge=bridge ingress-filtering=yes interface=sfp1 pvid=10
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged \
ingress-filtering=yes interface=ether11 pvid=13
add bridge=bridge ingress-filtering=yes interface=sfp2 pvid=11
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes \
interface=trunk-ccr1-crs1
/ip settings
set accept-source-route=yes
/ipv6 settings
set accept-redirects=no
/interface bridge vlan
add bridge=bridge tagged=bridge,trunk-ccr1-crs1 vlan-ids=100
add bridge=bridge tagged=sfp1,bridge vlan-ids=254
add bridge=bridge tagged=bridge,trunk-ccr1-crs1 vlan-ids=101
add bridge=bridge tagged=bridge,trunk-ccr1-crs1 vlan-ids=102
add bridge=bridge tagged=trunk-ccr1-crs1,bridge vlan-ids=107
add bridge=bridge tagged=trunk-ccr1-crs1,bridge vlan-ids=103
add bridge=bridge tagged=bridge,trunk-ccr1-crs1 vlan-ids=110
add bridge=bridge tagged=bridge untagged=ether11 vlan-ids=13
add bridge=bridge tagged=bridge,trunk-ccr1-crs1 vlan-ids=106
add bridge=bridge tagged=bridge,trunk-ccr1-crs1 vlan-ids=105
add bridge=bridge tagged=trunk-ccr1-crs1,bridge vlan-ids=20
add bridge=bridge tagged=trunk-ccr1-crs1,bridge vlan-ids=1001
add bridge=bridge tagged=bridge,trunk-ccr1-crs1 vlan-ids=111
add bridge=bridge tagged=bridge untagged=sfp1 vlan-ids=10
add bridge=bridge tagged=bridge untagged=sfp2 vlan-ids=11
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether1 network=\
192.168.88.0
add address=*.*.*.*/29 interface=vlan-mgmt network=*.*.*.*
add address=10.0.0.1/24 interface=vlan-vrrp network=10.0.0.0
add address=10.0.0.3 interface=vrrp1 network=10.0.0.3
/ip route
add distance=1 dst-address=*.*.*.*/23 type=unreachable
Code: Select all
# jan/08/2019 21:59:33 by RouterOS 6.43.8
# software id = U12W-39Y9
#
# model = CCR1036-12G-4S
# serial number =
/interface bridge
add ingress-filtering=yes name=bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] speed=100Mbps
set [ find default-name=ether2 ] speed=100Mbps
set [ find default-name=ether3 ] mac-address=6C:3B:6B:08:92:65 speed=100Mbps
set [ find default-name=ether4 ] disabled=yes speed=100Mbps
set [ find default-name=ether5 ] disabled=yes speed=100Mbps
set [ find default-name=ether6 ] disabled=yes speed=100Mbps
set [ find default-name=ether7 ] disabled=yes speed=100Mbps
set [ find default-name=ether8 ] disabled=yes speed=100Mbps
set [ find default-name=ether9 ] disabled=yes speed=100Mbps
set [ find default-name=ether10 ] disabled=yes speed=100Mbps
set [ find default-name=ether11 ] speed=100Mbps
set [ find default-name=ether12 ] speed=100Mbps
set [ find default-name=sfp1 ] advertise=10M-full,100M-full,1000M-full \
disabled=yes
set [ find default-name=sfp2 ] advertise=10M-full,100M-full,1000M-full \
disabled=yes
set [ find default-name=sfp3 ] advertise=10M-full,100M-full,1000M-full \
disabled=yes
set [ find default-name=sfp4 ] advertise=10M-full,100M-full,1000M-full \
disabled=yes
/interface vlan
add interface=bridge name=vlan-mgmt vlan-id=20
add interface=bridge name=vlan-vrrp vlan-id=111
/interface bonding
add mode=802.3ad name=trunk-ccr2-crs2 slaves=ether2,ether3
/interface vrrp
add interface=vlan-vrrp name=vrrp1 priority=99
/routing bgp instance
set default as=***** router-id=*.*.*.*
add as=***** name=ibgp redistribute-connected=yes redistribute-other-bgp=yes
/interface bridge port
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes \
interface=trunk-ccr2-crs2
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged \
ingress-filtering=yes interface=ether11 pvid=30
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged \
ingress-filtering=yes interface=ether12 pvid=30
/ip settings
set accept-source-route=yes
/interface bridge vlan
add bridge=bridge tagged=bridge,trunk-ccr2-crs2 vlan-ids=20
add bridge=bridge tagged=bridge untagged=ether11,ether12 vlan-ids=30
add bridge=bridge tagged=bridge,trunk-ccr2-crs2 vlan-ids=103
add bridge=bridge tagged=bridge,trunk-ccr2-crs2 vlan-ids=111
add bridge=bridge tagged=bridge,trunk-ccr2-crs2 vlan-ids=1001
/ip address
add address=*.*.*.*/29 interface=vlan-mgmt network=*.*.*.*
add address=10.0.0.2/24 interface=vlan-vrrp network=10.0.0.0
add address=10.0.0.3 interface=vrrp1 network=10.0.0.3
/ip route
add distance=1 dst-address=*.*.*.*/23 type=blackhole
Code: Select all
# jan/09/1970 22:29:09 by RouterOS 6.43.8
# software id = BZ0B-CY0W
#
# model = CRS317-1G-16S+
# serial number =
/interface bridge
add ingress-filtering=yes name=bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus3 ] mac-address=B8:69:F4:8D:C2:57
/interface vlan
add interface=sfp-sfpplus1 name=vlan-gs-ser vlan-id=309
add interface=bridge name=vlan-mgmt vlan-id=20
/interface bonding
add mode=802.3ad name=trunk-ccr1-crs1 slaves=sfp-sfpplus2,sfp-sfpplus3
/interface bridge port
add bridge=bridge ingress-filtering=yes interface=trunk-ccr1-crs1
add bridge=bridge interface=sfp-sfpplus1
add bridge=bridge ingress-filtering=yes interface=vlan-gs-ser
add bridge=bridge ingress-filtering=yes interface=sfp-sfpplus6 pvid=107
add bridge=bridge ingress-filtering=yes interface=sfp-sfpplus7 pvid=107
add bridge=bridge ingress-filtering=yes interface=sfp-sfpplus8 pvid=107
add bridge=bridge interface=sfp-sfpplus9 pvid=107
add bridge=bridge ingress-filtering=yes interface=sfp-sfpplus10 pvid=107
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged \
ingress-filtering=yes interface=sfp-sfpplus11 pvid=100
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes \
interface=sfp-sfpplus14
/interface bridge vlan
add bridge=bridge tagged=vlan-gs-ser,trunk-ccr1-crs1,bridge untagged=\
sfp-sfpplus6,sfp-sfpplus7,sfp-sfpplus8,sfp-sfpplus9,sfp-sfpplus10 \
vlan-ids=107
add bridge=bridge tagged=trunk-ccr1-crs1,sfp-sfpplus1,bridge vlan-ids=1001
add bridge=bridge tagged=bridge,trunk-ccr1-crs1,vlan-gs-ser,sfp-sfpplus14 \
vlan-ids=20
add bridge=bridge tagged="bridge,trunk-ccr1-crs1,vlan-gs-ser,sfp-sfpplus7,sfp-\
sfpplus8,sfp-sfpplus9,sfp-sfpplus10,sfp-sfpplus14" untagged=sfp-sfpplus11 \
vlan-ids=100
add bridge=bridge tagged=vlan-gs-ser,trunk-ccr1-crs1,bridge,sfp-sfpplus6 \
vlan-ids=103
add bridge=bridge tagged=vlan-gs-ser,trunk-ccr1-crs1,bridge vlan-ids=111
add bridge=bridge tagged=\
vlan-gs-ser,trunk-ccr1-crs1,bridge,sfp-sfpplus7,sfp-sfpplus14 vlan-ids=\
102
add bridge=bridge tagged=bridge,trunk-ccr1-crs1,sfp-sfpplus14 vlan-ids=106
add bridge=bridge tagged=bridge,trunk-ccr1-crs1,sfp-sfpplus14 vlan-ids=101
add bridge=bridge tagged=bridge,trunk-ccr1-crs1,sfp-sfpplus14 vlan-ids=108
add bridge=bridge tagged=bridge,trunk-ccr1-crs1,sfp-sfpplus14 vlan-ids=110
/ip address
add address=*.*.*.*/29 interface=vlan-mgmt network=*.*.*.*
Code: Select all
# jan/08/2019 22:00:20 by RouterOS 6.43.8
# software id = 20WM-JWM7
#
# model = CRS317-1G-16S+
# serial number =
/interface bridge
add ingress-filtering=yes name=bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus3 ] mac-address=B8:69:F4:8D:93:94
set [ find default-name=sfp-sfpplus16 ] mac-address=B8:69:F4:8D:93:A1
/interface vlan
add interface=sfp-sfpplus1 name=vlan-gs-ser vlan-id=309
add interface=bridge name=vlan-mgmt vlan-id=20
/interface bonding
add mode=802.3ad name=trunk-ccr2-crs2 slaves=sfp-sfpplus2,sfp-sfpplus3
add mode=802.3ad name=trunk-storage-tank2 slaves=sfp-sfpplus15,sfp-sfpplus16
/interface bridge port
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes \
interface=vlan-gs-ser
add bridge=bridge ingress-filtering=yes interface=trunk-storage-tank2 pvid=\
107
add bridge=bridge ingress-filtering=yes interface=sfp-sfpplus6 pvid=107
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes \
interface=trunk-ccr2-crs2
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes \
interface=sfp-sfpplus1
/interface bridge vlan
add bridge=bridge tagged=vlan-gs-ser,trunk-ccr2-crs2,sfp-sfpplus6,bridge \
vlan-ids=20
add bridge=bridge tagged=vlan-gs-ser,bridge,sfp-sfpplus6,trunk-ccr2-crs2 \
vlan-ids=103
add bridge=bridge tagged=vlan-gs-ser,bridge untagged=\
sfp-sfpplus6,trunk-storage-tank2 vlan-ids=107
add bridge=bridge tagged=sfp-sfpplus1,bridge vlan-ids=309
add bridge=bridge tagged=vlan-gs-ser,sfp-sfpplus6,trunk-storage-tank2,bridge \
vlan-ids=100
add bridge=bridge tagged=bridge,vlan-gs-ser,trunk-ccr2-crs2,sfp-sfpplus6 \
vlan-ids=111
add bridge=bridge tagged=bridge,sfp-sfpplus1,trunk-ccr2-crs2 vlan-ids=1001
/ip address
add address=*.*.*.*/29 interface=vlan-mgmt network=*.*.*.*