I've been trying to use a RB750Gr3 in bridge mode with a VPN server.
The situation is as follows:
Internet ---> Modem/router---> Mikrotik
1.1.1.1 ---> 192.168.5.1 ---> 192.168.5.100
Port 1 is connected to Modem/router
I need port 2,3,4,5 to be acting as switch.
What did I overlook?
Code: Select all
# jun/23/2017 18:54:29 by RouterOS 6.36.1
/interface bridge
add name=bridge1
/ip pool
add name=pool-VPN ranges=172.31.80.1-172.31.80.20
/ppp profile
add change-tcp-mss=yes dns-server=8.8.8.8 local-address=pool-VPN name=\
L2TP-Profile remote-address=pool-VPN use-upnp=no
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/interface l2tp-server server
set authentication=mschap2 default-profile=L2TP-Profile enabled=yes \
ipsec-secret=SOME-SUPER-TOP-SECRET-PASSWORD use-ipsec=yes
/ip address
add address=192.168.5.100/24 interface=ether2 network=192.168.5.0
/ip ipsec peer
add address=0.0.0.0/0 enc-algorithm=3des exchange-mode=main-l2tp secret=\
SOME-SUPER-TOP-SECRET-PASSWORD
/ip route
add distance=1 gateway=192.168.5.1
/ppp secret
add name=USERNAME password=SOME-SUPER-TOP-SECRET-PASSWORD profile=L2TP-Profile service=l2tp