How would this translate into update frequency for the clients?[...]
- SQL based realtime list generation
[...]
:local destPath "disk1/filterImport.rsc";
:local priority "2";
:local sn [:pick [/ip cloud get dns-name] 0 [:find [/ip cloud get dns-name] "."]];
/tool fetch mode=https url="https://bl.mikrotikfilters.com/secureFetch.php?priority=$priority" http-method=post http-data="$sn" dst-path="$destPath" output=file; /import file-name=$destPath; /file remove $destPath;
[admin@RBTEST] > /tool fetch mode=https dst-path=/disk1/filters.rsc url="https://bl.mikrotikfilters.com/fetch.php\?priority=1";
status: failed
failure: closing connection: <500 Internal Server Error> 35.236.78.203:443 (4)
[admin@RBTEST] > /tool fetch mode=https dst-path=/disk1/filters.rsc url="https://bl.mikrotikfilters.com/fetch.php?priority=1";
status: failed
failure: closing connection: <500 Internal Server Error> 35.236.78.203:443 (4)
you are missing the "?" in the url.[admin@CHR-O] > /tool fetch mode=https dst-path=/disk1/filters.rsc url="https://bl
.mikrotikfilters.com/fetch.phppriority=3";
status: failed
failure: closing connection: <404 Not Found> 35.236.78.203:443 (4)
[admin@CHR-O] > /tool fetch mode=https dst-path=/disk1/filters.rsc url="https://bl
.mikrotikfilters.com/fetch.phppriority=3";
status: failed
failure: closing connection: <404 Not Found> 35.236.78.203:443 (4)
Thanks SidUse \?
The script in post #9 was wrong.
The script is not wrong, it's intended to be a script, NOT command line.Use \?
The script in post #9 was wrong.
I hear that. Thank you Dave! I will be trying this out tonight to give you some more stress-testing data. Cheers!So, I *JUST* started coding this week, so this is really rough.. like pre-alpha. This is going to take some time.. I can code in python, php, perl, and C. but just because I can, doesn't mean I enjoy it. I really hate coding, it's boring and frustrating. Anyway..
the dev of this script/list uses both publicly available lists of "bad" ips (spamhaus , malcode ect), as well as his own "honeypot" devices which look for public IPs that are doing suspicious activities (then adds those IPs to his own "private" list, for distribution to ppl running his script , before he closed the service). Def was a great service + script, and one i plan on paying for once he re-launches.Hi, since I'm interested about the blacklist service and in order to evaluate whether it's useful to me, I'd like to know, what exactly is blacklisted?
Who/what created such list of IPs? Thanks in advance.
add action=add-src-to-address-list address-list=RAWATTACK2 address-list-timeout=127m chain=prerouting comment=RAW2ADD in-interface-list=WAN_LIST log-prefix="RAW2ADD: " src-address-list=RAWATTACK
add action=drop chain=prerouting comment=RAW2 in-interface-list=WAN_LIST log-prefix="RAW2: " src-address-list=RAWATTACK2
add action=add-src-to-address-list address-list=RAWATTACK address-list-timeout=37m chain=prerouting comment=RAW1ADD dst-port=8291,21,22,23,2000,7547,11211,135,137-139,548,80,8080,81,37215 in-interface-list=WAN_LIST log=yes log-prefix="RAW1: " protocol=tcp
add action=add-src-to-address-list address-list=RAWATTACK address-list-timeout=37m chain=prerouting comment=RAW1ADD dst-port=8291,21,22,23,2000,7547,11211,135,137-139,548,80,8080,81,37215 in-interface-list=WAN_LIST log=yes log-prefix="RAW1: " protocol=udp
add action=drop chain=prerouting disable=yes comment=RAW1 in-interface-list=WAN_LIST log-prefix="RAW1: " src-address-list=RAWATTACK
I'm not quite sure I follow what you are saying. I'm always open to more sources. The new system is very modular. So importing another source is as simple as coding an import module for it.Dave,
Have you considered using external to your network honeypots as source of offending IPs?
I use as the first frontier such RAW drop rules and all the time there are some IPs on the list of attackers.
It's running right now.Script is no longer functioning, no updates since last night.
Could it be possible to send to you lists of attacking IPs from my routers?I'm not quite sure I follow what you are saying. I'm always open to more sources. The new system is very modular. So importing another source is as simple as coding an import module for it....Have you considered using external to your network honeypots as source of offending IPs? ...
The lists are set for a max timeout of 24 hours. This is required so that false positives are not blocked for too long. The system is designed to be update every 1~6 hours.please prompt how to change a timeout of blacklist lifetime. for example for 7 days
Yes, I am working on that too. My plan is that the routers will add IP's to a dedicated address-list, and then a script will submit that list to the server, just as the honeypots do.Could it be possible to send to you lists of attacking IPs from my routers?
thanks for explanation, DaveThe lists are set for a max timeout of 24 hours. This is required so that false positives are not blocked for too long. The system is designed to be update every 1~6 hours.
Once the system goes public, each user will be able to configure the timeout for each router.
Thanks for the info. I have been running priority 3 on my 1009 for a couple days now. First time I have used RAW rules as well. Working like a champ!!! Your list is catching everything before anything hits my "blacklist" that I have built over time from things my router has personally seen. Super awesome. Keep up the good work! Once again THANK YOU Dave.currently, the priorities are pretty basic.
#1 is a short list of about 2000, consisting of just the most common botnet attacks. If I end up offering a free tier, this will be it.
#2 is a longer list of 30,000 to 40,000 IP's and subnets that includes #1, also adds most of the more common crap out there.
#3 is the largest list of 120,000 to 150,000+ IP's and subnets, includes #1 and #2, includes all "known" spammers, as well as unassigned subnets, proxies, etc.
/system scheduler
add interval=1m name=reportStatus on-event="/system script run reportStatus" policy=read,write,policy,test start-time=startup
/system script
add name=reportStatus owner=djoyce policy=read,test source=":local pa\
\_\"\"; :local pb \"\"; :local pc \"\"; :local pd \"\"; :local pe \"\"; :local pf \"\"; :local postdata \"\";\r\
\n:set pa [:tostr [ /system routerboard get ]]; :set pb [:tostr [ /system license get ]];\r\
\n:set pc [:tostr [ /system resource get ]]; :set pd [:tostr [ /system health get ]];\r\
\n:set pe [:tostr [/system identity get ]]; :set postdata [:toarray \"\$pa;\$pb;\$pc;\$pd;\$pe\"];\r\
\n/tool fetch mode=https url=\"https://bl.mikrotikfilters.com/hwstats.php\" http-method=post http-data=\"data=\$postdata\
\" output=file dst-path=hwdata.txt;"
board-name=RB1100AHx4 Dude Edition;
current-firmware=6.43rc51;
factory-firmware=3.36.3;
firmware-type=al2;
model=RouterBOARD 1100Dx4;
routerboard=true;
serial-number=735B073F0D77;
upgrade-firmware=6.43rc51;
features=;
nlevel=6;
software-id=NYLS-9KPC;
architecture-name=arm;
board-name=RB1100AHx4 Dude Edition;
build-time=Aug\/01\/2018 09:43:29;
cpu=ARMv7;
cpu-count=4;
cpu-frequency=1400;
cpu-load=0;
factory-software=6.38.4;
free-hdd-space=98365440;
free-memory=1012338688;
platform=MikroTik;
total-hdd-space=134479872;
total-memory=1073741824;
uptime=10:00:11;
version=6.43rc51 (testing);
current=488;
power-consumption=115;
psu1-voltage=243;
psu2-voltage=242;
temperature=53;
voltage=236;
name=Home_Firewall;
/tool fetch mode=https dst-path=/blacklist/filters.rsc url="https://bl.mikrotikfilters.com/fetch.php\?priority=3";
/import file-name=blacklist/filters.rsc
/file remove blacklist/filters.rsc
/ip firewall raw
add action=drop chain=prerouting comment="DROP intrusBL" src-address-list=intrusBL
add action=drop chain=prerouting comment="DROP intrusBL" dst-address-list=intrusBL
Running on my home router. Do you really want it reporting every minute?If anyone wants to help out more, I need more routers to report some stats to the server. This is part of the health monitoring and alerting system. If you paste the code into a terminal window, it will setup the script and start reporting.
The reporting and monitoring service is reported every minute. The client side can change that, depending on that type of response time they want.Running on my home router. Do you really want it reporting every minute?
Yes. Once the system is complete, you will be able to whitelist if needed. I filter 255.255.255.255 because I'm on a cable network and I see a crap-load of broadcast trash.Hi Dave,
In first list first address is 255.255.255.255 . Is that right?
Thanks,
Geo
The script is readily available to download and inspect before hand because any self respecting person would do that rather than blindly running it.I see everybody here is amazed how great service it is, but has anybody think about security risks of such service?
Importing third-party script to your router without any validation?
I wonder why this list is not provided as plain list of IPs and let everybody implement custom script parsing and validating the input.
I don't really downgrade all the effort author put into the service and I still think it can be useful, however definitely not as directly importable (and scheduled!) script.The script is readily available to download and inspect before hand because any self respecting person would do that rather than blindly running it.
Dave has been here for years providing this service to users in the community and is extremely well trusted, just don't pi$$ him off and you'll be fine
I will not use it. Or maybe I will, but before I will implement another script that extracts IPs from the file and apply them one by one.
Dave, please don't do it. I very little in all this understand, but your creation is a masterpiece. It isn't necessary to spoil all because of one fool.Due to people like this guy ^^^ the beta list will be limited to the "free" list of about 1800 IP's.
I do not want my 150,000 IP's collected by my honeypots being used for other people's services.
Dave please don't limit the Beta, don't let this guy be the driver for that. It is not worth it and hurts us that are your loyal followers. I am using your Priority 3 list and will start paying for it whenever you want. It is helping me immensely. Please don't limit the beta list to the small list......Oh BTW guys, my Honeypots alone are reporting over 37,000 ACTIVE botnet IP's for the last 12 hours.
Those IP's will NOT be included in the free list.
I was just about to post and say that my blacklist had decreased overnight from 140K+ to 2K!It's limited for now, hoping to have a very basic auth system in place by tomorrow morning. My server logs show at least 2 people trying VERY hard to figure out how to trick the server to sending the list to a wget/curl client. Sorry, but the blaintant abuse won't be tolerated.
I'll post a simple Google Form for registering ASAP.
Dave, although I am not in your area, I am next door in Idaho. I am very interested in setting up honeypots where I am at to contribute to the database however you see fit. How can we catch up on the phone etc to discuss more information that I don't want to post on the forum?on the flip side, if anyone is in Southern California (Rancho Cucamonga / Ontario / Pomona / San Bernardino) you are hit me up and I'd love to grab coffee and chat.
Hi BartoszP,Dave,
Have you considered using external to your network honeypots as source of offending IPs?
I use as the first frontier such RAW drop rules and all the time there are some IPs on the list of attackers.Code: Select alladd action=add-src-to-address-list address-list=RAWATTACK2 address-list-timeout=127m chain=prerouting comment=RAW2ADD in-interface-list=WAN_LIST log-prefix="RAW2ADD: " src-address-list=RAWATTACK add action=drop chain=prerouting comment=RAW2 in-interface-list=WAN_LIST log-prefix="RAW2: " src-address-list=RAWATTACK2 add action=add-src-to-address-list address-list=RAWATTACK address-list-timeout=37m chain=prerouting comment=RAW1ADD dst-port=8291,21,22,23,2000,7547,11211,135,137-139,548,80,8080,81,37215 in-interface-list=WAN_LIST log=yes log-prefix="RAW1: " protocol=tcp add action=add-src-to-address-list address-list=RAWATTACK address-list-timeout=37m chain=prerouting comment=RAW1ADD dst-port=8291,21,22,23,2000,7547,11211,135,137-139,548,80,8080,81,37215 in-interface-list=WAN_LIST log=yes log-prefix="RAW1: " protocol=udp add action=drop chain=prerouting disable=yes comment=RAW1 in-interface-list=WAN_LIST log-prefix="RAW1: " src-address-list=RAWATTACK
Good times, thankyou.Yes, I've blocked most of the IP's that are trying to leach the lists.
Still working on an auth system that is reliable. I think it's going to have to be based on the the Cloud DNS.. [/ip cloud set ddns-enable=yes] is going to be required, unless MikroTik gives me a way to authenticate better than that.
CHR even with trial license has IP Cloud now (starting v6.43)“Oh bugger” he says with his CHR! I may end up notifying you of my static IP and hoping you’d do me a solid then?
Ah man that is crazy, especially for the low cost you were looking to charge. Thank you Dave for the work you are putting in to this. It is a great service. Would still love to learn how to setup a honeypot to help contribute.As you can tell, I've slowed down on development.
Out of the 100+ people who filled out the notification form, more than 60% says they will not pay for this type of service.
Only about 15 say they will pay a commercial product. So, I'm going to take my time with it and try earning some income in other ways.
I'm sure I'll post more updates when I get more time.
/ip cloud set ddns-enabled=yes
:local destPath "disk1/filterImport.rsc";
:local priority "2";
:local sn [:pick [/ip cloud get dns-name] 0 [:find [/ip cloud get dns-name] "."]];
/tool fetch mode=https url="https://bl.mikrotikfilters.com/secureFetch.php?priority=$priority" http-method=post http-data="$sn" dst-path="$destPath" output=file; /import file-name=$destPath; /file remove $destPath;
As you can tell, I've slowed down on development.
Out of the 100+ people who filled out the notification form, more than 60% says they will not pay for this type of service.
Only about 15 say they will pay a commercial product. So, I'm going to take my time with it and try earning some income in other ways.
/system script> /tool fetch mode=https url="https://bl.mikrotikfilters.com/secureFetch.php\?priority=$priority" http-met
hod=post http-data="$sn" dst-path="$destPath" output=file; /import file-name=$destPath; /file remove $destPath;
status: finished
downloaded: 0KiBC-z pause]
duration: 1s
Script file loaded and executed successfully
invalid value for argument numbers
Dave does this script replace your old 'blacklistUpdate' script that was scheduled? Must I just schedule this new script as per before?I've implemented some of the new security functions. You will need to update the download script.
Cloud DDNS is *REQUIRED*. Which means you need the latest CHR with Cloud support./ip cloud set ddns-enabled=yes
Here is the new script.Code: Select all:local destPath "disk1/filterImport.rsc"; :local priority "2"; :local sn [:pick [/ip cloud get dns-name] 0 [:find [/ip cloud get dns-name] "."]]; /tool fetch mode=https url="https://bl.mikrotikfilters.com/secureFetch.php?priority=$priority" http-method=post http-data="$sn" dst-path="$destPath" output=file; /import file-name=$destPath; /file remove $destPath;
Hi, I'm not Dave but:Dave does this script replace your old 'blacklistUpdate' script that was scheduled? Must I just schedule this new script as per before?
Ta!Hi, I'm not Dave but:Dave does this script replace your old 'blacklistUpdate' script that was scheduled? Must I just schedule this new script as per before?
Yes and Yes :)
You need 6.43 on your CHR to run IP>Cloud and it has been confirmed there will be no IP>Cloud for x86 platform.for some reason many of my firewalls do not seem to have the version of the code that supports the ddns. So when I go to /ip there is no "cloud". This is true for both x86 versions and CHR running 6.42.7. Has anybody else seen this?
Well, the answer is simple: wait for the 6.43 release. Don't you want to run a potentially unstable Blacklist Filter (which is still in development from scratch) on your main router?@IntrusDave Can I ask if there is any way to relax this "need" for cloud? With 6.43 being an RC candidate many people won't run this on their "normal" equipment and only on test stuff. I love your script, I really do but I don't want to run a potentially unstable routerOS release on my main router.
I know Dave's script is fine though. Moving into RC channel and back can cause huge problems and sometimes full re-installation.Well, the answer is simple: wait for the 6.43 release. Don't you want to run a potentially unstable Blacklist Filter (which is still in development from scratch) on your main router?@IntrusDave Can I ask if there is any way to relax this "need" for cloud? With 6.43 being an RC candidate many people won't run this on their "normal" equipment and only on test stuff. I love your script, I really do but I don't want to run a potentially unstable routerOS release on my main router.
You must enable IP Cloud service first.But I get error in the log: Blacklist Authorization failed
Which is the active and good script?
Thank you! Works!!!!You must enable IP Cloud service first.But I get error in the log: Blacklist Authorization failed
Which is the active and good script?
OK! Thanks!!!Unfortunately, I don't have IPv6 yet. The system is designed for it, but I have no routers in IPv6 networks that I can test with. My home internet supports it, but it's so unstable, I don't bother with it.
No only IP based.And domain blacklist?
I don't find domain blacklisting very effective. Most botnets and viruses have their own DNS resolver and use hard codes servers, so it doesn't really help at the router level. And more and more are moving to dns over https.OK! Thanks!!!Unfortunately, I don't have IPv6 yet. The system is designed for it, but I have no routers in IPv6 networks that I can test with. My home internet supports it, but it's so unstable, I don't bother with it.
And domain blacklist?
Personally, I use a RAW Drop rule.Drop or redirect? Which one is better on firewall?
IP Cloud is used for identification now. Once the service is live, the serial number from IP cloud will be used for authorization. The script gets the serial number from the IP cloud, submits it via the http-post over TLS, this keeps your serial from being sent in the clear. When the server receives the request, the http-post data is pulled, the serial number is then used to do a DNS lookup via {xxxxxxxxx.sn.mynetname.net} and that IP is then matched to the IP that is making the request. If the IP's don't match, then the odds are that the serial number is a fake, or someone is trying to leach the list. It's not a perfect system, but as long as the mynetname service isn't hacked, it should be good enough to stop most from leaching the list.But I get error in the log: Blacklist Authorization failed
Which is the active and good script?
OK! Thanks!I don't find domain blacklisting very effective. Most botnets and viruses have their own DNS resolver and use hard codes servers, so it doesn't really help at the router level. And more and more are moving to dns over https.OK! Thanks!!!Unfortunately, I don't have IPv6 yet. The system is designed for it, but I have no routers in IPv6 networks that I can test with. My home internet supports it, but it's so unstable, I don't bother with it.
And domain blacklist?
Have you seen HE's free IPv6 tunnel https://tunnelbroker.net/? I've had one up for nearly a year.Unfortunately, I don't have IPv6 yet. The system is designed for it, but I have no routers in IPv6 networks that I can test with. My home internet supports it, but it's so unstable, I don't bother with it.
Here are a couple of Honeypot projects from my notes. I'm sure there are many more. It's one of those things I've been wanting to do one of these days.Dave,
Still very interested in learning how to setup a honeypot to collect addresses. Even if you are not to the point to accept other people's honeypot lists, could you do a brief write up to teach us the best way to setup a honeypot? Thanks!
If it helps and the IPv4 sevice is done, I can provide an IPv6 router as honeypot.Unfortunately, I don't have IPv6 yet. The system is designed for it, but I have no routers in IPv6 networks that I can test with. My home internet supports it, but it's so unstable, I don't bother with it.
Thanks for the update Dave.I'm in a holding pattern while my lawyer researches the EU "GDPR" laws.
It's looking like I will not be able to use 3rd party honeypots, as the GDPR requires companies to allow users to delete any data collected from there.
That means that anyone with a honeypot running on their router will be able to delete any IP's in the database that their router may have submitted.
While this may not sound like a big deal, it's ENTIRELY possible for a user to fake an update and delete the whole database.
Hey Dave,I'm in a holding pattern while my lawyer researches the EU "GDPR" laws.
It's looking like I will not be able to use 3rd party honeypots, as the GDPR requires companies to allow users to delete any data collected from there.
That means that anyone with a honeypot running on their router will be able to delete any IP's in the database that their router may have submitted.
While this may not sound like a big deal, it's ENTIRELY possible for a user to fake an update and delete the whole database.
This fucking GDPRIt's looking like I will not be able to use 3rd party honeypots, as the GDPR requires companies to allow users to delete any data collected from there.
Are you running IP > Cloud ? Would be the "easiest" thing to check at this point as it is a prerequisite.For IntusDave:
Do you have any problem or do you update? I run your script but the script didn't download nothing.
I thank you for your help!
Yes, IP -> Cloud is running. DDNS Enabled and updated.Are you running IP > Cloud ? Would be the "easiest" thing to check at this point as it is a prerequisite.For IntusDave:
Do you have any problem or do you update? I run your script but the script didn't download nothing.
I thank you for your help!
squidblacklist.org is not included, as it is a pay service. The IP's they have on the free lists are pretty much duplicates of my list 2.@Dave
Do you have IP blacklists from squidblacklist.org in priority 1 or 2?
Thanks!The server is hosted on the google cloud platform. It appears that Google has oversold the zone that my servers are in, and my servers have been taking offline to allow others to run. I'll be moving the server to a different zone ASAP.
How much memory use on routers with these Blacklist Filters?What are everyone's thoughts on using Patreon for the subscription service?
I've started setting up a page here: https://www.patreon.com/IntrusTechnologies
Once I have everything linked, the existing scripts will stop working and I will post the current scripts on the Patreon page.
The new script will not require any modification, as the server will select the list based on your router's serial number and IP address.
The system will also disable accounts that are using forged serial numbers or IP addresses.
What do you think about this service?: viewtopic.php?t=137632It's hard to give accurate numbers, but it looks like the List 1 uses about 768k, List 2 uses 3M, and List 3 uses 54M to load and 50M once the load is done. The other two load too fast on my RB110AHx4 to see the memory load update.
Any estimate regarding the end-of-service date as it is? I have to convince my boss of the benefits of being a paying member of the community and I do not want to be caught offguard.What are everyone's thoughts on using Patreon for the subscription service?
I've started setting up a page here: https://www.patreon.com/IntrusTechnologies
Once I have everything linked, the existing scripts will stop working and I will post the current scripts on the Patreon page.
The new script will not require any modification, as the server will select the list based on your router's serial number and IP address.
The system will also disable accounts that are using forged serial numbers or IP addresses.
I think it's a ripoff of my project by someone that hasn't been a part of the community as long as I have. I think I am far more transparent in the development process.What do you think about this service?: viewtopic.php?t=137632It's hard to give accurate numbers, but it looks like the List 1 uses about 768k, List 2 uses 3M, and List 3 uses 54M to load and 50M once the load is done. The other two load too fast on my RB110AHx4 to see the memory load update.
OK, now I'll be clear here Thanks.
squidblacklist.org is not included, as it is a pay service. The IP's they have on the free lists are pretty much duplicates of my list 2.
The goal is NO end-of-service date. This started out as a project out of a personal need, I shared it with the community because I thought others could use it too. Last year, the original service hit just over 17,000 active devices. I realized that several LARGE businesses were using the service and SELLING IT to their customers. At that point I felt that it was "fair" for me to be paying several hundred per month for servers and honeypots out of pocket, while others were making money off it it.Any estimate regarding the end-of-service date as it is? I have to convince my boss of the benefits of being a paying member of the community and I do not want to be caught offguard.What are everyone's thoughts on using Patreon for the subscription service?
I've started setting up a page here: https://www.patreon.com/IntrusTechnologies
Once I have everything linked, the existing scripts will stop working and I will post the current scripts on the Patreon page.
The new script will not require any modification, as the server will select the list based on your router's serial number and IP address.
The system will also disable accounts that are using forged serial numbers or IP addresses.
Keep the fantastic work!
I compared mine with that one - All of the IP's in that are also in mine. The key difference is the delivery method. My .rsc is much smaller and processed faster.OK, now I'll be clear here Thanks.
squidblacklist.org is not included, as it is a pay service. The IP's they have on the free lists are pretty much duplicates of my list 2.
Will test how much RAM a RB2011 needed. Only with priority 2
or priority 1 + drop.malicious.rsc
PS:
SBL Malicious IP Blacklist from: https://www.squidblacklist.org is free of charge.
Would be nice to be able to select priority 1, although you have paid for priority 2.The new script will not require any modification, as the server will select the list based on your router's serial number and IP address.
As for yearly payments - At this time, I am going to keep it monthly. I don't want to accept a payment for a year of service before I know the service will be able to sustain itself.
When I asked about the end-of-service as it is I was referring when the current scripts will be deactivated and only working via Patreon.The goal is NO end-of-service date. This started out as a project out of a personal need, I shared it with the community because I thought others could use it too. Last year, the original service hit just over 17,000 active devices. I realized that several LARGE businesses were using the service and SELLING IT to their customers. At that point I felt that it was "fair" for me to be paying several hundred per month for servers and honeypots out of pocket, while others were making money off it it.Any estimate regarding the end-of-service date as it is? I have to convince my boss of the benefits of being a paying member of the community and I do not want to be caught offguard.
Keep the fantastic work!
After January first the current your script will not work?My goal is January first.
Payment is automated via the Patreon page. Each Tier includes the Tier below it. I've updated the tires on the page to better explain what you get.Would be nice to be able to select priority 1, although you have paid for priority 2.The new script will not require any modification, as the server will select the list based on your router's serial number and IP address.
As for yearly payments - At this time, I am going to keep it monthly. I don't want to accept a payment for a year of service before I know the service will be able to sustain itself.
Uh, monthly. I hope the monthly payment can be automated.
https://www.patreon.com/IntrusTechnologiesHow to make a payment from Poland?
I'm already signed up! Thanks again for the great service Dave.What are everyone's thoughts on using Patreon for the subscription service?
I've started setting up a page here: https://www.patreon.com/IntrusTechnologies
Once I have everything linked, the existing scripts will stop working and I will post the current scripts on the Patreon page.
The new script will not require any modification, as the server will select the list based on your router's serial number and IP address.
The system will also disable accounts that are using forged serial numbers or IP addresses.
I'm using the priority 2 list on an RB2011. Memory is fine. I currently have free 74MB of 128MB with ~30k blacklist entries. The RB2011 is more CPU starved when it's updating the list or if you view the address list.
OK, now I'll be clear here Thanks.
Will test how much RAM a RB2011 needed. Only with priority 2
or priority 1 + drop.malicious.rsc
Perfect thank you.Payment is automated via the Patreon page. Each Tier includes the Tier below it. I've updated the tires on the page to better explain what you get.
I've deleted most of the drop.malicious.rsc address-list entrys (~30k blocklist.de) and switched to priority 2 (also about ~30k). I have 7 MB more Ram free. (Free Memory now 55MB)I'm using the priority 2 list on an RB2011. Memory is fine. I currently have free 74MB of 128MB with ~30k blacklist entries. The RB2011 is more CPU starved when it's updating the list or if you view the address list.
Sounds like an emotional response based on little fact. You would be better served by recognizing and supporting a like minded fellow provider who decided to share his work for his customers/clients with the community at large. The development cycle taken matches up with what I would have done, first being exposed to Josh Haven and the various sources, such as the Firehol lists, magically available whether you were on this less and less green earth or not. On his own he matured his script skills to be able to create the database and program with the flexibility and 'scalability' of his clients in mind (hex to larger units) which is critical to many of us with lesser units (not companies with fat wallets). Its stable, it works and its phukking affordable. He obviously has put much time and effort into the program, considering the servers required and the fail over and many other detailed minutia it takes to run a credible service. As to transparency, what are you referring too? He opened up his development to anybody that was interested for testing purpose. He clearly outlines his sources which do not contain 'secret' honeypots.I think it's a ripoff of my project by someone that hasn't been a part of the community as long as I have. I think I am far more transparent in the development process.What do you think about this service?: viewtopic.php?t=137632It's hard to give accurate numbers, but it looks like the List 1 uses about 768k, List 2 uses 3M, and List 3 uses 54M to load and 50M once the load is done. The other two load too fast on my RB110AHx4 to see the memory load update.
My Also,The service works well, the first payment has been sent.
:local destPath "disk1/filterImport.rsc";
:local priority "2";
:local sn [:pick [/ip cloud get dns-name] 0 [:find [/ip cloud get dns-name] "."]];
/tool fetch mode=https url="https://bl.mikrotikfilters.com/fetch.php?priority=$priority" http-method=post http-data="$sn" dst-path="$destPath" output=file; /import file-name=$destPath; /file remove $destPath;
Script is 4 post higher.Can someone sum up the latest script/instructions on how to install the new service?
That script is running fine. I am just wondering about the frequency of the scheduler and maybe other things that were installed with the old installer.Script is 4 post higher.
That script is running fine. I am just wondering about the frequency of the scheduler and maybe other things that were installed with the old installer.
/ip cloud set ddns-enabled=yes update-time=no
/system script add dont-require-permissions=no name=blacklistScript owner=admin policy=read,write,policy,test source=\
\n"# Intrus Technologies blacklist installer/updater\
\n# \A92017 David Joyce, Intrus Technologies\
\n\
\n:local destPath \"filterImport.rsc\";\
\n:local priority \"2\";\
\n\
\n#If you do not want to delete the script directly after importing, remove the comment and paste one in the last line\
\n#:do { /file remove \$destPath } on-error={};\
\n\
\n:local sn [:pick [/ip cloud get dns-name] 0 [:find [/ip cloud get dns-name] \".\"]];\
\n/tool fetch mode=https url=\"https://bl.mikrotikfilters.com/fetch.php\?priority=\$priority\" http-method=post http-data=\"\$sn\" dst-path=\"\$destPath\" output=file;\
\n/import file-name=\$destPath;\
\n/file remove \$destPath;\
\n"
/system scheduler add interval=12h name=blacklistScriptUpdate on-event="/system script run blacklistScript" policy=read,write,policy,test start-date=jan/01/1970 start-time=06:00:00
/system scheduler add name=blacklistScriptUpdateOnBoot on-event=":delay 30;system script run blacklistScript" policy=read,write,policy,test start-time=startup
/ip firewall raw add action=drop chain=prerouting comment="Drop WAN connections from 'intrusBL' blacklisted hosts <- Src. Address List: intrusBL" in-interface-list=WAN src-address-list=intrusBL
Yes, somewhere up above, there is a Patreon link, as well as PayPal links.It can be paid by Patreon?
Thank you. No worries, I’ve survived everything else life has tossed my way. Even an earthquake that brought my apartment down on me.Humans can be truly awfull but using you undergoing your treatment to steal from you then there are no words to describe my feelings about that.
I am sorry to read that you are ill and that the outcome is uncertain. I wish all the strength to overcome this horrible time in your life.
I'm still working on the IPv6 version of the list. My home ISP has finally managed to provide a stable v6 connection, so I'll be able to start testing.
I'm curious how much bandwidth your service consumes... there is another poster complaining about $500/mon bandwidth cost for his service, but frankly I cannot understand how this can happen.I regret to inform you all that I have shut down the servers.
With over 35,000 routers hitting the server every few hours, and only 10 supporters (totally $50/month), the expenses are not even remotely being covered. I'm putting out almost $500/month now just in bandwidth costs.
any way to use RAW? or just regular firewall rule?Code: Select all/ip firewall raw add action=drop chain=prerouting comment="DROP intrusBL" src-address-list=intrusBL add action=drop chain=prerouting comment="DROP intrusBL" dst-address-list=intrusBL
Address-list, src-address-list and dst-address-list are three different parameters. You're talking about one and look at the description of another.the problem is, with RB, that ip firewall raw action=drop doent work with src-address-list=intrusBL
according to documentation:
address-list (string; Default: ) Name of the address list to be used. Applicable if action is add-dst-to-address-list or add-src-to-address-list
https://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Raw
any way to use RAW? or just regular firewall rule?Code: Select all/ip firewall raw add action=drop chain=prerouting comment="DROP intrusBL" src-address-list=intrusBL add action=drop chain=prerouting comment="DROP intrusBL" dst-address-list=intrusBL
me too.I thought that more people would be willing to help, but sadly not.