I have 2 CHRs in different locations, with an EoIPv6 tunnel between them. Each router in each location has it's own upstream peer (different ASNs), and when I try to establish a BGP session between the two CHRs, the tunnel starts flapping like a fish out of water.
I've tried filtering out of the iBGP session the external upstream v6 address prefixes (as I thought that it was trying to use the iBGP as the best route, which it couldn't do because the tunnel was established before BGP), to no avail. Does anyone have any ideas? I for the life of me, cannot work it out.
Router 1:
Code: Select all
/ipv6 address
add address=n:n:n:491d:5400:1ff:fee3:7b24 advertise=no interface=ether1
add address=fd00:1::1/126 advertise=no interface=tun1-v6
/interface eoipv6
add ipsec-secret=abc123blah local-address=n:n:n:491d:5400:1ff:fee3:7b24 loop-protect-disable-time=0s loop-protect-send-interval=0s mac-address=nn:nn:nn:nn:nn:nn name=tun1-v6 remote-address=n:n:n:67::1 tunnel-id=2002
/routing bgp peer
add address-families=ipv6 disabled=yes hold-time=5m in-filter=IMPORT-ASnn8510-V6 instance=ASnn8510 name=ASnn8510-LON-V6 out-filter=EXPORT-ASnn8510-V6 remote-address=fd00:1::2 remote-as=nn8510 ttl=default
Router 2:
Code: Select all
/ipv6 address
add address=n:n:n:67::1/48 advertise=no interface=ether1
add address=fd00:1::2/126 advertise=no interface=tun1-v6
/interface eoipv6
add ipsec-secret=abc123blah local-address=n:n:n:67::1 loop-protect-disable-time=0s loop-protect-send-interval=0s mac-address=nn:nn:nn:nn:nn:nn name=tun1-v6 remote-address=n:n:n:491d:5400:1ff:fee3:7b24 tunnel-id=2002
/routing bgp peer
add address-families=ipv6 disabled=yes hold-time=5m in-filter=IMPORT-ASnn8510-V6 instance=ASnn8510 name=ASnn8510-SYD-V6 out-filter=EXPORT-ASnn8510-V6 remote-address=fd00:1::1 remote-as=nn8510 ttl=default
Christopher H.