Can you please check my configuration and tell me what is wrog? it will make me crazy
Configuration:
Code: Select all
/system routerboard pr
routerboard: yes
model: CCR1009-8G-1S-1S+
firmware-type: tilegx
factory-firmware: 3.22
current-firmware: 6.44
upgrade-firmware: 6.44
I have a setup PCC LB setup over 4 VDSL lines, all local LAN's use the LB rules.. and i have this problems:
1. Sometimes connections from local LAN 192.168.5.0/24 (SIP phones), cannot reach the LAN subnet 192.168.2.0/24 (address 192.168.2.21 - asterisk) , and i have figured out that some times connections is mark as one of PCC LB connection mark pppoe-dsl-1-pcc-con ... and there is no reason to mark local lan to local lan like that :/ (so i remove connection few times until pppoe-dsl-1-pcc-mark is not wissible on that session in /ip firewall connections.
2. 10.17.1.0/24 is my OSPF range - in connections i see that simmilar problem, but in these case OSPF address marks multicast 224.0.0.5 as one of connections for loadbalance pcc ... (see picture)
3. And if i VPN to router (PPtP) get address 10.0.1.8, local addrs 10.0.1.1 (simple pptp config) , cannot reach nothing except 10.0.1.1 and all subnets gateway , ex 192.168.2.1 but not 192.168.2.21 witch is in the same subnet, until i set this:
Code: Select all
/ip firewall nat
add action=masquerade chain=srcnat disabled=yes dst-address-list=local-addr src-address=10.0.1.0/24
router config:
Code: Select all
/ip firewall address-list
add address=192.168.0.0/16 list=local-addr
add address=10.17.1.0/24 list=local-addr
add address=10.0.1.0/24 list=local-addr
add address=10.199.199.0/24 list=local-addr
add address=192.168.110.0/24 list=users_network
add address=192.168.111.0/24 list=users_network
add address=192.168.112.0/24 list=users_network
add address=192.168.113.0/24 list=users_network
add address=192.168.114.0/24 list=users_network
add address=192.168.210.0/23 list=users_network
add address=192.168.0.0/16 comment=" - load balancing addresses" list=\
access_internet_pcc
add address=10.0.0.0/8 comment=" - load balancing addresses" disabled=\
yes list=access_internet_pcc
add address=10.0.0.0/8 comment=" - private addresses" disabled=yes list=\
private_addresses
add address=172.16.0.0/12 comment=" - private addresses" disabled=yes \
list=private_addresses
add address=192.168.0.0/16 comment=" - private addresses" list=\
private_addresses
add address=10.17.1.0/24 list=private_addresses
add address=10.17.1.0/24 comment=" - load balancing addresses" list=\
access_internet_pcc
Code: Select all
/ip firewall mangle
add action=mark-routing chain=prerouting comment=\
" - mark routing - direct access (dsl-1)" dst-address-list=\
!private_addresses dst-address-type=!local new-routing-mark=\
pppoe-dsl-1-traffic passthrough=no src-address-list=\
access_internet_pppoe-dsl-1
add action=mark-routing chain=prerouting comment=\
" - mark routing - direct access (dsl-2)" dst-address-list=\
!private_addresses dst-address-type=!local new-routing-mark=\
pppoe-dsl-2-traffic passthrough=no src-address-list=\
access_internet_pppoe-dsl-2
add action=mark-connection chain=input comment=\
" - mark connection - IN dsl-1 -> OUT dsl-1" in-interface=\
pppoe-dsl-1 new-connection-mark=pppoe-dsl-1-conn passthrough=yes
add action=mark-routing chain=output comment=\
" - mark routing - IN dsl-1 -> OUT dsl-1" connection-mark=\
pppoe-dsl-1-conn new-routing-mark=pppoe-dsl-1-traffic passthrough=no
add action=mark-connection chain=input comment=\
" - mark connection - IN dsl-2 -> OUT dsl-2" in-interface=\
pppoe-dsl-2 new-connection-mark=pppoe-dsl-2-conn passthrough=yes
add action=mark-routing chain=output comment=\
" - mark routing - IN dsl-2 -> OUT dsl-2" connection-mark=\
pppoe-dsl-2-conn new-routing-mark=pppoe-dsl-2-traffic passthrough=no
add action=mark-connection chain=input comment=\
" - mark connection - IN dsl-3 -> OUT dsl-3" in-interface=\
pppoe-dsl-3 new-connection-mark=pppoe-dsl-3-conn passthrough=yes
add action=mark-routing chain=output comment=\
" - mark routing - IN dsl-3 -> OUT dsl-3" connection-mark=\
pppoe-dsl-3-conn new-routing-mark=pppoe-dsl-3-traffic passthrough=no
add action=mark-connection chain=input comment=\
" - mark connection - IN dsl-4 -> OUT dsl-4" in-interface=\
pppoe-dsl-4 new-connection-mark=pppoe-dsl-4-conn passthrough=yes
add action=mark-routing chain=output comment=\
" - mark routing - IN dsl-4 -> OUT dsl-4" connection-mark=\
pppoe-dsl-4-conn new-routing-mark=pppoe-dsl-4-traffic passthrough=no
add action=mark-connection chain=forward comment=" - mark connection for \
new conn (packet forward) - IN dsl-1 -> OUT dsl-1" connection-state=new \
in-interface=pppoe-dsl-1 new-connection-mark=pppoe-dsl-1-pfw passthrough=\
no
add action=mark-routing chain=prerouting comment=" - mark routing for new\
\_conn (packet forward) - IN dsl-1 -> OUT dsl-1" connection-mark=\
pppoe-dsl-1-pfw new-routing-mark=pppoe-dsl-1-traffic passthrough=no \
src-address-list=port_forwarding_addresses
add action=mark-connection chain=forward comment=" - mark connection for \
new conn (packet forward) - IN dsl-2 -> OUT dsl-2" connection-state=new \
in-interface=pppoe-dsl-2 new-connection-mark=pppoe-dsl-2-pfw passthrough=\
no
add action=mark-routing chain=prerouting comment=" - mark routing for new\
\_conn (packet forward) - IN dsl-2 -> OUT dsl-2" connection-mark=\
pppoe-dsl-2-pfw new-routing-mark=pppoe-dsl-2-traffic passthrough=no \
src-address-list=port_forwarding_addresses
add action=mark-connection chain=forward comment=" - mark connection for \
new conn (packet forward) - IN dsl-3 -> OUT dsl-3" connection-state=new \
in-interface=pppoe-dsl-3 new-connection-mark=pppoe-dsl-3-pfw passthrough=\
no
add action=mark-routing chain=prerouting comment=" - mark routing for new\
\_conn (packet forward) - IN dsl-3 -> OUT dsl-3" connection-mark=\
pppoe-dsl-3-pfw new-routing-mark=pppoe-dsl-3-traffic passthrough=no \
src-address-list=port_forwarding_addresses
add action=mark-connection chain=forward comment=" - mark connection for \
new conn (packet forward) - IN dsl-4 -> OUT dsl-4" connection-state=new \
in-interface=pppoe-dsl-4 new-connection-mark=pppoe-dsl-4-pfw passthrough=\
no
add action=mark-routing chain=prerouting comment=" - mark routing for new\
\_conn (packet forward) - IN dsl-4 -> OUT dsl-4" connection-mark=\
pppoe-dsl-4-pfw new-routing-mark=pppoe-dsl-4-traffic passthrough=no \
src-address-list=port_forwarding_addresses
add action=accept chain=prerouting comment=" - accept (dsl-1)" \
in-interface=pppoe-dsl-1
add action=accept chain=prerouting comment=" - accept (dsl-2)" \
in-interface=pppoe-dsl-2
add action=accept chain=prerouting comment=" - accept (dsl-3)" \
in-interface=pppoe-dsl-3
add action=accept chain=prerouting comment=" - accept (dsl-4)" \
in-interface=pppoe-dsl-4
add action=mark-connection chain=prerouting comment=" - pcc 4/0 (dsl-1)" \
dst-address-list=!private_addresses dst-address-type=!local \
new-connection-mark=pppoe-dsl-1-pcc-conn passthrough=yes \
per-connection-classifier=both-addresses:4/0 src-address-list=\
access_internet_pcc
add action=mark-connection chain=prerouting comment=" - pcc 4/1 (dsl-2)" \
dst-address-list=!private_addresses dst-address-type=!local \
new-connection-mark=pppoe-dsl-2-pcc-conn passthrough=yes \
per-connection-classifier=both-addresses:4/1 src-address-list=\
access_internet_pcc
add action=mark-connection chain=prerouting comment=" - pcc 4/2 (dsl-3)" \
dst-address-list=!private_addresses dst-address-type=!local \
new-connection-mark=pppoe-dsl-3-pcc-conn passthrough=yes \
per-connection-classifier=both-addresses:4/2 src-address-list=\
access_internet_pcc
add action=mark-connection chain=prerouting comment=" - pcc 4/3 (dsl-4)" \
dst-address-list=!private_addresses dst-address-type=!local \
new-connection-mark=pppoe-dsl-4-pcc-conn passthrough=yes \
per-connection-classifier=both-addresses:4/3 src-address-list=\
access_internet_pcc
add action=mark-routing chain=prerouting comment=\
" - mark routing for pcc (dsl-1)" connection-mark=\
pppoe-dsl-1-pcc-conn new-routing-mark=pppoe-dsl-1-pcc passthrough=yes
add action=mark-routing chain=prerouting comment=\
" - mark routing for pcc (dsl-2)" connection-mark=\
pppoe-dsl-2-pcc-conn new-routing-mark=pppoe-dsl-2-pcc passthrough=yes
add action=mark-routing chain=prerouting comment=\
" - mark routing for pcc (dsl-3)" connection-mark=\
pppoe-dsl-3-pcc-conn new-routing-mark=pppoe-dsl-3-pcc passthrough=yes
add action=mark-routing chain=prerouting comment=\
" - mark routing for pcc (dsl-4)" connection-mark=\
pppoe-dsl-4-pcc-conn new-routing-mark=pppoe-dsl-4-pcc passthrough=yes
Code: Select all
/ip route
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-1) - distance 1" distance=1 gateway=\
pppoe-dsl-1 routing-mark=pppoe-dsl-1-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-2) - distance 2" distance=2 gateway=\
pppoe-dsl-2 routing-mark=pppoe-dsl-1-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-3) - distance 3" distance=3 gateway=\
pppoe-dsl-3 routing-mark=pppoe-dsl-1-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-4) - distance 4" distance=4 gateway=\
pppoe-dsl-4 routing-mark=pppoe-dsl-1-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-2) - distance 1" distance=1 gateway=\
pppoe-dsl-2 routing-mark=pppoe-dsl-2-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-1) - distance 2" distance=2 gateway=\
pppoe-dsl-1 routing-mark=pppoe-dsl-2-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-3) - distance 3" distance=3 gateway=\
pppoe-dsl-3 routing-mark=pppoe-dsl-2-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-4) - distance 4" distance=4 gateway=\
pppoe-dsl-4 routing-mark=pppoe-dsl-2-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-3) - distance 1" distance=1 gateway=\
pppoe-dsl-3 routing-mark=pppoe-dsl-3-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-1) - distance 2" distance=2 gateway=\
pppoe-dsl-1 routing-mark=pppoe-dsl-3-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-2) - distance 3" distance=3 gateway=\
pppoe-dsl-2 routing-mark=pppoe-dsl-3-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-4) - distance 4" distance=4 gateway=\
pppoe-dsl-4 routing-mark=pppoe-dsl-3-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-4) - distance 1" distance=1 gateway=\
pppoe-dsl-4 routing-mark=pppoe-dsl-4-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-1) - distance 2" distance=2 gateway=\
pppoe-dsl-1 routing-mark=pppoe-dsl-4-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-2) - distance 3" distance=3 gateway=\
pppoe-dsl-2 routing-mark=pppoe-dsl-4-traffic
add check-gateway=arp comment=\
" - traffic route (pppoe-dsl-3) - distance 4" distance=4 gateway=\
pppoe-dsl-3 routing-mark=pppoe-dsl-4-traffic
add check-gateway=arp comment=" - PCC route (pppoe-dsl-1) - distance 1" \
distance=1 gateway=pppoe-dsl-1 routing-mark=pppoe-dsl-1-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-2) - distance 2" \
distance=2 gateway=pppoe-dsl-2 routing-mark=pppoe-dsl-1-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-3) - distance 3" \
distance=3 gateway=pppoe-dsl-3 routing-mark=pppoe-dsl-1-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-4) - distance 4" \
distance=4 gateway=pppoe-dsl-4 routing-mark=pppoe-dsl-1-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-2) - distance 1" \
distance=1 gateway=pppoe-dsl-2 routing-mark=pppoe-dsl-2-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-1) - distance 2" \
distance=2 gateway=pppoe-dsl-1 routing-mark=pppoe-dsl-2-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-3) - distance 3" \
distance=3 gateway=pppoe-dsl-3 routing-mark=pppoe-dsl-2-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-4) - distance 4" \
distance=4 gateway=pppoe-dsl-4 routing-mark=pppoe-dsl-2-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-3) - distance 1" \
distance=1 gateway=pppoe-dsl-3 routing-mark=pppoe-dsl-3-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-1) - distance 2" \
distance=2 gateway=pppoe-dsl-1 routing-mark=pppoe-dsl-3-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-2) - distance 3" \
distance=3 gateway=pppoe-dsl-2 routing-mark=pppoe-dsl-3-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-4) - distance 4" \
distance=4 gateway=pppoe-dsl-4 routing-mark=pppoe-dsl-3-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-4) - distance 1" \
distance=1 gateway=pppoe-dsl-4 routing-mark=pppoe-dsl-4-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-1) - distance 2" \
distance=2 gateway=pppoe-dsl-1 routing-mark=pppoe-dsl-4-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-2) - distance 3" \
distance=3 gateway=pppoe-dsl-2 routing-mark=pppoe-dsl-4-pcc
add check-gateway=arp comment=" - PCC route (pppoe-dsl-3) - distance 4" \
distance=4 gateway=pppoe-dsl-3 routing-mark=pppoe-dsl-4-pcc
add check-gateway=ping comment=\
" - default route (pppoe-dsl-3) - distance 1" distance=1 gateway=\
pppoe-dsl-3
add check-gateway=arp comment=\
" - default route (pppoe-dsl-2) - distance 1" distance=1 gateway=\
pppoe-dsl-2
add check-gateway=arp comment=\
" - default route (pppoe-dsl-1) - distance 1" distance=1 gateway=\
pppoe-dsl-1
add check-gateway=ping comment=\
" - default route (pppoe-dsl-4) - distance 1" distance=1 gateway=\
pppoe-dsl-4
add disabled=yes distance=110 dst-address=10.17.1.19/32 gateway=10.17.1.78 \
scope=20
add disabled=yes distance=110 dst-address=10.17.1.19/32 gateway=10.17.1.78 \
scope=20
add distance=1 dst-address=10.17.1.90/32 gateway=10.17.1.34
add distance=1 dst-address=10.17.1.90/32 gateway=10.17.1.34
Code: Select all
/ip firewall nat
add action=masquerade chain=srcnat comment="masquarade dsl1" out-interface=\
pppoe-dsl-1
add action=masquerade chain=srcnat comment="masquarade dsl2" out-interface=\
pppoe-dsl-2
add action=masquerade chain=srcnat comment="masquarade dsl3" out-interface=\
pppoe-dsl-3
add action=masquerade chain=srcnat comment="masquarade dsl4" out-interface=\
pppoe-dsl-4