Yes, although you should use private IP addresses internally, I'd suggest something like 192.168.99.x
For the first Mikrotik, wlan1 operating as a station with a DHCP client to pick up an IP and gateway from the host, ether1 with IP 192.168.99.1 and DHCP server, DNS proxy and NAT for your devices
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto ssid=HOSTSSID wireless-protocol=802.11 wps-mode=disabled
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=HOSTPASSWORD
/ip pool
add name=dhcp ranges=192.168.99.100-192.168.99.199
/ip dhcp-server
add address-pool=dhcp disabled=no interface=ether1 name=dhcp1
/ip address
add address=192.168.99.1/24 interface=ether1 network=192.168.99.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=wlan1
/ip dhcp-server network
add address=192.168.99.0/24 dns-server=192.168.99.1 gateway=192.168.99.1
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1
For the second Mikrotik, wlan1 operating as an AP, a bridge for ether1 and wlan1 with static IP, default route and DNS provided by first Mikrotik (only needed for this Mikrotik to access the internet)
/interface bridge
add name=bridge protocol-mode=none
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MYSSID wireless-protocol=802.11 wps-mode=disabled
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=MYPASSWORD
/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge comment=defconf interface=wlan1
/ip address
add address=192.168.99.2/24 interface=bridge network=192.168.99.0
/ip dns
set servers=192.168.99.1
/ip route
add distance=1 gateway=192.168.99.1
These are not full configs, firewalling on the first Mikrotik would be good, but gives you the idea of what is needed.