I do not use the IPsec wizard in the L2TP server settings. After performing the IPsec configuration using PSK everything works fine but with certificates I have a "no identity suits proposal" error.
It occurs on both Windows 10 and Android.
My config:
/ip ipsec profile
add dh-group=ecp256,ecp384,ecp521,ec2n185,ec2n155,modp8192,modp6144,modp4096,modp3072,modp2048,modp1536,modp1024,modp768 enc-algorithm=aes-256,camellia-256,aes-192,camellia-192,aes-128,camellia-128,3des,blowfish,des name=l2tp_profile
/ip ipsec peer
add name=peer1 passive=yes profile=l2tp_profile
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha512,sha256,sha1,md5,null enc-algorithms=\
aes-256-cbc,aes-256-ctr,aes-256-gcm,camellia-256,aes-192-cbc,aes-192-ctr,aes-192-gcm,camellia-192,aes-128-cbc,aes-128-ctr,aes-128-gcm,camellia-128,3des,blowfish,twofish,des,null pfs-group=none
/ppp profile
add name=L2TP use-compression=no use-encryption=required use-ipv6=no use-mpls=no use-upnp=no
/ip neighbor discovery-settings
set discover-interface-list=none
/interface l2tp-server server
set authentication=mschap2 default-profile=L2TP enabled=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/ip ipsec identity
add auth-method=rsa-signature certificate=Server generate-policy=port-strict match-by=certificate notrack-chain=prerouting peer=peer1 remote-certificate=Client
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh port=57185
set api disabled=yes
set api-ssl disabled=yes
/ppp secret
add local-address=10.10.10.1 name=wmanka password= profile=L2TP remote-address=10.10.10.2
/tool mac-server
set allowed-interface-list=none
/tool mac-server mac-winbox
set allowed-interface-list=none
/tool mac-server ping
set enabled=no
certificate print detail
Flags: K - private-key, D - dsa, L - crl, C - smart-card-key, A - authority, I - issued, R - revoked, E - expired, T - trusted
0 K A T name="CA" digest-algorithm=sha256 country="PL" common-name="IP" key-size=8192 subject-alt-name="" days-valid=365 trusted=yes key-usage=key-cert-sign,crl-sign serial-number="5BAC4F56F5046670"
fingerprint="2afed65843fe8f73fc09623943b71057226c5f92f3ee29c3e618b39bda4300fa" invalid-before=may/06/2019 13:30:05 invalid-after=may/05/2020 13:30:05 expires-after=52w14h34m27s
1 K I T name="Server" digest-algorithm=sha256 country="PL" common-name="IP" key-size=8192 subject-alt-name="" days-valid=365 trusted=yes key-usage=digital-signature,key-encipherment,data-encipherment,tls-server ca=CA
serial-number="09D94549811F2874" fingerprint="1ad16b1c7a1340d8b123e79cf17e1eafff2cf11fc8b2c074403ece99f6babf17" invalid-before=may/06/2019 13:49:50 invalid-after=may/05/2020 13:49:50 expires-after=52w14h54m12s
2 K I name="Client" digest-algorithm=sha256 country="PL" common-name="mail" key-size=8192 subject-alt-name="" days-valid=365 trusted=no key-usage=tls-client ca=CA serial-number="3D25B6C52192A1AF"
fingerprint="116a6c4e2448ae5fc9e940749369aa0c0e4380eb0a8443d55d77fce4eb422f97" invalid-before=may/06/2019 13:55:39 invalid-after=may/05/2020 13:55:39 expires-after=52w15h1s
In log prom try to connect I have this:
22:52:54 ipsec,debug ===== received 408 bytes from
22:52:54 ipsec,debug,packet 0587cc63 31d27009 00000000 00000000 01100200 00000000 00000198 0d0000d4
22:52:54 ipsec,debug,packet 00000001 00000001 000000c8 01010005 03000028 01010000 80010007 800e0100
22:52:54 ipsec,debug,packet 80020002 80040014 80030003 800b0001 000c0004 00007080 03000028 02010000
22:52:54 ipsec,debug,packet 80010007 800e0080 80020002 80040013 80030003 800b0001 000c0004 00007080
22:52:54 ipsec,debug,packet 03000028 03010000 80010007 800e0100 80020002 8004000e 80030003 800b0001
22:52:54 ipsec,debug,packet 000c0004 00007080 03000024 04010000 80010005 80020002 8004000e 80030003
22:52:54 ipsec,debug,packet 800b0001 000c0004 00007080 00000024 05010000 80010005 80020002 80040002
22:52:54 ipsec,debug,packet 80030003 800b0001 000c0004 00007080 0d000018 01528bbb c0069612 1849ab9a
22:52:54 ipsec,debug,packet 1c5b2a51 00000001 0d000018 1e2b5169 05991c7d 7c96fcbf b587e461 00000009
22:52:54 ipsec,debug,packet 0d000014 4a131c81 07035845 5c5728f2 0e95452f 0d000014 90cb8091 3ebb696e
22:52:54 ipsec,debug,packet 086381b5 ec427b1f 0d000014 4048b7d5 6ebce885 25e7de7f 00d6c2d3 0d000014
22:52:54 ipsec,debug,packet fb1de3cd f341b7ea 16b7e5be 0855f120 0d000014 26244d38 eddb61b3 172a36e3
22:52:54 ipsec,debug,packet d0cfb819 00000014 e3a5966a 76379fe7 07228231 e5ce8652
22:52:54 ipsec,debug ===
22:52:54 ipsec,info respond new phase 1 (Identity Protection):
22:52:54 ipsec,debug begin.
22:52:54 ipsec,debug seen nptype=1(sa) len=212
22:52:54 ipsec,debug seen nptype=13(vid) len=24
22:52:54 ipsec,debug seen nptype=13(vid) len=24
22:52:54 ipsec,debug seen nptype=13(vid) len=20
22:52:54 ipsec,debug seen nptype=13(vid) len=20
22:52:54 ipsec,debug seen nptype=13(vid) len=20
22:52:54 ipsec,debug seen nptype=13(vid) len=20
22:52:54 ipsec,debug seen nptype=13(vid) len=20
22:52:54 ipsec,debug seen nptype=13(vid) len=20
22:52:54 ipsec,debug succeed.
22:52:54 ipsec,debug received unknown Vendor ID
22:52:54 ipsec,debug 01528bbb c0069612 1849ab9a 1c5b2a51 00000001
22:52:54 ipsec received long Microsoft ID: MS NT5 ISAKMPOAKLEY
22:52:54 ipsec received Vendor ID: RFC 3947
22:52:54 ipsec received Vendor ID: draft-ietf-ipsec-nat-t-ike-02\n
22:52:54 ipsec received Vendor ID: FRAGMENTATION
22:52:54 ipsec Fragmentation enabled
22:52:54 ipsec,debug received unknown Vendor ID
22:52:54 ipsec,debug fb1de3cd f341b7ea 16b7e5be 0855f120
22:52:54 ipsec,debug received unknown Vendor ID
22:52:54 ipsec,debug 26244d38 eddb61b3 172a36e3 d0cfb819
22:52:54 ipsec,debug received unknown Vendor ID
22:52:54 ipsec,debug e3a5966a 76379fe7 07228231 e5ce8652
22:52:54 ipsec CLIENT_IP Selected NAT-T version: RFC 3947
22:52:54 ipsec,debug total SA len=208
22:52:54 ipsec,debug 00000001 00000001 000000c8 01010005 03000028 01010000 80010007 800e0100
22:52:54 ipsec,debug 80020002 80040014 80030003 800b0001 000c0004 00007080 03000028 02010000
22:52:54 ipsec,debug 80010007 800e0080 80020002 80040013 80030003 800b0001 000c0004 00007080
22:52:54 ipsec,debug 03000028 03010000 80010007 800e0100 80020002 8004000e 80030003 800b0001
22:52:54 ipsec,debug 000c0004 00007080 03000024 04010000 80010005 80020002 8004000e 80030003
22:52:54 ipsec,debug 800b0001 000c0004 00007080 00000024 05010000 80010005 80020002 80040002
22:52:54 ipsec,debug 80030003 800b0001 000c0004 00007080
22:52:54 ipsec,debug begin.
22:52:54 ipsec,debug seen nptype=2(prop) len=200
22:52:54 ipsec,debug succeed.
22:52:54 ipsec,debug proposal #1 len=200
22:52:54 ipsec,debug begin.
22:52:54 ipsec,debug seen nptype=3(trns) len=40
22:52:54 ipsec,debug seen nptype=3(trns) len=40
22:52:54 ipsec,debug seen nptype=3(trns) len=40
22:52:54 ipsec,debug seen nptype=3(trns) len=36
22:52:54 ipsec,debug seen nptype=3(trns) len=36
22:52:54 ipsec,debug succeed.
22:52:54 ipsec,debug transform #1 len=40
22:52:54 ipsec,debug type=Encryption Algorithm, flag=0x8000, lorv=AES-CBC
22:52:54 ipsec,debug encryption(aes)
22:52:54 ipsec,debug type=Key Length, flag=0x8000, lorv=256
22:52:54 ipsec,debug type=Hash Algorithm, flag=0x8000, lorv=SHA
22:52:54 ipsec,debug hash(sha1)
22:52:54 ipsec,debug type=Group Description, flag=0x8000, lorv=384-bit random ECP group
22:52:54 ipsec,debug dh(ecp384)
22:52:54 ipsec,debug type=Authentication Method, flag=0x8000, lorv=RSA signatures
22:52:54 ipsec,debug type=Life Type, flag=0x8000, lorv=seconds
22:52:54 ipsec,debug type=Life Duration, flag=0x0000, lorv=4
22:52:54 ipsec,debug transform #2 len=40
22:52:54 ipsec,debug type=Encryption Algorithm, flag=0x8000, lorv=AES-CBC
22:52:54 ipsec,debug encryption(aes)
22:52:54 ipsec,debug type=Key Length, flag=0x8000, lorv=128
22:52:54 ipsec,debug type=Hash Algorithm, flag=0x8000, lorv=SHA
22:52:54 ipsec,debug hash(sha1)
22:52:54 ipsec,debug type=Group Description, flag=0x8000, lorv=256-bit random ECP group
22:52:54 ipsec,debug dh(ecp256)
22:52:54 ipsec,debug type=Authentication Method, flag=0x8000, lorv=RSA signatures
22:52:54 ipsec,debug type=Life Type, flag=0x8000, lorv=seconds
22:52:54 ipsec,debug type=Life Duration, flag=0x0000, lorv=4
22:52:54 ipsec,debug transform #3 len=40
22:52:54 ipsec,debug type=Encryption Algorithm, flag=0x8000, lorv=AES-CBC
22:52:54 ipsec,debug encryption(aes)
22:52:54 ipsec,debug type=Key Length, flag=0x8000, lorv=256
22:52:54 ipsec,debug type=Hash Algorithm, flag=0x8000, lorv=SHA
22:52:54 ipsec,debug hash(sha1)
22:52:54 ipsec,debug type=Group Description, flag=0x8000, lorv=2048-bit MODP group
22:52:54 ipsec,debug dh(modp2048)
22:52:54 ipsec,debug type=Authentication Method, flag=0x8000, lorv=RSA signatures
22:52:54 ipsec,debug type=Life Type, flag=0x8000, lorv=seconds
22:52:54 ipsec,debug type=Life Duration, flag=0x0000, lorv=4
22:52:54 ipsec,debug transform #4 len=36
22:52:54 ipsec,debug type=Encryption Algorithm, flag=0x8000, lorv=3DES-CBC
22:52:54 ipsec,debug encryption(3des)
22:52:54 ipsec,debug type=Hash Algorithm, flag=0x8000, lorv=SHA
22:52:54 ipsec,debug hash(sha1)
22:52:54 ipsec,debug type=Group Description, flag=0x8000, lorv=2048-bit MODP group
22:52:54 ipsec,debug dh(modp2048)
22:52:54 ipsec,debug type=Authentication Method, flag=0x8000, lorv=RSA signatures
22:52:54 ipsec,debug type=Life Type, flag=0x8000, lorv=seconds
22:52:54 ipsec,debug type=Life Duration, flag=0x0000, lorv=4
22:52:54 ipsec,debug transform #5 len=36
22:52:54 ipsec,debug type=Encryption Algorithm, flag=0x8000, lorv=3DES-CBC
22:52:54 ipsec,debug encryption(3des)
22:52:54 ipsec,debug type=Hash Algorithm, flag=0x8000, lorv=SHA
22:52:54 ipsec,debug hash(sha1)
22:52:54 ipsec,debug type=Group Description, flag=0x8000, lorv=1024-bit MODP group
22:52:54 ipsec,debug dh(modp1024)
22:52:54 ipsec,debug type=Authentication Method, flag=0x8000, lorv=RSA signatures
22:52:54 ipsec,debug type=Life Type, flag=0x8000, lorv=seconds
22:52:54 ipsec,debug type=Life Duration, flag=0x0000, lorv=4
22:52:54 ipsec,debug pair 1:
22:52:54 ipsec,debug 0x80bd938: next=(nil) tnext=0x80bcfc8
22:52:54 ipsec,debug 0x80bcfc8: next=(nil) tnext=0x80c02f0
22:52:54 ipsec,debug 0x80c02f0: next=(nil) tnext=0x80b4078
22:52:54 ipsec,debug 0x80b4078: next=(nil) tnext=0x80bd8c0
22:52:54 ipsec,debug 0x80bd8c0: next=(nil) tnext=(nil)
22:52:54 ipsec,debug proposal #1: 5 transform
22:52:54 ipsec,debug -checking with RSA signatures auth-
22:52:54 ipsec,debug prop#=1, prot-id=ISAKMP, spi-size=0, #trns=5
22:52:54 ipsec,debug trns#=1, trns-id=IKE
22:52:54 ipsec,debug type=Encryption Algorithm, flag=0x8000, lorv=AES-CBC
22:52:54 ipsec,debug type=Key Length, flag=0x8000, lorv=256
22:52:54 ipsec,debug type=Hash Algorithm, flag=0x8000, lorv=SHA
22:52:54 ipsec,debug type=Group Description, flag=0x8000, lorv=384-bit random ECP group
22:52:54 ipsec,debug type=Authentication Method, flag=0x8000, lorv=RSA signatures
22:52:54 ipsec,debug type=Life Type, flag=0x8000, lorv=seconds
22:52:54 ipsec,debug type=Life Duration, flag=0x0000, lorv=4
22:52:54 ipsec,debug -compare proposal #1: Local:Peer
22:52:54 ipsec,debug (lifetime = 86400:28800)
22:52:54 ipsec,debug (lifebyte = 0:0)
22:52:54 ipsec,debug enctype = AES-CBC:AES-CBC
22:52:54 ipsec,debug (encklen = 256:256)
22:52:54 ipsec,debug hashtype = SHA:SHA
22:52:54 ipsec,debug authmethod = RSA signatures:RSA signatures
22:52:54 ipsec,debug dh_group = 521-bit random ECP group:384-bit random ECP group
22:52:54 ipsec,debug -compare proposal #2: Local:Peer
22:52:54 ipsec,debug (lifetime = 86400:28800)
22:52:54 ipsec,debug (lifebyte = 0:0)
22:52:54 ipsec,debug enctype = AES-CBC:AES-CBC
22:52:54 ipsec,debug (encklen = 256:256)
22:52:54 ipsec,debug hashtype = SHA:SHA
22:52:54 ipsec,debug authmethod = RSA signatures:RSA signatures
22:52:54 ipsec,debug dh_group = 384-bit random ECP group:384-bit random ECP group
22:52:54 ipsec,error no identity suits proposal
22:52:54 ipsec,error CLIENT_IP failed to get valid proposal.
22:52:54 ipsec,error CLIENT_IP failed to pre-process ph1 packet (side: 1, status 1).
22:52:54 ipsec,error CLIENT_IP phase1 negotiation failed.
I have no idea what I'm doing wrong
Please help.