Community discussions

MikroTik App
 
harryenlared
just joined
Topic Author
Posts: 5
Joined: Fri Feb 15, 2013 10:29 pm

Queue priority and limits

Fri Oct 18, 2019 9:24 pm

Hello!

Queue priority only works if you have defined limit-at and max-limit values. Ok.

But here: https://wiki.mikrotik.com/wiki/DSCP_bas ... queue_tree there is an example where all the child queues have limit-at=0 and max-limit=0 and some priority defined.

It's something like this:

/queue tree add limit-at=0 max-limit=5000000 name=ether1 parent=ether1

/queue tree add limit-at=0 max-limit=0 packet-mark=p8 parent=ether1 priority=8
/queue tree add limit-at=0 max-limit=0 packet-mark=p7 parent=ether1 priority=7
/queue tree add limit-at=0 max-limit=0 packet-mark=p6 parent=ether1 priority=6
...

So, does it work or not?

If not, Is the example in this article wrong? https://wiki.mikrotik.com/wiki/DSCP_bas ... queue_tree

Thanks!
 
Zacharias
Forum Guru
Forum Guru
Posts: 3459
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Queue priority and limits

Sat Oct 19, 2019 5:59 pm

It works...packets marked with p6 have greater priority in the queue list than those with priority 7 or 8 etc...

So highest priority is served first...
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1782
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Queue priority and limits

Sat Oct 19, 2019 11:15 pm

And the total limit is defined at the parent level, all children "borrow" from parent:

/queue tree add limit-at=0 max-limit=5000000 name=ether1 parent=ether1
 
harryenlared
just joined
Topic Author
Posts: 5
Joined: Fri Feb 15, 2013 10:29 pm

Re: Queue priority and limits

Mon Oct 21, 2019 1:58 pm

And the total limit is defined at the parent level, all children "borrow" from parent:

/queue tree add limit-at=0 max-limit=5000000 name=ether1 parent=ether1
Thanks!
And priority acts only when the parent max-limit is reached, right?
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1782
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Queue priority and limits

Mon Oct 21, 2019 2:42 pm

priority is always active: queue tokens are used for packets from highest to lowest prio. Once pipe is full / tokens are exhausted and priority queues are full, new packets get dropped

In effect, if bandwidth is not scarce, all packets are transmitted and one could say that priority is irrelevant, and only becomes apparent once there is a bottleneck / scarce bandwidth.