i just upgraded my RB2011 from RouterOS 6.43.12 to 6.45.7 and one of my scripts stopped working. Script looks like this:
Code: Select all
{
:global S03IP
:local DestIP [:resolve s03.domain.com]
if ($DestIP != $S03IP) do={
:log warn "Destination IP for IPSec-Tunnel S03 changed to $DestIP, fixing IPSec"
/ip ipsec policy
set [find comment~"S03"] sa-dst-address=$DestIP;
/ip ipsec peer
set [find comment="S03"] address=$DestIP;
:set S03IP $DestIP
}
}
Greetings,
Markus