Yes, internal router CAN PPPoE authenticate and get a public IP from ISP while it's connected downstream to ISP modem (in absentee of Mikrotik).The question is if you are able to make PPPoE connection from "internal" router to receive public address if there is no Mikrotik "in the middle"?
What do Mikrotik should do in your opinion?
Thanks for confirmation.Yes, it is possible. RouterOS is not going to be a limitation and CPU power in a Hex is plenty for distributing those 8 mbps.
Just use queues and separate the interfaces from the switch chip.
Create a PPPoE client...
1- What do you mean by that? What is the alternative?You can do that too..
What should be the port configuration for Layer 2 for:1. You said you want your internal router to PPPoE authenticate with your ISP right? For this to happen you should have a layer2 tunnel between your internal router and the ISPs router...
I understand but new to Mikrotik so what is the command that should run to make eth1 and eth2 prepared for this?Layer 2 means no routing.. Data link layer.. Mac addresses....
If you Bridge two interfaces then they are on the same Layer 2 network.I understand but new to Mikrotik so what is the command that should run to make eth1 and eth2 prepared for this?Layer 2 means no routing.. Data link layer.. Mac addresses....
Can I limit speed on that bridge which is layer-2 and used for PPPoE?If you Bridge two interfaces then they are on the same Layer 2 network.I understand but new to Mikrotik so what is the command that should run to make eth1 and eth2 prepared for this?Layer 2 means no routing.. Data link layer.. Mac addresses....
For example, i could have my ISPs router connected with a mikrotik router that works with a dhcp client.. Lets say i have a bridge named Bridge witch has ports ether1 and ether2. I can use dhcp client on that Bridge so i can have internet to my first router. Then I use either ether1 or ether2 (the one that is free) to connect it to my second mikrotik router that has a PPPoE client on his ether1...
Is rate limit same as queues?Assign a rate limit in the profile of the PPPoE server...
https://wiki.mikrotik.com/wiki/Manual:P ... r_Profiles
Check the rate limit in the above link..
/interface bridge
add name=Shared-LAN
/interface bridge port
add bridge=Shared-LAN interface=ether1
add bridge=Shared-LAN interface=ether2
add bridge=Shared-LAN interface=ether3
/queue simple
add max-limit=1M/10M name=All-ISP-Bandwidth target=Shared-LAN
add limit-at=768k/5M max-limit=1M/10M name=Phones parent=All-ISP-Bandwidth priority=1/1 target=192.168.2.0/24
add max-limit=1M/10M name=3rd-party-router parent=All-ISP-Bandwidth priority=2/2 target=""
Thanks for the diagram and the command lines. This is beautifully explained. I have implemented this with bit changes to speed and Upload seems to work just fine but download is splitting between Ether-2 and Ether-3. My tests are done using nperf.com and I have run the tests at the same time OR starting one before the other. In all cases that I tested Upload priority was given to phones network but Download speed was shared.Here are some example configs and a diagram that should point you in the right direction. A few notes on this - I tried to keep the config as simplistic as possible since you're dealing with very low speeds. There are more efficient ways to do this, but it requires more config. Also, I used 10M download and 1M upload as the values for the ISP connection - these will need to be adjusted to the actual values.
Here is an overview of the solution
Configuration
First you need to create a bridge for the ports and add them to the bridge.
Code: Select all/interface bridge add name=Shared-LAN /interface bridge port add bridge=Shared-LAN interface=ether1 add bridge=Shared-LAN interface=ether2 add bridge=Shared-LAN interface=ether3
Then you need to add the simple queue rules which will classify the traffic and prioritize accordingly
Code: Select all/queue simple add max-limit=1M/10M name=All-ISP-Bandwidth target=Shared-LAN add limit-at=768k/5M max-limit=1M/10M name=Phones parent=All-ISP-Bandwidth priority=1/1 target=192.168.2.0/24 add max-limit=1M/10M name=3rd-party-router parent=All-ISP-Bandwidth priority=2/2 target=""
/queue simple
add max-limit=11.46M/21.30M name=All-ISP-Bandwidth target=Shared-LAN
add limit-at=10M/20M max-limit=11.46M/21.30M name=Phones parent=All-ISP-Bandwidth priority=1/1 target=192.168.2.0/24
add max-limit=1M/1M name=3rd-party-router parent=All-ISP-Bandwidth priority=2/2 target=""
I am not sure what control means in this context but PPPoE server is on ISP side. Of course, I can run a PPPoE server on Mikrotik too and maybe(?) then pass public IP to 3rd Party Router but seems like your method is the best IF it doesn't break PPPoE connection (can you please confirm this because on IRC channel I heard someone say PPPoE will break with Queues usage).If I read the OP correctly, he does not have control of the PPPoE server.
I am not sure what you mean by that. Can you add commands please like IPANETEngineer did. PPPoE is done on "3rd Party Router".Did you finally add queues for the PPPoE? Can i see those queues?
/interface bridge
add name=Shared-LAN
/interface bridge port
add bridge=Shared-LAN interface=ether1
add bridge=Shared-LAN interface=ether2
add bridge=Shared-LAN interface=ether3
/queue simple
add max-limit=11.46M/21.30M name=All-ISP-Bandwidth target=Shared-LAN
add limit-at=10M/20M max-limit=11.46M/21.30M name=Phones parent=All-ISP-Bandwidth priority=1/1 target=192.168.2.0/24
add max-limit=1M/1M name=3rd-party-router parent=All-ISP-Bandwidth priority=2/2 target=""
Looking at it again, neither Upload or Download limits work at all. None of the queues work. It was my desktop eating more upload bandwidth compared to a Surface notebook that made me think Upload works.Here are some example configs and a diagram that should point you in the right direction. A few notes on this - I tried to keep the config as simplistic as possible since you're dealing with very low speeds. There are more efficient ways to do this, but it requires more config. Also, I used 10M download and 1M upload as the values for the ISP connection - these will need to be adjusted to the actual values.
Here is an overview of the solution
Configuration
First you need to create a bridge for the ports and add them to the bridge.
Code: Select all/interface bridge add name=Shared-LAN /interface bridge port add bridge=Shared-LAN interface=ether1 add bridge=Shared-LAN interface=ether2 add bridge=Shared-LAN interface=ether3
Then you need to add the simple queue rules which will classify the traffic and prioritize accordingly
Code: Select all/queue simple add max-limit=1M/10M name=All-ISP-Bandwidth target=Shared-LAN add limit-at=768k/5M max-limit=1M/10M name=Phones parent=All-ISP-Bandwidth priority=1/1 target=192.168.2.0/24 add max-limit=1M/10M name=3rd-party-router parent=All-ISP-Bandwidth priority=2/2 target=""
Your queues look fine... in the advanced tab of the parent queue add as type pcq upload default and pcq download default...
Also specify your target in your third router...
Then test again...
Anyone can comment on this?Your queues look fine... in the advanced tab of the parent queue add as type pcq upload default and pcq download default...
Also specify your target in your third router...
Then test again...
Setting to PCQ Default for both upload and download did not make a difference. Also setting Target to ether2-master (the 3rd party router connected port) did not make a difference. I am going by the diagram posted by IPANetEngineer by the way.
*I enabled and disabled these Queues and it made absolutely no difference at my tests. I am using nperf.com to test with two different computers simultaneously.
Here is a snap shot:
Thanks for feedback.Actually its really simple...
Something is preventing it from working on your configuration...
The specific configuration no...Thanks for feedback.Actually its really simple...
Something is preventing it from working on your configuration...
Have you tested this in your lab that you can say for sure?
Yeah, I thought there is something wrong. So what is your suggestion or there is no hope for this scenario?The specific configuration no...Thanks for feedback.Actually its really simple...
Something is preventing it from working on your configuration...
Have you tested this in your lab that you can say for sure?
However i have used simple queues, really, in hundreds of configurations...
So i know they do work
Sindy, seems you are very close. I haven't tried everything you said yet but will do that tomorrow and will post here. For now I have got this working using below configuration. This is only for PPPoE port bandwidth limit. It seems to be working for Download speed but Upload mangle doesn't register any packets:I may have missed that in the previous posts, but it seems to me that the configuration by @IPANetEngineer lacks a significant bit of information - in order for queues to work also for L2 frames, in interface bridge settings, use-ip-firewall must be set to yes; in order that PPPoE frames were handled as well, use-ip-firewall-for-pppoe must be set to yes too.
I also have some doubts regarding the way the three simple queues are organized, but I lack any experience here, so it may be allright. The fact that the last one, which should handle the 3rd party router's PPPoE traffic, has target="" is fine; what bothers me is the first one to match on target=Shared_LAN. I expect that rule to either match everything (which would be wrong) or nothing (which would just mean it is useless) because the Shared_LAN has no L3 configuration assigned to it.
So start from changing the bridge settings and have a look whether the queues start counting packets, drops etc. once you do that. If only the first one wil start counting, disable it.