I'm trying to send any DNS traffic from mikrotik which operates in bridge mode to a remote server. I discovered three ways to accomplish this - a calea options, a firewall mangle sniff TZSP action and /tool sniffer. I set up a linux server with a tcpdump capturing port 37008 in a ring buffer.
I think I need this option to use any firewall level function on a bridge:
Code: Select all
/interface bridge settings set use-ip-firewall=yes
Option 1: tool sniffer
Code: Select all
/tool sniffer set file-limit=10KiB filter-interface=all filter-ip-protocol=tcp,udp filter-port=dns filter-stream=yes memory-scroll=no streaming-enabled=yes streaming-server=10.0.0.1
Option 2: action=sniff-tzsp
Code: Select all
/ip firewall mangle add action=sniff-tzsp chain=forward dst-address=0.0.0.0 dst-port=53 port="" protocol=udp sniff-target=10.0.0.1 sniff-target-port=37008 src-address=0.0.0.0
Option 3: /interface bridge calea
Code: Select all
/interface bridge calea add action=sniff chain=forward disabled=yes sniff-target=10.0.0.1 sniff-target-port=37008
what is the right way to send DNS traffic to IDS? What are the differences between these three methods? Can you suggest what need to be adjusted in the configuration to make it work?