Could someone please check my config for the issue? Thanks a lot!
Edit 1: Added one more device to VLAN 255, which I pinged from VLAN 10 / 20. Same problem.
Hi,
I spent a few hours to set up InterVLAN Routing between 3 VLANs.
This works with one important exception: Traffic of clients, directly attached to an Untagged Access Port of my primary CRS210 router, won't get routed. All of these clients are able to reach the VLAN interfaces of the router, but not the network after the first hop.
This works perfectly fine with tagged ports. All clients behind my SwOS switches are able to reach every network behind my CRS210 router.
One example:
- My pfSense (IP 192.168.255.1) is able to be pinged from all SwOS devices in VLAN 10 / 20
- My pfSense (IP 192.168.255.1) is not pingable from all Access Ports, for which I configured an ingress VLAN directly at my CRS210
- For not working clients: One ping is going through, afterwards everything seems dropped.
VLAN Design:
VLAN 10: 192.168.10.0 /24 for Mgmt
VLAN 20: 192.168.20.0 /24 for Users
VLAN 255: 192.168.255.0 /30 as transit network between CRS210 and my pfSense Firewall --> Internet Access
Connection of my components
RouterOS Switch CRS210
- sfp1: Uplink SwOS Switch (Tagged VLAN 10)
- sfp2: Uplink SwOS Switch (Tagged VLAN 10, 20)
- ether8: Uplink pfSense Firewall (Tagged VLAN 255)
- ether1-7: Access Ports im VLAN 10 (Untagged PVID 10)
CRS210 configuration
Two notes to my config:
- Factory Reset was done before the config was applied, "No Default Configuration" and "Do Not Backup" were checked
- Intentionally no VLAN filtering was used, because HW offloading is needed
Following guides were used to create the config:
https://wiki.mikrotik.com/wiki/Manual:B ... s_switches
https://wiki.mikrotik.com/wiki/Manual:C ... s_examples
viewtopic.php?f=13&t=154701#p764807
Code: Select all
This is the full configuration of my CRS210 router right now:
[code]
[admin@MikroTik] > /export hide-sensitive
# jan/01/2020 13:41:10 by RouterOS 6.46.1
#
# model = CRS210-8G-2S+
/interface bridge
add name=bridge protocol-mode=none
/interface vlan
add interface=bridge name=EG vlan-id=20
add interface=bridge name=Internet vlan-id=255
add interface=bridge name=OG vlan-id=10
/interface list
add name=WAN
add name=LAN
/ip pool
add name=dhcp_pool0 ranges=192.168.10.100-192.168.10.199
add name=dhcp_pool1 ranges=192.168.20.100-192.168.20.199
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=OG lease-time=3h name=dhcp1
add address-pool=dhcp_pool1 disabled=no interface=EG lease-time=3h name=dhcp2
/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=ether2
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether5
add bridge=bridge interface=ether6
add bridge=bridge interface=ether7
add bridge=bridge interface=ether8
add bridge=bridge interface=sfp-sfpplus1
add bridge=bridge interface=sfpplus2
/interface ethernet switch egress-vlan-tag
add tagged-ports=switch1-cpu,sfpplus2,sfp-sfpplus1 vlan-id=10
add tagged-ports=switch1-cpu,sfpplus2 vlan-id=20
add tagged-ports=switch1-cpu,ether8 vlan-id=255
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7
/interface ethernet switch vlan
add ports=switch1-cpu,ether1,ether2,ether3,ether4,ether5,ether6,ether7,sfpplus2,sfp-sfpplus1 vlan-id=10
add ports=switch1-cpu,sfpplus2 vlan-id=20
add ports=switch1-cpu,ether8 vlan-id=255
/interface list member
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=ether6 list=LAN
add interface=ether7 list=LAN
add interface=ether8 list=LAN
add interface=sfp-sfpplus1 list=LAN
add interface=sfpplus2 list=LAN
/ip address
add address=192.168.10.1/24 interface=OG network=192.168.10.0
add address=192.168.20.1/24 interface=EG network=192.168.20.0
add address=192.168.255.2/30 interface=Internet network=192.168.255.0
/ip dhcp-server network
add address=192.168.10.0/24 gateway=192.168.10.1
add address=192.168.20.0/24 gateway=192.168.20.1
/ip dns
set servers=192.168.255.1
/ip route
add distance=1 gateway=192.168.255.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/lcd
set enabled=no touch-screen=disabled
/system clock
set time-zone-name=Europe/Berlin
/system package update
set channel=long-term
/tool bandwidth-server
set enabled=no
Everyone, have a great and healthy new year!