Community discussions

MikroTik App
 
chgruem
just joined
Topic Author
Posts: 3
Joined: Sun Jul 10, 2016 10:24 am

Modify config in order to use hardware offloading

Sun Feb 23, 2020 11:12 am

Hi to all

I need to modify the below config in order to use the hardware offloading feature. Do I have to rewrite the whole config? As far as I know I need to add all ports to a brdige. And then? What steps are required?

I'm thankful for any tips.

BR,
Michael
# feb/22/2020 18:25:00 by RouterOS 6.46.3
# software id = K9UC-SSTZ
#
# model = CRS312-4C+8XG
# serial number = ...
/interface bridge
add admin-mac=74:4D:28:B7:4D:25 arp=proxy-arp auto-mac=no comment=defconf name=bridge protocol-mode=none
/interface ethernet
set [ find default-name=combo1 ] arp=proxy-arp
set [ find default-name=ether1 ] arp=proxy-arp loop-protect=off
set [ find default-name=ether2 ] arp=proxy-arp loop-protect=off
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge comment=defconf interface=combo2
add bridge=bridge comment=defconf interface=combo3
add bridge=bridge comment=defconf interface=combo4
/ip address
add address=192.168.88.1/24 interface=ether9 network=192.168.88.0
add address=192.168.1.55/24 interface=ether2 network=192.168.1.0
add address=10.103.0.55/16 interface=combo1 network=10.103.0.0
add address=192.168.1.55/24 interface=ether1 network=192.168.1.0
/ip firewall mangle
add action=mark-routing chain=prerouting dst-address=10.103.15.1 new-routing-mark=UUTA passthrough=yes
add action=mark-routing chain=prerouting dst-address=10.103.15.2 new-routing-mark=UUTA passthrough=yes
add action=mark-routing chain=prerouting dst-address=10.103.15.220 new-routing-mark=UUTA passthrough=yes
add action=mark-routing chain=prerouting dst-address=192.168.1.105 new-routing-mark=main passthrough=yes routing-mark=UUTA
add action=mark-routing chain=prerouting dst-address=10.103.25.1 new-routing-mark=UUTB passthrough=yes
add action=mark-routing chain=prerouting dst-address=10.103.25.2 new-routing-mark=UUTB passthrough=yes
add action=mark-routing chain=prerouting dst-address=10.103.25.220 new-routing-mark=UUTB passthrough=yes
add action=mark-routing chain=prerouting dst-address=192.168.1.105 new-routing-mark=main passthrough=yes routing-mark=UUTB
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=10.103.15.1 routing-mark=UUTA to-addresses=192.168.1.1
add action=dst-nat chain=dstnat dst-address=10.103.15.2 routing-mark=UUTA to-addresses=192.168.1.2
add action=dst-nat chain=dstnat dst-address=10.103.15.220 routing-mark=UUTA to-addresses=192.168.1.220
add action=src-nat chain=srcnat routing-mark=UUTA src-address=10.103.0.100 to-addresses=192.168.1.105
add action=dst-nat chain=dstnat dst-address=10.103.25.1 routing-mark=UUTB to-addresses=192.168.1.1
add action=dst-nat chain=dstnat dst-address=10.103.25.2 routing-mark=UUTB to-addresses=192.168.1.2
add action=dst-nat chain=dstnat dst-address=10.103.25.220 routing-mark=UUTB to-addresses=192.168.1.220
add action=src-nat chain=srcnat routing-mark=UUTB src-address=10.103.0.100 to-addresses=192.168.1.105
/ip route
add distance=1 dst-address=10.103.15.1/32 gateway=192.168.1.1 routing-mark=UUTA
add distance=1 dst-address=10.103.15.2/32 gateway=192.168.1.1 routing-mark=UUTA
add distance=1 dst-address=10.103.15.220/32 gateway=192.168.1.1 routing-mark=UUTA
add distance=1 dst-address=10.103.25.1/32 gateway=192.168.1.1 routing-mark=UUTB
add distance=1 dst-address=10.103.25.2/32 gateway=192.168.1.1 routing-mark=UUTB
add distance=1 dst-address=10.103.25.220/32 gateway=192.168.1.1 routing-mark=UUTB
add distance=1 dst-address=192.168.1.105/32 gateway=10.103.0.100
/ip route rule
add dst-address=10.103.15.1/32 interface=combo1 table=UUTA
add dst-address=10.103.15.2/32 interface=combo1 table=UUTA
add dst-address=10.103.15.220/32 interface=combo1 table=UUTA
add dst-address=192.168.1.105/32 routing-mark=UUTA table=main
add dst-address=10.103.25.1/32 interface=combo1 table=UUTB
add dst-address=10.103.25.2/32 interface=combo1 table=UUTB
add dst-address=10.103.25.220/32 interface=combo1 table=UUTB
add dst-address=192.168.1.105/32 routing-mark=UUTB table=main
/ip route vrf
add interfaces=ether1 route-distinguisher=101:1 routing-mark=UUTA
add interfaces=ether2 route-distinguisher=102:2 routing-mark=UUTB
/system clock
set time-zone-name=Europe/Zurich
/system routerboard settings
set boot-os=router-os