I'm using 1x CRS326-24G-2S+RM as my central routing instance for 3 VLANs. InterVLAN Routing with HW offloading was configured, which worked fine so far. When I upgraded my internet line from 200 Mbps to 1 Gbits, I recognized that a maximum of 500 Mbps are going through.
This only happens when my internet modem is in a different VLAN than the client, which means that the problem occures when the CRS326 is routing between the subnets. When the internet modem gets connected to the CRS326 and added to the same VLAN as the client, the client reaches the max speed of 1Gbits.
Two issues seem possible to me:
1. HW offloading is not working as it should be, which means the traffic gets routed by the CPU
2. The performance of the CRS326 is too weak, even with HW offloading
I'm using following config:
Code: Select all
/ip pool
add name=dhcp_pool0 ranges=192.168.10.100-192.168.10.199
add name=dhcp_pool1 ranges=192.168.20.100-192.168.20.199
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=VLAN10 lease-time=3d name=dhcp1
add address-pool=dhcp_pool1 disabled=no interface=VLAN20 lease-time=3d name=dhcp2
/interface bridge port
add bridge=bridge interface=ether1 pvid=10
add bridge=bridge interface=ether2 pvid=10
add bridge=bridge comment=Uplink-Internet-1G interface=ether24 pvid=255
add bridge=bridge comment=Uplink-Switch-10G interface=sfp-sfpplus1
add bridge=bridge comment=Uplink-Switch-10G interface=sfp-sfpplus2
/interface bridge vlan
add bridge=bridge tagged=bridge,sfp-sfpplus1,sfp-sfpplus2 untagged="ether1,ether2" vlan-ids=10
add bridge=bridge tagged=bridge,sfp-sfpplus2 vlan-ids=20
add bridge=bridge tagged=bridge vlan-ids=255
/ip address
add address=192.168.10.1/24 interface=VLAN10 network=192.168.10.0
add address=192.168.20.1/24 interface=VLAN20 network=192.168.20.0
add address=192.168.255.2/30 interface=FW network=192.168.255.0
/ip cloud
set update-time=no
/ip dhcp-server network
add address=192.168.10.0/24 gateway=192.168.10.1
add address=192.168.20.0/24 gateway=192.168.20.1
/ip dns
set servers=192.168.255.1
/ip route
add distance=1 gateway=192.168.255.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Berlin
/system ntp client
set enabled=yes server-dns-names=\
pool.ntp.org
/system routerboard settings
set boot-os=router-os
/tool bandwidth-server
set enabled=no/code]