I searched the forum, and it seems to be configurable via `/system routerboard mode-button`
Is there any documentation that explains how to configure mode button?
I'm impressed with configurability and useability of RouterOS although documentation can improve.
If I search google with "mode button site:http://wiki.mikrotik.com", https://wiki.mikrotik.com/wiki/Manual:R ... D_settings is not on the first page of the search results.RouterOS has thousands of features. We will not reference each feature with links to manual. There is a search function after all.
If I search google with "mode button site:http://wiki.mikrotik.com", https://wiki.mikrotik.com/wiki/Manual:R ... D_settings is not on the first page of the search results.RouterOS has thousands of features. We will not reference each feature with links to manual. There is a search function after all.
Also, on google search results, it's not obvious that RouterBOARD_settings is related to mode buttons unless one is already familiar with RouterOS.
It should become easier to find.
https://wiki.mikrotik.com/index.php?tit ... ldid=29628 tells me that the documentation on mode button was created by normis after I created this thread.
Documentation is always left behind.
:log info message=("mode button was pressed");
:local i
:if ( [/int wir get 0 disabled ] = true ) do={
:foreach i in= [ /int wir find ] do={ :int wir enable $i };
} else={
:foreach i in= [ /int wir find ] do={ :int wir disable $i };
}
I propose to continue discussing this issue in this thread viewtopic.php?f=9&t=136670Yes, I'm facing the delays too. Sometimes it looks like my hap lite just don't recognize I pressed a button on it, and some time later (~ 5-30 sec) it will recognize it and react to it.
Also today it seemed like the script on the button was running twice: enabling wireless interface for a short period of time, then disabling it after ~10 sec. I added comment to the start of it, so now I will see for sure if script is running twice for one press or it's something else.
I'm using next script for the button to disable/enable wireless interface:Code: Select all:log info message=("mode button was pressed"); :local i :if ( [/int wir get 0 disabled ] = true ) do={ :foreach i in= [ /int wir find ] do={ :int wir enable $i }; } else={ :foreach i in= [ /int wir find ] do={ :int wir disable $i }; }