after finding a rather comprehensive and good blog entry how to handle the annoying IPv6 prefix changes from the Deutsche Telekom (security by obscurity)
https://blog.chanoa.de/mikrotik-ipv6
I tried again (after a couple of years) to establish IPv6 over pppoe with a Telekom aka T-Online account. But it does not work, again....
Pool
Code: Select all
/ipv6 pool
add name=telekom.ipv6 prefix=::/56 prefix-length=64
Code: Select all
/ipv6 settings
set accept-router-advertisements=yes
Code: Select all
/ipv6 address
add from-pool=telekom.ipv6 interface=vlan101
add from-pool=telekom.ipv6 interface=vlan102
add from-pool=telekom.ipv6 interface=vlan103
Code: Select all
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1-dsl1 pool-name=telekom.ipv6 request=address,prefix
Code: Select all
/ipv6 firewall filter
add action=accept chain=input comment="accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment="accept DHCPv6-Client prefix delegation." dst-port=546 protocol=udp src-address=fe80::/10
Code: Select all
/ipv6 nd
set [ find default=yes ] advertise-dns=no disabled=yes interface=pppoe-out1-dsl1 managed-address-configuration=yes other-configuration=yes
add interface=vlan101 ra-lifetime=10m
add interface=vlan102 ra-lifetime=10m
add interface=vlan103 ra-lifetime=10m
When I try to release/renew the prefix I get the following log entry:
Code: Select all
14:56:30 firewall,info ipv6-telekom-fe80 input: in:pppoe-out1-dsl1 out:(unknown 0), src-mac 1c:fc:83:cc:f2:75, proto UDP, [fe80::9ecc:83ff:fecc:1275]:547->[fe80::e]:546, prio 6->0, len 168
14:56:31 firewall,info ipv6-telekom-fe80 input: in:pppoe-out1-dsl1 out:(unknown 0), src-mac 1c:fc:83:cc:f2:75, proto UDP, [fe80::9ecc:83ff:fecc:1275]:547->[fe80::e]:546, prio 6->0, len 168
14:56:34 firewall,info ipv6-telekom-fe80 input: in:pppoe-out1-dsl1 out:(unknown 0), src-mac 1c:fc:83:cc:f2:75, proto UDP, [fe80::9ecc:83ff:fecc:1275]:547->[fe80::e]:546, prio 6->0, len 168
14:56:38 firewall,info ipv6-telekom-fe80 input: in:pppoe-out1-dsl1 out:(unknown 0), src-mac 1c:fc:83:cc:f2:75, proto UDP, [fe80::9ecc:83ff:fecc:1275]:547->[fe80::e]:546, prio 6->0, len 168
The funny thing is, in the "neighbour" List I found (only for a short period of time) some 2003:: Telekom IPv6 Adresses which tried to access the router on its IPv6 fe80:: Adress on Port 53.... It was only very short though, don't know whats that all about.
Could anyone give me some hints how to debug this behaviour further?
What i did (with a second, RB750 device, which i had laying around) testing the same configuration not with PPPoE but with straigth DHCPv6 and prefix delegation confiured in my pfsense box which worked out of the box and all defined pools got filled with /64 networks - so in theorie, the config is working - but there is some special things for dhcpclientv6 over pppoe mandatory, I think....
Thanks a lot for your time.
Cheers
4920441