Community discussions

MikroTik App
 
withaai
just joined
Topic Author
Posts: 19
Joined: Tue Apr 14, 2020 9:06 pm

Multiple ISP and Hotspot connections

Mon Jun 01, 2020 6:46 pm

Good Day
I am wondering if the following is possible.
I want to be able to swap between my connections so I am thinking of using the hotspot and giving each internet connection its own hotspot.
Please see image as I try to explain it.
Will this work?
Net idea.png
You do not have the required permissions to view the files attached to this post.
 
alexanwar
just joined
Posts: 23
Joined: Tue Aug 07, 2018 10:38 am

Re: Multiple ISP and Hotspot connections

Tue Jun 02, 2020 11:18 pm

i assume you want to change isp by changing wifi connection right?
for that scenario, the logic is like this:
  1. make 2 bridges for each isp, bridge1 to rain and bridge2 to mtn.
  2. set local lan ip address, setup dhcp and all other required settings like firewall rules, nat etc. on both bridges.
  3. make sure each bridge can access internet. you can temporary assign an ethernet port to each bridge and test using your pc by directly plugged-in to that port. you can revert back after the test success.
  4. setup 2 wifi interface, one primary and one slave, set the primary wlan1 for rain and the slave wlan2 for mtn. set all necessary config like ssid, passphrase etc.
  5. assign each wlan interface to their designated bridge, wlan1 to bridge1 and wlan2 to bridge2.
  6. create new routes with dst. address 0.0.0.0/0 with gateway of each isp and routing mark for each isp. for example:
    /ip route
    add gateway=ip_address_of_rain_gateway routing-mark=rain
    add gateway=ip_address_of_mtn_gateway routing-mark=mtn
    
  7. add rules in firewall mangle to force routing traffic from each bridge to designated isp route like this:
    /ip firewall mangle
    add action=mark-routing chain=prerouting in-interface=bridge1 new-routing-mark=rain passthrough=yes
    add action=mark-routing chain=prerouting in-interface=bridge2 new-routing-mark=mtn passthrough=yes
    
there you go. if you want to use rain, just connect to wifi ssid for rain, and so with mtn.
if you want to use ethernet/lan, do not revert setting in step 3 so you can plug cable to port assigend to specific isp.
 
withaai
just joined
Topic Author
Posts: 19
Joined: Tue Apr 14, 2020 9:06 pm

Re: Multiple ISP and Hotspot connections

Wed Jun 10, 2020 10:58 pm

i assume you want to change isp by changing wifi connection right?
for that scenario, the logic is like this:
  1. make 2 bridges for each isp, bridge1 to rain and bridge2 to mtn.
  2. set local lan ip address, setup dhcp and all other required settings like firewall rules, nat etc. on both bridges.
  3. make sure each bridge can access internet. you can temporary assign an ethernet port to each bridge and test using your pc by directly plugged-in to that port. you can revert back after the test success.
  4. setup 2 wifi interface, one primary and one slave, set the primary wlan1 for rain and the slave wlan2 for mtn. set all necessary config like ssid, passphrase etc.
  5. assign each wlan interface to their designated bridge, wlan1 to bridge1 and wlan2 to bridge2.
  6. create new routes with dst. address 0.0.0.0/0 with gateway of each isp and routing mark for each isp. for example:
    /ip route
    add gateway=ip_address_of_rain_gateway routing-mark=rain
    add gateway=ip_address_of_mtn_gateway routing-mark=mtn
    
  7. add rules in firewall mangle to force routing traffic from each bridge to designated isp route like this:
    /ip firewall mangle
    add action=mark-routing chain=prerouting in-interface=bridge1 new-routing-mark=rain passthrough=yes
    add action=mark-routing chain=prerouting in-interface=bridge2 new-routing-mark=mtn passthrough=yes
    
there you go. if you want to use rain, just connect to wifi ssid for rain, and so with mtn.
if you want to use ethernet/lan, do not revert setting in step 3 so you can plug cable to port assigend to specific isp.
Thank you for the help I will try this, only problem is I want to be able to use Lan by not changing ports but still changing isp's, the wifi can be connected to rain only.
I basically want all gaming traffic to flow through mtn and the rest through rain. I was thinking of doing a load balance and then blocking port 80 and 443 for browsing on the mtn connection I don't know yet if this will work.
My network
2 x PC - Used for gaming must be able to use mtn and rain network (lan connection)
5 x Cellphones - Only need rain connection (wifi and lan connection - some cellphones run through AP to mikrotik)

My reasons are that MTN network is much better but does not offer uncapped, Rain offers uncapped but network not that strong for gaming.