i have two sim cards in my ltAP and want to change the card in winbox from remote.
They both have different APNs .. how can i assign the correct APN to SIM Slot up and down ?
is this possible ?
Richard
#get SIM info and swap
:local sim
set $sim [/system routerboard modem get sim-slot];
:if ($sim = "a") do={
:log warning "SIM A is active, now switching to B";
/interface set lte1 disabled=no;
:delay 1;
/interface lte set apn-profiles=Vodafone numbers=0;
/system routerboard modem set sim-slot=b;
} else={
:log warning "SIM B is active, now switching to A";
/interface set lte1 disabled=no;
:delay 1;
/interface lte set apn-profiles=default numbers=0;
/system routerboard modem set sim-slot=a;
}
/tool netwatch
add down-script=":log warning \" Internet Down swapSIM\";\r\
\n/system script run swapSIM;\r\
\n" host=8.8.8.8 interval=30m timeout=2s up-script=":log warning \" Internet Up \";"