Here are the VLAN parts of the config that worked very well up until 6.42.1:
Code: Select all
/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether24-trunk
/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports="ether2,ether3,ether24-trunk"
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether24-trunk,switch1-cpu vlan-id=10
add tagged-ports=ether24-trunk,switch1-cpu vlan-id=20
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=ether2,switch1-cpu
add customer-vid=0 new-customer-vid=20 ports=ether3,switch1-cpu
/interface ethernet switch vlan
add ports=ether2,ether24-trunk,switch1-cpu vlan-id=10
add ports=ether3,ether24-trunk,switch1-cpu vlan-id=20
6.43.2 - bad (horribly slow LAN, barely works to ssh to CRS)
6.42.9 - bad (horribly slow LAN, barely works to ssh to CRS)
6.42.1 - bad (horribly slow LAN, barely works to ssh to CRS)
6.41.4 - good
6.41.3 - good
I stopped trying after 6.43.2 because it was the latest version at the time and shelved the upgrade. Everything kept working just fine but now it is being repurposed somewhere else and are now reusing the CRS with a 1Gbps connection. Since it has been so long, I decided to upgrade to 6.47.1 and start fresh. Some things have changed since then, and the usual tutorials do not seem to work on the new version. Consensus also seems to be "switch is not a router" and that the CRS125 is not suited for what I'm trying to do... except it worked great previously with the 100Mbit connection.
* Is the CRS125 suitable for 1000Mbit internet acting as a switch and a router?
* Should I use the hapac as the router with the CRS125 as switch? Does the CRS handle ALL of the internal traffic, and then when it comes time to reach the internet, it goes through the hapac? What would that config even look like? There is a post showing an example config router config, and then corresponding switch config. Why does the router config even have VLANs configured if the switch is handling the internal traffic? In that scenario, does the switch or router do the VLAN to VLAN firewalling? If adding extra hapacs for wifi, would they hang off a trunk port on the hapac router, or the CRS?
* Should I get a CRS3xx to do many port based VLANs with 1000mbit internet just like before, and then hang a hapac off a trunk port for wifi?
* What is the "correct" way to do VLANs now on 6.47.1 on the CRS125?