In a "router-on-a-stick" scenario, none of traffic can be HW offloaded on most Mikrotik devices. And on devices (currently CRS317 only) where it can be (or rather: will be under ROSv7), it's the vlan-bridge way of doing it as well.
First things first: there's
safe mode available in all UIs (including CLI ... press ctrl-X to toggle it ON/OFF). When enabled and one looses management connection, ROS will revert all the changes done since enabling it ... So when you're about to change something which might lock you out, enable safe mode, perform the change ... and if management connection survives, exit safe mode (making the change permanent). Note that logging out while in safe mode counts as loosing management connection as well, so you have to manually exit safe mode before logging out to keep the changes.
Example of configuration for your test scenario (ether2 access port for VLAN11 and ether3 access port for VLAN12) extended to include ether4 as tunk port:
/interface bridge
add name=bridge vlan-filtering=yes
/interface bridge port
add bridge=bridge ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged interface=ether2 pvid=11
add bridge=bridge ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged interface=ether3 pvid=12
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=ether4
/interface bridge vlan
add bridge=bridge tagged=bridge,ether4 untagged=ether2 vlan-ids=11
add bridge=bridge tagged=bridge,ether4 untagged=ether3 vlan-ids=12
/interface vlan
add interface=bridge name=vlan11 vlan-id=11
add interface=bridge name=vlan12 vlan-id=12
# IP config is same as in your example
There's an excellent
tutorial on configuring VLANs on bridge with several use cases explained.
One thing one really has to be careful is not to lock self out of management. One thing is management over IP (webfig, CLI, "normal" winbox) which works over IP and firewall settings may need to be adjusted. Winbox over plain ethernet (select MAC address to connect instead of IP address) is another thing (it's configured under
/tool mac-server). By default both access types are configured by properly configuring interface lists in
/interface list and management VLAN interfaces have to be added to
LAN interface list:
/interface list member
add interface=vlan11 list=LAN
Which is true for WAN as well ... if WAN interface is anything but default ether1 (e.g. if WAN comes in via VLAN, then appropriate VLAN interface has to be added to WAN interface list).