I recently migrated from a CCR to CHR,
however when I need to pass packets with a size of 1500 with vlans within a vlan within the bridge it does not pass if the packet is 1500, it does not happen when I place the vlans within ether1 directly without a bridge, but I need the bridges for other operations
I made a laboratory to reproduce the problem, I will pass the script from a CHR and RB2011
obs: the proxmox has jumboframe active and working
script to reproduce the problem:
script in RB2011:
Code: Select all
/interface bridge add name=bridge1
/interface vlan
add interface=bridge1 name=VLAN1 use-service-tag=yes vlan-id=1
add interface=VLAN1 name=VLAN2 use-service-tag=yes vlan-id=2
/interface bridge port add bridge=bridge1 interface=ether1
/ip address add address=192.168.1.2/24 interface=VLAN2
CHR script that doesn't work:
Code: Select all
/interface bridge
add name=bridge1
/interface vlan
add interface=bridge1 name=VLAN1 use-service-tag=yes vlan-id=1
add interface=VLAN1 name=VLAN2 use-service-tag=yes vlan-id=2
/interface bridge port add bridge=bridge1 interface=ether1
/ip address add address=192.168.1.1/24 interface=VLAN2
/ping 192.168.1.1 size=1500
CHR script that works:
Code: Select all
/interface vlan
add interface=ether1 name=VLAN1 use-service-tag=yes vlan-id=1
add interface=VLAN1 name=VLAN2 use-service-tag=yes vlan-id=2
/ip address add address=192.168.1.1/24 interface=VLAN2
/ping 192.168.1.1 size=1500