Read something that said I needed to slave all of the interfaces to the uplink:
[admin@MikroTik] /interface ethernet> set [ find default-name=ether48 ] master-port=sfp-sfpplus1
expected end of command (line 1 column 35)
Everything I've read just gives me errors. Not even trying to config it to my needs just following along in the wiki.
You must have wandered into the historic section of the wiki (or the numerous out-of-date third-party examples around the web) as
master-port= hardware switching mechanism was removed from RouterOS in version 6.41 (released Dec 2017).
https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering should cover everything you need.
What I need to do is create vlans and some trunks with one trunk uplink going to a router.
Access interfaces
int 1 vlan 100
int 2 vlan 100
int 3 vlan 100
int 4 vlan 110
int 5 vlan 120
int 6 vlan 130
Trunk interfaces
int 7 vlan 200
int 8 vlan 300,400
int 9 vlan 500,600
Uplink trunk
int 49
There isn't a Mikrotik equivalent to 'trunk all VLANs', you have to specify them. So fragments for your example would be
/interface bridge
add name=bridge vlan-filtering=yes
/interface bridge port
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=ether1 pvid=100
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=ether2 pvid=100
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=ether3 pvid=100
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=ether4 pvid=110
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=ether5 pvid=120
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=ether6 pvid=130
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=ether7
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=ether8
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=ether9
...
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus1 (assuming that is the name of the SFP port)
/interface bridge vlan
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=100
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=110
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=120
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=130
add bridge=bridge tagged=sfp-sfpplus1,ether7 vlan-ids=200
add bridge=bridge tagged=sfp-sfpplus1,ether8 vlan-ids=300
add bridge=bridge tagged=sfp-sfpplus1,ether8 vlan-ids=400
add bridge=bridge tagged=sfp-sfpplus1,ether9 vlan-ids=500
add bridge=bridge tagged=sfp-sfpplus1,ether9 vlan-ids=600
As you have existing bridge and bridge ports you can use
set rather than
add as mentioned by mkx, or use the Winbox GUI - more clicking but hides you from the CLI syntax.