# sep/09/2019 00:59:42 by RouterOS 6.42.11
# software id = H2AJ-QXHP
#
# model = RB750Gr3
/interface ethernet
set [ find default-name=ether2 ] l2mtu=1598 name=ether1-gateway
set [ find default-name=ether3 ] arp=proxy-arp l2mtu=1598 mac-address=\
4C:5E:0C:AB:85:8D name=ether2-vlan
set [ find default-name=ether4 ] l2mtu=1598 mac-address=4C:5E:0C:AB:85:8E \
name="ether3-subnet1 CID office"
set [ find default-name=ether5 ] l2mtu=1598 mac-address=4C:5E:0C:AB:85:8F \
name=ether4-admin
/interface vlan
add interface=ether2-vlan name="vlan10 translation" vlan-id=10
add interface=ether2-vlan name="vlan11 CID office" vlan-id=11
add interface=ether2-vlan name="vlan12 CID wireless" vlan-id=12
add interface=ether2-vlan name="vlan13 Admin only" vlan-id=13
add interface=ether2-vlan name="vlan15 Guest Internet only" vlan-id=15
add interface=ether2-vlan name="vlan18 OpenVPN" vlan-id=18
/ip pool
add name=dhcp ranges=192.168.1.90-192.168.1.150
add name=dhcp_pool3 ranges=192.168.3.151-192.168.3.180
add name=dhcp_pool0 ranges=192.168.0.200-192.168.0.253
add name=dhcp_pool2 ranges=192.168.2.200-192.168.2.253
add name=dhcp_pool1 ranges=192.168.1.151-192.168.1.220
add name=dhcp_pool8 ranges=192.168.8.200-192.168.8.254
/ip dhcp-server
add address-pool=dhcp_pool2 authoritative=after-10sec-delay disabled=no \
interface="vlan12 CID wireless" name="Wireless office"
add address-pool=dhcp_pool8 disabled=no interface="vlan18 OpenVPN" \
lease-time=6h name=VPN
add address-pool=dhcp_pool1 disabled=no interface="ether3-subnet1 CID office" \
name=Basement
add address-pool=dhcp_pool1 disabled=no interface="vlan11 CID office" name=\
"Upstairs wired"
add address-pool=dhcp_pool1 disabled=no interface=ether4-admin name=\
"Admin port"
add address-pool=dhcp_pool0 disabled=no interface="vlan10 translation" name=\
Translation
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=\
ether2-vlan network=192.168.88.0
add address=192.168.3.1/24 interface="vlan13 Admin only" network=192.168.3.0
add address=192.168.0.1/24 interface="vlan10 translation" network=192.168.0.0
add address=192.168.2.1/24 disabled=yes network=192.168.2.0
add address=192.168.8.1/24 interface="vlan18 OpenVPN" network=192.168.8.0
add address=192.168.2.1/24 interface="vlan12 CID wireless" network=\
192.168.2.0
add address=192.168.1.1/24 comment="Management port" interface=ether2-vlan \
network=192.168.1.0
add address=192.168.5.1/24 interface="vlan15 Guest Internet only" network=\
192.168.5.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=\
no interface=ether1-gateway
# sep/09/2019 03:18:55 by RouterOS 6.42.11
# software id = H2AJ-QXHP
# model = RB750Gr3
/interface ethernet
set [ find default-name=ether1 ] name=eth1-gateway
set [ find default-name=ether2 ] arp=proxy-arp l2mtu=1598 name=eth2-vlan
set [ find default-name=ether3 ] l2mtu=1598 mac-address=4C:5E:0C:AB:85:8D \
name=eth3-basement
set [ find default-name=ether4 ] l2mtu=1598 mac-address=4C:5E:0C:AB:85:8E \
name=eth4-admin
set [ find default-name=ether5 ] l2mtu=1598 mac-address=4C:5E:0C:AB:85:8F \
name=eth5-default
/ip pool
add name=dhcp_pool3 ranges=192.168.3.151-192.168.3.180
add name=dhcp_pool0 ranges=192.168.0.200-192.168.0.253
add name=dhcp_pool2 ranges=192.168.2.200-192.168.2.253
add name=dhcp_pool1 next-pool=dhcp_pool1a ranges=192.168.1.151-192.168.1.220
add name=dhcp_pool1a ranges=192.168.1.90-192.168.1.150
add name=dhcp_pool8VPN ranges=192.168.8.200-192.168.8.254
add name=adminpool ranges=192.168.88.90-192.168.88.253
add name=dhcp_pool4 ranges=192.168.4.151-192.168.4.220
/ip dhcp-server
add address-pool=dhcp_pool8VPN lease-time=6h name=VPN
add address-pool=adminpool disabled=no interface=eth5-default name=default
add address-pool=dhcp_pool0 disabled=no interface="vlan10 translation" name=Translation
add address-pool=dhcp_pool2 disabled=no interface="vlan12 CID wireless" name=Wireless
add address-pool=dhcp_pool3 disabled=no interface=eth3-basement name=Basement
add address-pool=dhcp_pool1 disabled=no interface="vlan11 CID office" name="CID wired upstairs"
/ip address
add address=192.168.10.2/24 interface=eth1-gateway network=192.168.10.0
add address=192.168.3.1/24 interface=eth3-basement network=192.168.3.0
add address=192.168.4.1/24 interface=eth4-admin network=192.168.4.0
add address=192.168.88.1/24 comment="default configuration" interface=eth5-default network=192.168.88.0
add address=192.168.0.1/24 interface="vlan10 translation" network=192.168.0.0
add address=192.168.1.1/24 interface="vlan11 CID office" network=192.168.1.0
add address=192.168.2.1/24 interface="vlan12 CID wireless" network=192.168.2.0
add address=192.168.5.1/24 interface="vlan15 Guest Internet only" network=192.168.5.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid interface=eth1-gateway
How does one check to see if the Mikrotik is receiving a DHCP address?Bridge mode means that the router should get a dynamic address. If you have a static allocation your gateway would have to be in router/gateway mode.
DHCP should work if the gateway device is actually handing out a DHCP address. Run the packet sniffer to see if dhcp requests are being sent and how they are being replied to by the gateway.
The only real reason to ever use these devices is if you need static addresses. If you don't just get a regular modem and things will "just work".
That's the problem I've been running into with Comcast. Not only do they all have different answers, they all disregard what the previous rep concluded after I spent hours on the phone. I've had to prove over and over to each new tech that something is wrong with the Comcast modem. Until the one guy I spoke to today who insisted the modem was working even when it wasn't, until he bricked it.viewtopic.php?f=2&t=165733
OP, I posted my thread in "General" section. Near identical issue.
Every other Comcast tech gave me a different answer. One I spoke this morning says bridge mode requires static IP. I have dynamic IP. So he recommends "pass through" mode: disable Comcast wifi and remove IPV4 and IPV6 firewalls. Keep DHCP on. I did so and still no internet.
Latest tech thinks Mikrotik router is not configured properly to receive DHCP from Comcast. I'm not sure how to check if the Mikrotik is setup properly.
Go to Terminal window, typeNewb question: how does one look and post the router 's config? Sorry for hijack.
export file my-current-config
1) If Mikrotik is set to obtain an address automatically, and your Internet is working downstream from the Mikrotik, it got a DHCP address.How does one check to see if the Mikrotik is receiving a DHCP address?
In my case, I don't need the static IP address, but what I DO need is to set up VLANs with advanced firewall rules. Internet service is in the basement of one brick building, and all the office equipment is in an addition separated by a lot of concrete. The Mikrotik's programmability allows me to maximize the use of a single cable in between, and keep everything secure.The only real reason to ever use these devices is if you need static addresses. If you don't just get a regular modem and things will "just work".
Yes, it didn't work like that, which is what finally got Comcast to replace the router. But unfortunately they replaced it with another non-functioning one. I've ordered my own Arris modem from Amazon which will arrive next week, but in the mean time I've got a brand-new routerboard I brought home that I cannot access or log into ever since it failed to get an IP address from Comcast. And it did the same thing a few days ago. As soon as it failed to get a dynamic WAN IP address, it stopped working altogether and had to be factory reset. Any ideas on why?Put comcast into pure bridge mode and try with a computer attached directly if you can set it in the way that everything starts to work.
One tech claims that if comcast modem is in bridge mode, it would require static IP. True or false?Really strange things. Put comcast into pure bridge mode and try with a computer attached directly if you can set it in the way that everything starts to work. Then replicate the settings to wan port of the router. Check it gets the expected ip address and is able to get the Internet connection then step forward... You need to split the aresas of possible problems and investigate them independently.
Thanks for the tips. In your case, is your Mikrotik showing an IP address? I assume if all is working correctly, the Mikrotik should show the Comcast gateway's IP.1) If Mikrotik is set to obtain an address automatically, and your Internet is working downstream from the Mikrotik, it got a DHCP address.How does one check to see if the Mikrotik is receiving a DHCP address?
2) Log into web admin and go to Quick set. It will show you the IP address it obtained by DHCP.
If all is working correctly, the Mikrotik should have at least two IPs, one for WAN (coming from Comcast), and one for LAN (which it displays inside to your other devices). It's possible to assign a different IP address to each ethernet port and interface on the RB.Thanks for the tips. In your case, is your Mikrotik showing an IP address? I assume if all is working correctly, the Mikrotik should show the Comcast gateway's IP.
I don't know if it's true or not, but given the level of knowledge of several of the Comcast reps I talked to today, I'd take it with a grain of salt and verify independently. That doesn't sound right to me.One tech claims that if comcast modem is in bridge mode, it would require static IP. True or false?
Copied and paste from a Comcast forum, posted by a Comcast tech:I don't know if it's true or not, but given the level of knowledge of several of the Comcast reps I talked to today, I'd take it with a grain of salt and verify independently. That doesn't sound right to me.One tech claims that if comcast modem is in bridge mode, it would require static IP. True or false?
That's correct. That's pretty much the definition of bridge mode. When the Comcast router is in bridge mode, it's your Mikrotik that gets the IP address, whether dynamic or static. And it has to be the only device connected.Copied and paste from a Comcast forum, posted by a Comcast tech:
"On the Comcast Network Static IP address cannot be assigned to a bridged device. Placing the device in <true bridge mode> disables all router functions of the gateway. In <true bridge mode> the public IP is passed directly to only one connected device, multiple connections to additional gateway LAN ports will create an IP conflict."
Where does one find this option? Thanks.For those with the odd behavior of not being able to connect after some time you might want to set all detect-internet interfaces to none.
Thanks. Can I ask what is the default option in case we need to go back?/interface detect-internet detect-interface-list=none
Can you clarify? So this line is by default?: /interface detect-internet detect-interface-list=noneThe default (from the default config from an rb931) is none. I don't think this is enabled default. If you use quickset or set it manually it is enabled.
In the WebFig, go to Interfaces, then click on the button "Detect Internet." Only the WAN port should detect Internet, or none of them.Can you clarify? So this line is by default?: /interface detect-internet detect-interface-list=none
Quick Set should only be used once on a device which has been reset to default. If you make any other changes to the configuration with Winbox, Webfig or CLI the results of running Quick Set again are completely unpredictable.UPDATE: There's something on the Quick Set page that kept breaking my RB. Whether or not I'm connected to Comcast, once I apply the settings in Quick Set, the box becomes unusable. The config that I restored has WAN IP 192.168.10.2 (static) and LAN IP 192.168.88.1 or 192.168.1.1 on the Quick Set page. When I restore the image and log in, it shows my LAN IP as 192.168.10.2, and my WAN IP as either static 0.0.0.0 or automatic.
Thanks. That's really helpful. Currently Quick Set shows the WAN IP address as 0.0.0.0. How/where do I get rid of that or change it in webfig? I'd like to to be an automatic IP address.Quick Set should only be used once on a device which has been reset to default. If you make any other changes to the configuration with Winbox, Webfig or CLI the results of running Quick Set again are completely unpredictable.
NM, I found this here: https://help.mikrotik.com/docs/display/ ... figurationCurrently Quick Set shows the WAN IP address as 0.0.0.0. How/where do I get rid of that or change it in webfig? I'd like to to be an automatic IP address.
Is the source of our problem? Should it be changed to match that of Comcast gateway?Thanks. That's really helpful. Currently Quick Set shows the WAN IP address as 0.0.0.0. How/where do I get rid of that or change it in webfig? I'd like to to be an automatic IP address.Quick Set should only be used once on a device which has been reset to default. If you make any other changes to the configuration with Winbox, Webfig or CLI the results of running Quick Set again are completely unpredictable.
No. Only if you have a static IP and bridge mode.Should it be changed to match that of Comcast gateway?
If default Comcast gateway is 10.1.10.1 and we have dynamic IP, what should WAN IP address be set at?No. Only if you have a static IP and bridge mode.Should it be changed to match that of Comcast gateway?
If your RB is behind the Comcast router (not in bridge mode), then both devices get a WAN IP and LAN IP. The Comcast router gets your public IP from Comcast; it presents 10.1.10.1 as the LAN IP. Your RB gets 10.1.10.x as it's "WAN IP" then presents something else on another subnet as LAN IP.If default Comcast gateway is 10.1.10.1 and we have dynamic IP, what should WAN IP address be set at?
0.0.0.0 is not a valid address, in a field which must contain an address it is often used as a placeholder to signify "unknown" or "anything". If the WAN is set to auto in Quick Set it is irrelevent, the actual IP address will be seen in under IP > DHCP Client or IP > Addresses.Is the source of our problem? Should it be changed to match that of Comcast gateway?Thanks. That's really helpful. Currently Quick Set shows the WAN IP address as 0.0.0.0. How/where do I get rid of that or change it in webfig? I'd like to to be an automatic IP address.
What should OP do in the case where the WAN IP is 0.0.0.0? Are you saying if the WAN is set to auto, the 0.0.0.0 WAN IP is of no problem? If WAN is not set to auto, what should OP set the WAN IP as? Somehow, our Mikrotik routers are not receiving a DHCP address from the Comcast gateway.0.0.0.0 is not a valid address, in a field which must contain an address it is often used as a placeholder to signify "unknown" or "anything". If the WAN is set to auto in Quick Set it is irrelevent, the actual IP address will be seen in under IP > DHCP Client or IP > Addresses.Is the source of our problem? Should it be changed to match that of Comcast gateway?Thanks. That's really helpful. Currently Quick Set shows the WAN IP address as 0.0.0.0. How/where do I get rid of that or change it in webfig? I'd like to to be an automatic IP address.
OPs church (as well as my office) have dynamic IP. What should the IP address be set at?0.0.0.0 is not a valid address, in a field which must contain an address it is often used as a placeholder to signify "unknown" or "anything". If the WAN is set to auto in Quick Set it is irrelevent, the actual IP address will be seen in under IP > DHCP Client or IP > Addresses.Is the source of our problem? Should it be changed to match that of Comcast gateway?Thanks. That's really helpful. Currently Quick Set shows the WAN IP address as 0.0.0.0. How/where do I get rid of that or change it in webfig? I'd like to to be an automatic IP address.
Try this, I found it on nextiva's site, and may be relevant for us. I'm going to try it at end of day:If your RB is behind the Comcast router (not in bridge mode), then both devices get a WAN IP and LAN IP. The Comcast router gets your public IP from Comcast; it presents 10.1.10.1 as the LAN IP. Your RB gets 10.1.10.x as it's "WAN IP" then presents something else on another subnet as LAN IP.If default Comcast gateway is 10.1.10.1 and we have dynamic IP, what should WAN IP address be set at?
I have dynamic IP. What would happen if Comcast is in "pass through" mode, and I turned IPV4 LAN DHCP off. Currently my Comcast has firewall off w/Mikrotik in router mode, but no internet.That's the problem I've been running into with Comcast. Not only do they all have different answers, they all disregard what the previous rep concluded after I spent hours on the phone. I've had to prove over and over to each new tech that something is wrong with the Comcast modem. Until the one guy I spoke to today who insisted the modem was working even when it wasn't, until he bricked it.
But I'm simultaltneously dealing with Mikrotik RB issues and it's VERY hard to troubleshoot when both are going on!
From many, many years of networking experience, I can say that either of these SHOULD work:In point of fact, I have used all of those modes with Comcast and various routers, including Mikrotik routers.
- Comcast in router mode, giving out DHCP + Mikrotik in router mode, getting WAN IP address automatically. Requires an extra "hop" so very slight performance degradation, but should work.
- Comcast in "pass-through" router mode, with DHCP off and firewall off + Mikrotik in router mode, with WAN IP address set statically.
- Comcast in actual bridge mode + Mikrotik getting WAN IP address automatically
Mixing those (like the Comcast rep this morning was insisting on until he bricked the box) with "pass-through" mode but no static IP on the Mikrotik should not work.
Comcast always prefers to upsell you to a more expensive package rather than fix their non-working equipment or train their reps, but there is no reason why you need to pay $25/month for a $0.50 static IP from Comcast in order for the Internet to work.
I suspect that will not work. My understanding is that "pass through" mode is not the same as true bridge mode, so nothing would be giving your Mikrotik an IP address at that point.I have dynamic IP. What would happen if Comcast is in "pass through" mode, and I turned IPV4 LAN DHCP off. Currently my Comcast has firewall off w/Mikrotik in router mode, but no internet.
I just tried above and did not work. Still no internet. I'm about to give up. I'm using a Mikrotik hAP ac2 router btw.Try this, I found it on nextiva's site, and may be relevant for us. I'm going to try it at end of day:If your RB is behind the Comcast router (not in bridge mode), then both devices get a WAN IP and LAN IP. The Comcast router gets your public IP from Comcast; it presents 10.1.10.1 as the LAN IP. Your RB gets 10.1.10.x as it's "WAN IP" then presents something else on another subnet as LAN IP.If default Comcast gateway is 10.1.10.1 and we have dynamic IP, what should WAN IP address be set at?
For DPC3941B Only:
Navigate to Advanced > NAT.
Uncheck the Disable All checkbox if there is a checkmark in the box.
Reboot the router and any devices connected to the router.
The lines quoted include one of your problems. You have all your LAN interfaces bridged together. But you assigned 192.168.88.1 to ether2 and not to the bridge. Delete that IP address from ether2 and assign it to the bridge.Sorry for the hijack OP....
I just tried this connection: Comcast gateway in "pass through mode" Port 1 --> Mikrotik port 1; M port 2 goes to main switch; M port 5 I hook up my laptop
With my laptop I login directly into the Mikrotik wifi, I get internet connection.
Office workstations connected via main switch still has no internet.
Under Router OS -> Interfaces -> Interface -> I see packets being sent/received for ethernet ports 1, 2, 5
Does this suggest a setting is wrong with the main switch?
Below is the config of the Mikrotik router. Any suggestions on what to do?
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=\
192.168.88.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1 use-peer-dns=no
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=8.8.8.8,8.8.4.4 \
gateway=192.168.88.1
Thanks for responding.The lines quoted include one of your problems. You have all your LAN interfaces bridged together. But you assigned 192.168.88.1 to ether2 and not to the bridge. Delete that IP address from ether2 and assign it to the bridge.Sorry for the hijack OP....
I just tried this connection: Comcast gateway in "pass through mode" Port 1 --> Mikrotik port 1; M port 2 goes to main switch; M port 5 I hook up my laptop
With my laptop I login directly into the Mikrotik wifi, I get internet connection.
Office workstations connected via main switch still has no internet.
Under Router OS -> Interfaces -> Interface -> I see packets being sent/received for ethernet ports 1, 2, 5
Does this suggest a setting is wrong with the main switch?
Below is the config of the Mikrotik router. Any suggestions on what to do?
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=\
192.168.88.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1 use-peer-dns=no
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=8.8.8.8,8.8.4.4 \
gateway=192.168.88.1
IP --> AddressesCan you let me know how do I delete that IP from ether2 and assign it to the bridge?
Apologies to the OP. Will continue in said thread above and in my post on other section.You should join corresponding thread instead of the hijacking the non relevant one.
Here it was solved already:
https://r.tapatalk.com/shareLink/topic? ... source=app
FAILED SETUP: Internet works only on wifi