Hey,
What have you tried until now?
There are some missing pieces to understand the technical issue.
Who is behind the Mikrotik device?
What are the routes on the Mikrotik device?
Might help to understand.
What you technically need to do is add a dnat rule on the l2tp\sstp interface with the local address and the corresponding firewall rules in the filter table.
I cannot assume what is the technical setup regarding what is in the Mikrotik device.
If you would share more info, maybe via a supout.rif or other output from the device me or others might be able to assist you
And as a side note, a L2TP is a tunnel and should have /32 address, the Gateway for such a device is the device itself.
With the right settings you don't need to add anything else then configuring the tunnel and the DHCP client properly.
(Assuming the TP-Link was good enough for you)
Example firewall rules:
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
add action=dst-nat chain=dstnat dst-address-type=local dst-port=80 in-interface-list=WAN protocol=tcp to-addresses=192.168.10.10
/ip firewall filter
add action=accept chain=forward comment="Accept ESTABLISH,RELATED" connection-state=established,related
add action=drop chain=forward comment="Drop INVALID" connection-state=invalid
add action=accept chain=forward comment="Accept NEW From LAN" connection-state=new in-interface-list=LAN
add action=accept chain=forward comment="ACCEPT DNAT FROM WAN" connection-nat-state=dstnat connection-state=new in-interface-list=WAN
add action=drop chain=forward comment="DROP New From WAN" connection-state=new in-interface-list=WAN
add action=accept chain=input comment="Allow ESTABLISHED Related" connection-state=established,related
add action=accept chain=input comment="ipsec policy matcher" ipsec-policy=in,ipsec
add action=accept chain=input comment="Accept ICMP on WAN" connection-state=new in-interface-list=WAN protocol=icmp
add action=drop chain=input connection-state=new in-interface-list=WAN
Since there was an example of a TP-Link working then it should be working the same on the Mikrotik device.
It's not a DUAL-WAN scenario in the TP-Link since it's converting the current default GW to the l2tp one.
In Mikrotik the only main issue with this L2TP connection is that it will not fetch the published DNS servers.
Example for my setup L2TP:
/interface l2tp-client
add add-default-route=yes allow=pap,chap allow-fast-path=yes comment=ISP1 connect-to=isp-host.net.il default-route-distance=5 name=l2tp-out1 password=test user=test1
/ip dhcp-client
add add-default-route=yes default-route-distance=20 dhcp-options=hostname,clientid disabled=yes interface=ether1 use-peer-dns=yes use-peer-ntp=yes
/ip dns
set allow-remote-requests=yes servers=192.168.1.254,8.8.8.8
To verify if FastPath or RouteCache is the issue you can set these to no:
/ip settings
set allow-fast-path=no route-cache=no
Let me know if some of this helps you.
Hello,
I am very new to Mikrotik, not much experience here.
Please see the picture first!
https://imgur.com/a/OFTV68D
We live in a very remote place where LTE and satellite internet are the only internet source available. We need to access web server from outside internet and of course the internet provider mentioned earlier doesn't have any public IP address. We found a vendor who is renting out public IP address and deliver it using either L2TP or SSTP.
We configure L2TP in our mikrotik, it is connected and getting public IP address. However, we have no idea on how to port forward to web server which on LAN 192.168.10.10/24
Ideally, client access from outside will be using public IP and the rest of default traffic will be going out using LTE internet
How can I accomplish that? I have very limited experience here so need step by step instruction in order to accomplish it.
Thank you