I'm trying to connect through to Windscribe VPN via Mikrotik using IKEv2 client. I've followed the guide from here:
https://www.reddit.com/user/gromo3eka/c ... indscribe/
For whatever reason I believe that this works fine in 6.46.X but after going to 6.47+, I'm experiencing some problems. To the extent that I've stripped everything back to basics and am still struggling to figure out what is wrong.
Here is the config:
Code: Select all
# dec/12/2020 02:27:28 by RouterOS 6.47.8
# software id = XXX
#
# model = RouterBOARD 1100Dx4
# serial number = XXXX
/interface bridge
add fast-forward=no name=bridge1
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether13 name=pppoe-out1 user=\
xxxx
/interface ethernet switch port
set 0 default-vlan-id=0
set 1 default-vlan-id=0
set 2 default-vlan-id=0
set 3 default-vlan-id=0
set 4 default-vlan-id=0
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 10 default-vlan-id=0
set 11 default-vlan-id=0
set 12 default-vlan-id=0
set 13 default-vlan-id=0
set 14 default-vlan-id=0
set 15 default-vlan-id=0
/interface list
add name=LAN
add name=WAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec mode-config
add name=WindscribeVPN responder=no src-address-list=SendThruVPN
/ip ipsec policy group
add name=WindscribeVPN
/ip ipsec profile
add dh-group=ecp384 enc-algorithm=aes-256 hash-algorithm=sha256 name=\
WindscribeVPN
/ip ipsec peer
add address=sk.windscribe.com exchange-mode=ike2 name=WindscribeVPN profile=\
WindscribeVPN
/ip ipsec proposal
add auth-algorithms=sha256 enc-algorithms=aes-256-gcm name=WindscribeVPN \
pfs-group=ecp384
/ip pool
add name=default_dhcp ranges=192.168.88.20-192.168.88.200
/ip dhcp-server
add address-pool=default_dhcp disabled=no interface=bridge1 name=default_dhcp
/interface bridge port
add bridge=bridge1 interface=ether12
/interface bridge settings
set allow-fast-path=no
/interface list member
add interface=bridge1 list=LAN
add interface=pppoe-out1 list=WAN
add list=LAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether12 network=\
192.168.88.0
/ip dhcp-server network
add address=192.168.11.0/24 dns-server=8.8.8.8 gateway=192.168.11.1 netmask=\
24
add address=192.168.88.0/24 dns-server=1.1.1.1 gateway=192.168.88.1 netmask=\
24
/ip dns
set servers=8.8.8.8
/ip firewall address-list
add address=192.168.88.0/24 list=SendThruVPN
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=drop chain=input dst-port=53 in-interface-list=WAN log=yes \
protocol=tcp
add action=drop chain=input dst-port=53 in-interface-list=WAN log=yes \
protocol=udp
add action=drop chain=input comment=\
"Don't allow these IP addresses to connect" log=yes log-prefix=DENIED \
src-address-list="Do not allow"
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add action=drop chain=input in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="Hairpin NAT" dst-address=\
192.168.1.0/24 out-interface=bridge1 src-address=192.168.1.0/24
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
192.168.89.0/24
add action=masquerade chain=srcnat comment="masq. L2TP vpn traffic" \
src-address=192.168.17.0/24
/ip firewall service-port
set h323 disabled=yes
set sip disabled=yes
/ip ipsec identity
add auth-method=eap certificate="" eap-methods=eap-mschapv2 generate-policy=\
port-strict mode-config=WindscribeVPN peer=WindscribeVPN \
policy-template-group=WindscribeVPN remote-id=fqdn:sk.windscribe.com \
username=XXX
/ip ipsec policy
add dst-address=0.0.0.0/0 group=WindscribeVPN proposal=WindscribeVPN \
src-address=0.0.0.0/0 template=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/London
/system logging
add prefix=IPSEC topics=ipsec
/system ntp client
set enabled=yes server-dns-names=\
0.uk.pool.ntp.org,1.uk.pool.ntp.org,2.uk.pool.ntp.org,3.uk.pool.ntp.org
I don't know if this is related but I've noticed that for whatever reason using Terminal from Winbox, I cannot resolve any hostnames once the VPN connection is established.
If anyone can point out what's wrong it'd be great! Thanks