Thanks for the quick replay and it's encouraging that you had a similar issue, but then resolved.
Below is the current configuration, using CAPsMAN which does not allow clients to get internet (because in my opinion CAPsMAN is not setting wlan1 and wlan2 with proper VLAN info).
# jan/09/2021 08:36:13 by RouterOS 6.46.8
# software id = 9R4M-XPCB
#
# model = RBD52G-5HacD2HnD
# serial number = D7160CB42EC8
/interface bridge
add admin-mac=48:8F:5A:C4:20:69 auto-mac=no comment=defconf name=bridge \
protocol-mode=none vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] l2mtu=1592
set [ find default-name=ether2 ] l2mtu=1592
set [ find default-name=ether3 ] l2mtu=1592
set [ find default-name=ether4 ] l2mtu=1592
set [ find default-name=ether5 ] l2mtu=1592 name=ether5-mgmt
/interface vlan
add comment="VLAN99 - mgmt" interface=bridge name=mgmt-VLAN vlan-id=99
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=\
CRLNetWPA2_5G supplicant-identity=""
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=\
CRLNetWPA2_2G supplicant-identity=""
/interface wireless
# managed by CAPsMAN
# channel: 2472/20/gn(-3dBm), SSID: CRLNet.072.2G, local forwarding
# managed by CAPsMAN
# channel: 5745/20-Ceee/ac(4dBm), SSID: CRLNet.072, local forwarding
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add comment=mgmt-lan name=mgmt-lan ranges=192.168.88.2-192.168.88.239
/ip dhcp-server
add address-pool=mgmt-lan disabled=no interface=ether5-mgmt name=mgmt-dhcp
/user group
set full policy="local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,pas\
sword,web,sniff,sensitive,api,romon,dude,tikapp"
/interface bridge port
add bridge=bridge comment=defconf frame-types=\
admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=\
ether2 pvid=10
add bridge=bridge comment=defconf frame-types=\
admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=\
ether3 pvid=10
add bridge=bridge comment=defconf frame-types=\
admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=\
ether4 pvid=10
add bridge=bridge frame-types=admit-only-vlan-tagged ingress-filtering=yes \
interface=ether1
/ip neighbor discovery-settings
set discover-interface-list=all
/interface bridge vlan
add bridge=bridge comment=Mgmt tagged=bridge,ether1 vlan-ids=99
add bridge=bridge tagged=ether1 untagged=wlan1,wlan2 vlan-ids=10
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/interface wireless cap
#
set bridge=bridge discovery-interfaces=mgmt-VLAN enabled=yes interfaces=\
wlan2,wlan1
/ip address
add address=192.168.88.1/24 comment="Mgmt subnet" interface=ether5-mgmt \
network=192.168.88.0
add address=192.168.99.251/24 comment="Mgmt VLAN99 subnet" interface=\
mgmt-VLAN network=192.168.99.0
/ip dhcp-server network
add address=192.168.88.0/24 comment="Management network" dns-server=\
208.67.222.222 domain=mgmt.lan gateway=192.168.88.1 netmask=24
/ip dns
set servers=10.5.5.5
/ip dns static
add address=192.168.10.251 comment=defconf name=rb7ap.router.lan
/ip route
add distance=1 gateway=192.168.99.240
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Rome
/system identity
set name=rb7ap
/system ntp client
set enabled=yes primary-ntp=193.204.114.233 secondary-ntp=37.247.53.178 \
server-dns-names=10.5.5.5
/system package update
set channel=long-term
/system watchdog
set watchdog-timer=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool romon
set enabled=yes
Do you see anything where I could add the VLAN10 setting for wlan1 and wlan2 using CAPsMAN ?
In the CAPsMAN router I have enabled a Datapath set which has VLAN Mode=no tag and VLAN ID=10, so that those wlan should have had such untagged vlan10.
But it does not work, even though the interfaces are managed by CAPsMAN.
However when setting wlan1 and wlan2 manually, and assigned untagged and vlan id10, then clients get access to internet as those wlans act as untagged ports.