This is our network setup:
Client Device -> Router -> Mikrotik RB750gr3 -> ISP(WAN)
Code: Select all
/ip firewall mangle
add action=change-ttl chain=postrouting new-ttl=set:2 out-interface=all-ppp passthrough=yes
But in this setup the problem is that if a client connects another router instead of a device, the routers that they have automatically increase(yes, increase instead of -1) if the is TTL=1 to TTL=128.
To solve this I am trying to implement instead that if the incoming packets to my Mikrotik from the client having TTL<=62, the packets would be dropped automatically.
This is the command I'm using but its not working.
Code: Select all
/ip firewall filter
add action=drop chain=prerouting ttl=less-than:63
I hope someone could help me on this.