I trying to get work ipv6 dhcp-client on Vlan interface on a vlan aware bridge under ros v6.46 on my RB1100AHx2.
config:
Code: Select all
/interface bridge
add name=LAN protocol-mode=mstp region-name=LAN region-revision=1 vlan-filtering=yes
/interface bridge msti
add bridge=LAN identifier=1 vlan-mapping=1-4094
/interface bridge port
add bridge=LAN interface=ether10
/interface bridge vlan
add bridge=LAN tagged=ether10,LAN vlan-ids=808
/interface vlan
add interface=LAN name=Vlan808 vlan-id=808
/ipv6 dhcp-client
add interface=Vlan808 pool-name=ipv6pool_vlan808 request=address,prefix
Code: Select all
$ tshark -r dhcpv6.pcap -V
Frame 1: 112 bytes on wire (896 bits), 112 bytes captured (896 bits)
Encapsulation type: Ethernet (1)
Arrival Time: Dec 9, 2019 13:48:12.612234000 CET
[Time shift for this packet: 0.000000000 seconds]
Epoch Time: 1575895692.612234000 seconds
[Time delta from previous captured frame: 0.000000000 seconds]
[Time delta from previous displayed frame: 0.000000000 seconds]
[Time since reference or first frame: 0.000000000 seconds]
Frame Number: 1
Frame Length: 112 bytes (896 bits)
Capture Length: 112 bytes (896 bits)
[Frame is marked: False]
[Frame is ignored: False]
[Protocols in frame: eth:ethertype:ipv6:udp:dhcpv6]
Ethernet II, Src: Routerbo_01:02:03 (4c:5e:0c:01:02:03), Dst: IPv6mcast_01:00:02 (33:33:00:01:00:02)
Destination: IPv6mcast_01:00:02 (33:33:00:01:00:02)
Address: IPv6mcast_01:00:02 (33:33:00:01:00:02)
.... ..1. .... .... .... .... = LG bit: Locally administered address (this is NOT the factory default)
.... ...1 .... .... .... .... = IG bit: Group address (multicast/broadcast)
Source: Routerbo_01:02:03 (4c:5e:0c:01:02:03)
Address: Routerbo_01:02:03 (4c:5e:0c:01:02:03)
.... ..0. .... .... .... .... = LG bit: Globally unique address (factory default)
.... ...0 .... .... .... .... = IG bit: Individual address (unicast)
Type: IPv6 (0x86dd)
Internet Protocol Version 6, Src: fe80::4e5e:cff:fe01:203, Dst: ff02::1:2
0110 .... = Version: 6
.... 0000 0000 .... .... .... .... .... = Traffic Class: 0x00 (DSCP: CS0, ECN: Not-ECT)
.... 0000 00.. .... .... .... .... .... = Differentiated Services Codepoint: Default (0)
.... .... ..00 .... .... .... .... .... = Explicit Congestion Notification: Not ECN-Capable Transport (0)
.... .... .... 0000 0000 0000 0000 0000 = Flow Label: 0x00000
Payload Length: 58
Next Header: UDP (17)
Hop Limit: 1
Source: fe80::4e5e:cff:fe01:203
Destination: ff02::1:2
[Source SA MAC: Routerbo_01:02:03 (4c:5e:0c:01:02:03)]
User Datagram Protocol, Src Port: 546, Dst Port: 547
Source Port: 546
Destination Port: 547
Length: 58
Checksum: 0x9de7 [unverified]
[Checksum Status: Unverified]
[Stream index: 0]
[Timestamps]
[Time since first frame: 0.000000000 seconds]
[Time since previous frame: 0.000000000 seconds]
DHCPv6
Message type: Solicit (1)
Transaction ID: 0x043f69
Client Identifier
Option: Client Identifier (1)
Length: 10
Value: 000300014c5e0c010200
DUID: 000300014c5e0c010200
DUID Type: link-layer address (3)
Hardware type: Ethernet (1)
Link-layer address: 4c:5e:0c:5a:46:57
Identity Association for Non-temporary Address
Option: Identity Association for Non-temporary Address (3)
Length: 12
Value: 0000001c0000070800000b40
IAID: 0000001c
T1: 1800
T2: 2880
Option Request
Option: Option Request (6)
Length: 2
Value: 0017
Requested Option code: DNS recursive name server (23)
Elapsed time
Option: Elapsed time (8)
Length: 2
Value: cd78
Elapsed time: 526000ms
Rapid Commit
Option: Rapid Commit (14)
Length: 0
Frame 2: 178 bytes on wire (1424 bits), 178 bytes captured (1424 bits)
Encapsulation type: Ethernet (1)
Arrival Time: Dec 9, 2019 13:48:12.615453000 CET
[Time shift for this packet: 0.000000000 seconds]
Epoch Time: 1575895692.615453000 seconds
[Time delta from previous captured frame: 0.003219000 seconds]
[Time delta from previous displayed frame: 0.003219000 seconds]
[Time since reference or first frame: 0.003219000 seconds]
Frame Number: 2
Frame Length: 178 bytes (1424 bits)
Capture Length: 178 bytes (1424 bits)
[Frame is marked: False]
[Frame is ignored: False]
[Protocols in frame: eth:ethertype:ipv6:udp:dhcpv6]
Ethernet II, Src: Cisco_03:9f:41 (8c:60:4f:03:9f:41), Dst: Routerbo_01:02:03 (4c:5e:0c:01:02:03)
Destination: Routerbo_01:02:03 (4c:5e:0c:01:02:03)
Address: Routerbo_01:02:03 (4c:5e:0c:01:02:03)
.... ..0. .... .... .... .... = LG bit: Globally unique address (factory default)
.... ...0 .... .... .... .... = IG bit: Individual address (unicast)
Source: Cisco_03:9f:41 (8c:60:4f:03:9f:41)
Address: Cisco_03:9f:41 (8c:60:4f:03:9f:41)
.... ..0. .... .... .... .... = LG bit: Globally unique address (factory default)
.... ...0 .... .... .... .... = IG bit: Individual address (unicast)
Type: IPv6 (0x86dd)
Internet Protocol Version 6, Src: 2001:db8:0:b00b::fff1, Dst: fe80::4e5e:cff:fe01:203
0110 .... = Version: 6
.... 0000 0000 .... .... .... .... .... = Traffic Class: 0x00 (DSCP: CS0, ECN: Not-ECT)
.... 0000 00.. .... .... .... .... .... = Differentiated Services Codepoint: Default (0)
.... .... ..00 .... .... .... .... .... = Explicit Congestion Notification: Not ECN-Capable Transport (0)
.... .... .... 0000 0000 0000 0000 0000 = Flow Label: 0x00000
Payload Length: 124
Next Header: UDP (17)
Hop Limit: 255
Source: 2001:db8:0:b00b::fff1
Destination: fe80::4e5e:cff:fe01:203
[Destination SA MAC: Routerbo_01:02:03 (4c:5e:0c:01:02:03)]
User Datagram Protocol, Src Port: 547, Dst Port: 546
Source Port: 547
Destination Port: 546
Length: 124
Checksum: 0x66e6 [unverified]
[Checksum Status: Unverified]
[Stream index: 1]
[Timestamps]
[Time since first frame: 0.000000000 seconds]
[Time since previous frame: 0.000000000 seconds]
DHCPv6
Message type: Advertise (2)
Transaction ID: 0x043f69
Identity Association for Non-temporary Address
Option: Identity Association for Non-temporary Address (3)
Length: 40
Value: 0000001c00000000000000000005001820010db80000b00b…
IAID: 0000001c
T1: 0
T2: 0
IA Address
Option: IA Address (5)
Length: 24
Value: 20010db80000b00b11bb2c83cf2e3704000069780000a8c0
IPv6 address: 2001:db8:0:b00b:11bb:2c83:cf2e:3704
Preferred lifetime: 27000
Valid lifetime: 43200
Client Identifier
Option: Client Identifier (1)
Length: 10
Value: 000300014c5e0c010200
DUID: 000300014c5e0c010200
DUID Type: link-layer address (3)
Hardware type: Ethernet (1)
Link-layer address: 4c:5e:0c:5a:46:57
Server Identifier
Option: Server Identifier (2)
Length: 14
Value: 000100011ed5a517001999b3abf3
DUID: 000100011ed5a517001999b3abf3
DUID Type: link-layer address plus time (1)
Hardware type: Ethernet (1)
DUID Time: May 23, 2016 13:25:11.000000000 CEST
Link-layer address: 00:19:99:b3:ab:f3
DNS recursive name server
Option: DNS recursive name server (23)
Length: 32
Value: 20010db80000babe000000000053000120010db80000babe…
1 DNS server address: 2001:db8:0:babe::53:1
2 DNS server address: 2001:db8:0:babe::53:2
Code: Select all
16:06:30 dhcp,debug,packet send Vlan808 -> ff02::1:2%13
16:06:30 dhcp,debug,packet type: solicit
16:06:30 dhcp,debug,packet transaction-id: 87464e
16:06:30 dhcp,debug,packet -> clientid: 00030001 4c5e0c5a 4657
16:06:30 dhcp,debug,packet -> ia_na:
16:06:30 dhcp,debug,packet t1: 1800
16:06:30 dhcp,debug,packet t2: 2880
16:06:30 dhcp,debug,packet id: 0x1c
16:06:30 dhcp,debug,packet -> oro: 23
16:06:30 dhcp,debug,packet -> elapsed_time: 2000
16:06:30 dhcp,debug,packet -> rapid_commit: [empty]
16:06:30 dhcp,debug,packet -> ia_pd:
16:06:30 dhcp,debug,packet t1: 1800
16:06:30 dhcp,debug,packet t2: 2880
16:06:30 dhcp,debug,packet id: 0x1c
Any idea, whats wrong?