Mon Feb 15, 2021 1:42 pm
Hi MKX,
Thanks a lot!
After reading the article you suggested, I am able to create the VLAN.
I found the missing step I didn't do before was set the bridge as a tagged member.
Example command as below.
set bridge=BR1 tagged=BR1 [find vlan-ids=10]
Now the vlan is functionable, but when I export and check the configuration file. I can't see the above command in it.
Below is the configuration of my switch.
# feb/15/2021 19:26:09 by RouterOS 6.48.1
# software id = 801C-59LB
#
# model = CRS328-24P-4S+
# serial number = D7620CF6AE89
/interface bridge
add name=bridge1 protocol-mode=none vlan-filtering=yes
/interface vlan
add interface=bridge1 name=VLAN10 vlan-id=10
add interface=bridge1 name=VLAN30 vlan-id=30
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
set default as=102 router-id=2.2.2.2
/interface bridge port
add bridge=bridge1 interface=ether1 pvid=10
add bridge=bridge1 interface=ether2 pvid=10
add bridge=bridge1 interface=ether19 pvid=30
add bridge=bridge1 interface=ether20 pvid=30
add bridge=bridge1 interface=ether21 pvid=30
add bridge=bridge1 interface=ether22 pvid=30
add bridge=bridge1 interface=ether23 pvid=30
add bridge=bridge1 interface=ether24 pvid=30
add bridge=bridge1 interface=ether3 pvid=10
add bridge=bridge1 interface=ether4 pvid=10
/interface bridge vlan
add bridge=bridge1 tagged=bridge1 untagged=ether1,ether2,ether3 vlan-ids=10
add bridge=bridge1 tagged=bridge1 untagged=\
ether19,ether20,ether21,ether22,ether23,ether24 vlan-ids=30
/ip address
add address=192.168.0.2/30 interface=sfp-sfpplus1 network=192.168.0.0
add address=192.168.1.254/24 interface=VLAN10 network=192.168.1.0
add address=192.168.3.254/24 interface=VLAN30 network=192.168.3.0
/ip dhcp-relay
add dhcp-server=192.168.0.1 disabled=no interface=VLAN30 local-address=\
192.168.3.254 name=relay1
add dhcp-server=192.168.0.1 disabled=no interface=VLAN10 local-address=\
192.168.1.254 name=relay2
/routing bgp network
add network=192.168.1.0/24
add network=192.168.2.0/24
add network=192.168.3.0/24
/routing bgp peer
add name="peer to Router" remote-address=192.168.0.1 remote-as=101
/system clock
set time-zone-name=Asia/Macau
/system identity
set name="Core Switch"
/system ntp client
set enabled=yes primary-ntp=192.168.0.1 secondary-ntp=192.168.0.1
/system routerboard settings
set boot-os=router-os
/system swos
set address-acquisition-mode=static allow-from-ports="p1,p2,p3,p4,p5,p6,p7,p8,\
p9,p10,p11,p12,p13,p14,p15,p16,p17,p18,p19,p20,p21,p22,p23,p24,p25,p26,p27\
,p28" identity=Switch static-ip-address=192.168.1.251