There are L2
ports, which are bridged together to single L2 (ethernet) domain. All member ports have to use same max MTU size (not to overrun some interface). Bridge switches ethernet frames between member ports according to MAC table.
There are L3
interfaces which carry IP (or IPv6) addresses. Router routes IP packets between interfaces according to routing table(s). Interfaces can have different MTUs set, router will fragment packets if needed (and permitted).
A twist: in ROS bridge has twin personalities: 1) something like a switch (explained above) and 2)
interface which allows ROS to interact with bridged network. Interface gets created implicitly with creation of bridge personality #1.
What you did was to mix ports and interfaces. Each port/interface can only be used in one personality, either as port or as interface. You bridged SFP+1 and SFP+12 which, according to network topology, should not be bridged/switched, but rather routed. You bridged SFP+12
port and kept using it as
interface.
You have to decide whether to add SFP+1 to bridge or not. You can, but you'll have to sacrifice one VLAN ID for that. Example of fully bridged setup (except for management interface):
/interface ethernet
set [ find default-name=ether1 ] name=MGMT
/interface bridge
add name=bridge vlan-filtering=yes
/interface bridge port
# upstream port will be untagged (access) port of VLAN ID 42
add bridge=bridge pvid=42 ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged interface=sfp-sfpplus1
# the rest of SFP+ ports are brdiged together, all tagged
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus2 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus3 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus4 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus5 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus6 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus7 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus8 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus9 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus10 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus11 disabled=yes
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus12
/interface bridge vlan
add bridge=bridge tagged=bridge vlan-ids=42 # sfp-sfpplus1 gets added as untagged automatically due to pvid setting above
add bridge=bridge tagged=bridge,sfp-sfpplus12 vlan-ids=2611
add bridge=bridge tagged=bridge,sfp-sfpplus12 vlan-ids=2612
add bridge=bridge tagged=bridge,sfp-sfpplus12 vlan-ids=2613
/interface vlan
add name=WAN interface=bridge vlan-id=42
add name=VLAN2611 interface=bridge vlan-id=2611
add name=VLAN2612 interface=bridge vlan-id=2612
add name=VLAN2613 interface=bridge vlan-id=2613
/ip address
add address=10.13.2.10/24 interface=WAN
add interface=VLAN2611 address=172.26.11.1/24
add interface=VLAN2612 address=172.26.12.1/24
add interface=VLAN2613 address=172.26.13.1/24
Properties
frame-types and
ingress-filtering are about port security.
The example above uses VLAN ID 42 for upstream and is internal to CCR only (but you can extend it through other ports if you want to). SFP+ ports 2-11 are disabled. If you need to connect something to e.g. SFP+ port 10, just enable it as bridge member port and will become active. After that you have to adjust VLAN memberships. E.g. if you want to pass VLAN ID 2612 (but not the rest) through SFP+ port 10, you would execute the following command:
/interface bridge vlan
set [ find vlan-ids=2612 ] tagged=bridge,sfp-sfpplus10,sfp-sfpplus12
(be careful to enumerate all tagged member ports, it is not possible to simply add another port without knowing previous list of member ports). This is exactly the reason not to use "wildcard" VLAN membership setup: a VLAN ID can only be used once in this configuration section. If it's already used (e.g. as part of range), adding another config line will fail.