I'm using IPv6 with 750/750 Mbps Internet connection and IPv6 provided by my ISP on a hEX S. My WAN is being connected using a SFP ONT and I notice a very weird behavior in my speed tests.
If I disable IPv6 and do the speed tests, I can get very close to my nominal speeds, however, as soon as I enable IPv6 to my clients, my speed plummets to half of what I get using IPv4.
Checking the CPU usage, I can see CPU0 and CPU1 averaging 96 and 65 % while CPU2 and CPU3 are 2% on Download. During upload I can see CPU1 at 96% and CPU0 at 65% with the speeds around 300 Mbps in both Upload and Download.
While using IPv4, I can see a more uniform usage in the CPU Cores with CPU0 at 80%, CPU1 a 40%, CPU2 at 40% and CPU3 at 18% on upload test and CPU0 at 80% and the rest of the cores around 9% in the Download test. In both cases I'm able to get close to my ISP speed.
My IPv6 firewall rules are simple with 14 rules:
Code: Select all
/ipv6 firewall filter
add action=accept chain=input comment="Allow established connections" connection-state=established
add action=accept chain=input comment="Allow related connections" connection-state=related
add action=accept chain=input comment="Allow ICMP" protocol=icmpv6
add action=reject chain=input comment="Reject invalid packets" connection-state=invalid
add action=accept chain=input comment="Allow local network" in-interface=bridge
add action=reject chain=input comment="Reject TCP connections by default" protocol=tcp reject-with=tcp-reset
add action=reject chain=input comment="Reject other protocols by default" reject-with=icmp-admin-prohibited
add action=accept chain=forward comment="Allow established connections" connection-state=established
add action=accept chain=forward comment="Allow related connections" connection-state=related
add action=accept chain=forward comment="Allow ICMP" protocol=icmpv6
add action=reject chain=forward comment="Reject invalid packets" connection-state=invalid
add action=accept chain=forward comment="Allow any to internet" out-interface=sfp1
add action=reject chain=forward comment="Reject TCP connections by default" protocol=tcp reject-with=tcp-reset
add action=reject chain=forward comment="Reject other protocols by default" reject-with=icmp-admin-prohibited
Is some one getting a similar behavior with beta4 on other devices as well or this is a hardware limitation?
Thank you!